Unable to finish installer [Linux Mint 201303]

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

Unable to finish installer [Linux Mint 201303]

Postby tslater2006 on Sun Mar 24, 2013 8:39 am

Morning everyone,

I just recently 'discovered' Linux Mint from a friend of mine and I'm trying to give it a shot. Due to my PC Setup (a 60GB SSD, and a 1TB HDD) I would like to use the Custom install where I mount my partitions manually. I have made partitions for /, /boot, /home, /usr. I also have another for swap space. I mount the partitions using mount /dev/sda1 /target... mount /dev/sda2 /target/boot... etc.

Once they're mounted I click "Forward" on the installer, it asks where to install GRUB, I'm not really sure what to pick here but I select /dev/sda since that's the drive / and /boot are stored on. It then continues to install all of the files and I've verified it went onto the different drives as I wanted.

Next I need to make the fstab, I use sudo nano /target/etc/fstab... i put my UUIDs in and where they should mount to on boot and save. the issue i'm finding is that the "Forward" button is still greyed out and I cannot continue to finish the install. The installer stops at the "Installation is paused" section where the fstab needs to be made, and you can chroot to install other packages as needed. Is there some other condition the installer is looking for that I am missing? Any help or clarification would be greatly appreciated!

Also, nice forum you got here :)

EDIT: Not sure if it matters but I'm running the x86 MATE edition's installer. I'm doing this right now in a VirtualBox to ensure I get everything set up the way I want prior to doing it on the real machine which will be running the x64 MATE edition.
tslater2006
Level 1
Level 1
 
Posts: 2
Joined: Sat Mar 23, 2013 10:53 pm

Linux Mint is funded by ads and donations.
 

Re: Unable to finish installer [Linux Mint 201303]

Postby pindar on Sun Mar 24, 2013 5:38 pm

I had the same problem with the x86_64 cinnamon edition - after writing the fstab, all buttons were greyed out. I simply closed the window and rebooted, and the installation seems to have been successful (I'm writing this from within my new install). I had no /etc/hosts file after logging in, this may have been due to the aborted installation. Other than that, most things run smoothly.
pindar
Level 1
Level 1
 
Posts: 10
Joined: Mon Dec 03, 2012 6:19 am

Re: Unable to finish installer [Linux Mint 201303]

Postby tslater2006 on Sun Mar 24, 2013 7:49 pm

Interesting, seemed a bit too risky for me so i went with a default install to a single HDD, after install and boot I manually moved /usr /home and /var to the HDD and updated fstab as required, seems to work well :). They should really fix it though.
tslater2006
Level 1
Level 1
 
Posts: 2
Joined: Sat Mar 23, 2013 10:53 pm

Re: Unable to finish installer [Linux Mint 201303]

Postby pindar on Mon Mar 25, 2013 10:14 am

Well, I find it absolutely amazing that they have managed to reproduce the look and feel of Mint on a Debian base and am full of admiration for the devs - but there are still a few rough edges, I would say that LMDE is still in beta (I also had to work around the bug that the installer and partitioning tool asked for a password and neither sudo nor root worked).
pindar
Level 1
Level 1
 
Posts: 10
Joined: Mon Dec 03, 2012 6:19 am

Re: Unable to finish installer [Linux Mint 201303]

Postby rca123 on Wed Mar 27, 2013 10:38 am

I had the same problem. There was no way to continue with the installation on the 32-bit Cinnamon version. I manually specified and mounted partitions. I created /etc/fstab but there was no way to make the installer finish since everything was greyed out. I ended up trying to set up grub myself but could never get it working. I tried grub-install and dpkg-reconfigure grub-pc. Nothing. No /boot/grub/grub.cfg was ever generated no matter what I tried. I wish grub 1 was still around... I could mostly write those config files from memory.
rca123
Level 1
Level 1
 
Posts: 2
Joined: Wed Nov 09, 2011 11:47 am

Re: Unable to finish installer [Linux Mint 201303]

Postby MrHippo on Sat Apr 06, 2013 9:53 pm

You can fix the Forward button on the installer by doing the following:

Type into a console:
Code: Select all
gksudo gedit /usr/lib/live-installer/front-end/gtk_interface.py

Scroll down to line 1767 and add the following new line after it:
Code: Select all
                    self.wTree.get_widget("button_next").set_sensitive(True)

Python uses whitespace to denote blocks of code so you need to get that right. I think it is easiest to copy and paste the whole of line 1765 and change ".show()" to ".set_sensitive(True)". That way you get the same spacing before the line.

After you save the file you can run the installer again and the Forward button will be enabled after you close the dialog box. It seems to just do localization stuff after you press Forward so I'm not sure how critical it is for the install anyway
MrHippo
Level 1
Level 1
 
Posts: 1
Joined: Sat Apr 06, 2013 9:37 pm

Re: Unable to finish installer [Linux Mint 201303]

Postby vajra on Wed Apr 10, 2013 7:34 am

I tried just rebooting & grub failed so now i'll try again editing the gtk_interface.py file

unfortunate error.
vajra
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 10, 2009 8:41 am

Re: Unable to finish installer [Linux Mint 201303]

Postby vajra on Wed Apr 10, 2013 9:35 am

MrHippo wrote:Type into a console:
Code: Select all
gksudo gedit /usr/lib/live-installer/front-end/gtk_interface.py


The path is incorrect & gedit isn't available so I recommend...
Code: Select all
sudo pluma /usr/lib/live-installer/frontend/gtk_interface.py

That worked but i still get the Grub error so it must be another issue.
Code: Select all
error: disk xxxx not found

Anyone know about that?
vajra
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 10, 2009 8:41 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 0 guests