Wired internet not working..

Questions about cabled networking
Forum rules
Before you post please read this

Wired internet not working..

Postby rajat051984 on Sun Mar 17, 2013 1:35 am

I just installed Linux Mint 14 Cinnamon 32 bit on my laptop. The installation was done from Windows7.I plan to run both the OS. I cannot get the internet to work at all through on Linux but works fine on Windows 7.
The wired connection asks for userid and password validation. I provide the the proper ones as I do for Windows7, but it never gets connected in Linux.

Noted below are the results of system commands, which spells the details of PC.

$ ifconfig
rajat@linuxmint-rajat ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr e8:9a:8f:fd:fb:50
inet6 addr: fe80::ea9a:8fff:fefd:fb50/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1801 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:110880 (110.8 KB) TX bytes:3586 (3.5 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2864 (2.8 KB) TX bytes:2864 (2.8 KB)

$ lspci
rajat@linuxmint-rajat ~ $ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

rajat@linuxmint-rajat ~ $ inxi
CPU~Dual core Intel Core i3 CPU M 370 (-HT-MCP-) clocked at Min:933.000Mhz Max:2399.000Mhz Kernel~3.5.0-17-generic i686 Up~5 min Mem~220.6/3833.0MB HDD~500.1GB(57.4% used) Procs~161 Client~Shell inxi~1.8.4



Have not made any changes to any of the system files. All are default state.
I tried some commands after going through other relevant topics in the forums. Depicting the results below..

*********************************************************
rajat@linuxmint-rajat ~ $ sudo ipconfig eth0 down
[sudo] password for rajat:
sudo: ipconfig: command not found
*************************************************************
rajat@linuxmint-rajat ~ $ sudo aptitude reinstall network-manager
The following packages will be REINSTALLED:
network-manager
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 90 not upgraded.
Need to get 561 kB of archives. After unpacking 0 B will be used.
Err http://archive.ubuntu.com/ubuntu/ quantal/main network-manager i386 0.9.6.0-0ubuntu7
Could not resolve 'archive.ubuntu.com'
0% [Working]E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/m ... 7_i386.deb: Could not resolve 'archive.ubuntu.com'
E: Internal Error, No file name for network-manager:i386
*************************************************************
Kindly help!!

Regards,
Rajat
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Linux Mint is funded by ads and donations.
 

Re: Wired internet not working..

Postby BrowserXL on Sun Mar 17, 2013 1:57 am

Are you working in an ip6 only environment? Your ifconfig lack an ip4 address.

This is how mine looks:
browserxl@BrowserXL-NB ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr e8:9a:8f:2b:d0:30
inet addr:192.168.2.101 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::ea9a:8fff:fe2b:d030/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8120 errors:0 dropped:0 overruns:0 frame:0
TX packets:6799 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:9014305 (9.0 MB) TX bytes:727843 (727.8 KB)


I am running a dual stack config as you can see. It has an ip4 and an ip6 address. If your gateway only speaks ip4 then this is the problem ... your ip4 stack doesn't come up.
I would switch to Windows to check how it connects to the internet. If it uses an ip4 gateway we have to come up with a solution how to fix your ip stack.
Cigarettes are a lot like hamsters ... harmless until you put one in your mouth and light it on fire.
User avatar
BrowserXL
Level 1
Level 1
 
Posts: 31
Joined: Wed Mar 13, 2013 7:50 am
Location: Northern Germany

Re: Wired internet not working..

Postby rajat051984 on Fri Mar 22, 2013 12:09 pm

Thanks for your reply!!
I connected to internet on windows and can see it is IPV4 conectivity.

Can you kindly guide as to how to activate IPV4 connectivity in mint?
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Re: Wired internet not working..

Postby rajat051984 on Sun Mar 31, 2013 11:42 am

Can somebody kindly reply to this post? My Internet issue still persists!! :(
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Re: Wired internet not working..

Postby AlbertP on Sun Mar 31, 2013 12:11 pm

I think it's rather something to do with the user/password validation. Is this a so-called PPPoE connection perhaps?

It doesn't have an IP address assigned at all, it's not a IPv6 vs. IPv4 problem. The mentioned inet6 is a "fe80" local address which is always displayed if no other IPv6 connection is available.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wired internet not working..

Postby rajat051984 on Mon Apr 01, 2013 3:16 pm

Hi Albert,

I think you are right . I checked the properties of my broadband connection and below are the details -

Device Name - WAN Miniport(PPOE)
Device Type - PPPoE
Authentication - PAP
PPP multilink framing - off

However I have tried the authentication procedure multiple times .. but it never worked out. Let me know if I can check something else..

Should I try a older version of Mint e.g. 12?

Regards,
Rajat
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Re: Wired internet not working..

Postby AlbertP on Mon Apr 01, 2013 4:13 pm

You can run this in terminal to configure a PPPoE connection:
Code: Select all
sudo pppoeconf
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wired internet not working..

Postby rajat051984 on Sat Apr 06, 2013 4:44 pm

I tried that command .. gave the information it asked for like user id and password for Internet provider.. but still it is not connecting.
It has new status for my wired connection . "unmanaged"!! :evil:

And every other time(and exactly every other time) I start Linux mint, instead of going to Mouse Activated Interface, it goes unix prompt and asks for password verification though i have kept none for mint login.
Then I provide my windows credentials which I provided during installation of mint from windows, it accepts it and stays on the unix prompt. I don't know how to come out from that Unix prompt.

I believe it is time to give up !! :(

I want to run Linux only as a backup to my windows 7 and have very simple requirements -

1) installable from windows
2) should be able to access files kept in windows partitions from Linux(had bad experience with Ubuntu in this respect)
3) should be able to connect to wired Internet easily(mint 14 seems terrible in this aspect :( )

Can somebody suggest me some Linux distributions which fulfill the above requirements ??

Regards,
Rajat
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Re: Wired internet not working..

Postby rajat051984 on Thu Apr 11, 2013 1:31 pm

somebody, kindly please advise !! :(
rajat051984
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 17, 2013 12:42 am

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 2 guests

cron