Need help fixing "Failed to start X server" error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Need help fixing "Failed to start X server" error

Postby primordial27 on Wed Apr 10, 2013 7:47 am

I got the "Failed to start X server" error when I boot into Linux and these are the errors that detail it:
http://imgur.com/a/w0GuF.

I tried using the 'startx' command and this error popped out:

Code: Select all
    xauth: file /home/mark/.Xauthority does not exist
   
   
    X.Org X Server 1.11.3
   
    Release Date: 2011-12-16
   
    X Protocol Version 11, Revision 0
   
    Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
   
    Current Operating System: Linux mark-A6R 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686
   
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=ccd9563e-13ce-4e89-8e20-e172eba844e2 ro quiet splash vt.handoff=7
   
    Build Date: 04 April 2012 11:58:38PM
   
    xorg-server 2:1.11.4-0ubuntu10 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.24.4
   
       Before Reporting problems, check http:///wiki.x.org
       to make sure that you have the latest version.
   
    Markers: (--) probed, (**) from config file, (==)default setting,
           (WW) Warning, (EE) error, (NI) not implemented, (??) Unknown.
   
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 9 03:01:19 2013
   
    (==) Using config file: "/etc/X11/xorg.conf"
   
    (==) Using system config directry "/usr/share/X11/xorg.conf.d"
   
    vesa: Ignoring device with a bound kernel driver
   
    (EE) Screen(s) found, but none have a usable configuration.
   
    Fatal server error:
   
    no screens found
   
    Please Consult the The X.Org Foundation Support
          at http:/wiki.x.org
          for help.
   
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
   
       ddxSigGiveUp: Closing log
   
    Server terminated with error (1). Closing the log file.
   
    xinit: giving up
   
    xinit: unable to connect to X server: no such file or directory
   
    xinit: server error


One of the comments of my post from Reddit suggest that it was trying to install a generic VESA driver, and that I have to install a proprietary one.

If that's the solution, How can I download and install a proprietary driver for my laptop?

I am installing it on an ASUS A6R laptop.

Specs:

- ATI Radeon Xpress 200M (aka Radeon Xpress 1150)
- Intel Celeron M Processor (1.70 GHZ)
- 3 GB RAM
- 160 GB Hard Drive
primordial27
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 07, 2013 4:17 am

Linux Mint is funded by ads and donations.
 

Re: Need help fixing "Failed to start X server" error

Postby primordial27 on Fri Apr 12, 2013 6:21 am

Hello, guys. I managed to get to the desktop properly by following this post. viewtopic.php?f=46&t=122257

But If I don't boot it from the GRUB, it still brings me back to the terminal view.

However, the drivers for my graphic card, which is the ATI Radeon Xpress 200M (aka Radeon Xpress 1150), is not available in the "Additional Drivers" option which the link above is suggesting me to find. Either my graphic card doesn't need the 'additional drivers' or it simply doesn't exist anymore for my old graphics card.

I'm trying to check if there is an available fglrx driver for my using "fglrxinfo" command, but the output says "fglrxinfo : command not found". So I'm assuming there isn't any fglrx driver installed in this laptop. Any way to fix this?
primordial27
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 07, 2013 4:17 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 16 guests