[Solved] Cinnamon not showing after logging on

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

[Solved] Cinnamon not showing after logging on

Postby puddlejumper on Fri Apr 12, 2013 11:09 am

As the subject would suggest, the task-bar and window headers do not appear after I log in. The desktop icons show, and some of the hot-keys work (such as opening a terminal or ctrl+alt+del to bring up the log out option) but some don't (such as alt+f2 for the run dialog). No error message or anything, just gone. The problem started recently after I updated, although I wasn't paying attention at the time to which packages were affected. The gnome session works, but manually selecting Cinnamon before logging in doesn't. I hadn't touched any configuration files recently before the problem occurred.
Last edited by puddlejumper on Sun May 19, 2013 2:55 pm, edited 1 time in total.
puddlejumper
Level 1
Level 1
 
Posts: 4
Joined: Fri Apr 12, 2013 8:41 am

Linux Mint is funded by ads and donations.
 

Re: Cinnamon not showing after logging on

Postby odu dan on Sun Apr 14, 2013 3:47 am

puddlejumper wrote:As the subject would suggest, the task-bar and window headers do not appear after I log in. The desktop icons show, and some of the hot-keys work (such as opening a terminal or ctrl+alt+del to bring up the log out option) but some don't (such as alt+f2 for the run dialog). No error message or anything, just gone. The problem started recently after I updated, although I wasn't paying attention at the time to which packages were affected. The gnome session works, but manually selecting Cinnamon before logging in doesn't. I hadn't touched any configuration files recently before the problem occurred.


I was also encountering this problem. After a fresh install, I prevented this by disabling all updates except for "1" and "2" in Update Manager.

Answer found here: https://github.com/linuxmint/Cinnamon/i ... t-16057012
odu dan
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 14, 2013 3:39 am

Re: Cinnamon not showing after logging on

Postby d00med on Mon Apr 15, 2013 5:39 pm

odu dan wrote:
puddlejumper wrote:As the subject would suggest, the task-bar and window headers do not appear after I log in. The desktop icons show, and some of the hot-keys work (such as opening a terminal or ctrl+alt+del to bring up the log out option) but some don't (such as alt+f2 for the run dialog). No error message or anything, just gone. The problem started recently after I updated, although I wasn't paying attention at the time to which packages were affected. The gnome session works, but manually selecting Cinnamon before logging in doesn't. I hadn't touched any configuration files recently before the problem occurred.


I was also encountering this problem. After a fresh install, I prevented this by disabling all updates except for "1" and "2" in Update Manager.

Answer found here: https://github.com/linuxmint/Cinnamon/i ... t-16057012


The fix didn't work here.I'm using the Cinnamon nightlies and here's the output of cinnamon --replace
Code: Select all
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
    JS ERROR: !!!   Exception was: Error: No JS module 'lookingGlassDBus' found in search path
    JS ERROR: !!!     message = '"No JS module 'lookingGlassDBus' found in search path"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/main.js"'
    JS ERROR: !!!     lineNumber = '35'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/main.js:35
"'
    JS ERROR: !!!   Exception was: Error: No JS module 'lookingGlassDBus' found in search path
    JS ERROR: !!!     message = '"No JS module 'lookingGlassDBus' found in search path"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/main.js"'
    JS ERROR: !!!     lineNumber = '35'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/main.js:35
"'
Window manager warning: Log level 32: Execution of main.js threw exception: Error: No JS module 'lookingGlassDBus' found in search path

Same error before and after I tried that mesa PPA.
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Cinnamon not showing after logging on

Postby hypnotoad on Mon Apr 15, 2013 7:24 pm

I had a similar issue after updating from a nightly build for ubuntu 12.10. It appears the file lookingGlassDBus.js was removed from the build. I copied the file from the github repo and placed it in /usr/share/cinnamon/js/ui and restarted. This fixed the issue.
hypnotoad
Level 1
Level 1
 
Posts: 1
Joined: Mon Apr 15, 2013 7:21 pm

Re: Cinnamon not showing after logging on

Postby d00med on Mon Apr 15, 2013 7:50 pm

hypnotoad wrote:I had a similar issue after updating from a nightly build for ubuntu 12.10. It appears the file lookingGlassDBus.js was removed from the build. I copied the file from the github repo and placed it in /usr/share/cinnamon/js/ui and restarted. This fixed the issue.


That worked. Thanks.

Github link for the lazy
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Cinnamon not showing after logging on

Postby puddlejumper on Wed May 08, 2013 6:33 pm

Didn't work.

cinnamon --replace for me:
Code: Select all
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Segmentation fault


and after exporting LIBGL_DEBUG=verbose:
Code: Select all
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: dlopen /usr/lib/i386-linux-gnu/dri/swrast_dri.so failed (/usr/lib/i386-linux-gnu/dri/swrast_dri.so: wrong ELF class: ELFCLASS32)
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
      JS LOG: About to start Cinnamon
Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)
      JS LOG: Cinnamon started at Wed May 08 2013 15:32:34 GMT-0700 (PDT)
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
Segmentation fault
puddlejumper
Level 1
Level 1
 
Posts: 4
Joined: Fri Apr 12, 2013 8:41 am

Re: Cinnamon not showing after logging on

Postby Raen on Sun May 12, 2013 9:15 pm

Same subject as http://forums.linuxmint.com/viewtopic.php?f=208&t=127575 and http://forums.linuxmint.com/viewtopic.php?f=208&t=127018

Found out that actual (newer?) level 1 updates don't cause this problem anymore (explained better on the first topic linked above).
Raen
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 03, 2013 5:44 pm

Re: Cinnamon not showing after logging on

Postby puddlejumper on Sun May 19, 2013 2:54 pm

reinstalling ati drivers fixed the problem as described here:
http://forums.linuxmint.com/viewtopic.php?f=208&t=127018

Simply removing (had to force) and reinstalling (had to force again) my AMD graphics drivers fixed the problem
puddlejumper
Level 1
Level 1
 
Posts: 4
Joined: Fri Apr 12, 2013 8:41 am

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: Google Adsense [Bot] and 8 guests