Fglrx + Xen = No X

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Fglrx + Xen = No X

Postby Locuust on Mon Apr 08, 2013 1:51 pm

TL:DR: For now I'm going to consider this a driver issue and move on. If anyone plans on using Mint w/Xen in Dom0 I'd advise against buying an AMD 7000 series card as you may experience issues like mine with the proprietary drivers (fglrx). Of course if you have one already then maybe you'll succeed where I failed ;)

I really hesitate to post anything about my problem because I figure I'll get dismissive answers due to my unusual setup. However, I'm at my wits end after searching for a solution for a week so I'd appreciate any help/input/direction.

Disclaimer: Sorry if I sound mad or my tone is bad. It's merely frustration and it's not meant to be directed at anyone/thing. I just wish this worked.

Summary:
My goal, as the title suggests, is to run the proprietary fglrx driver on Mint 14 in a Xen Dom0. Everything boots fine loading Mint 14 w/o Xen. Booting w/Xen only works if I pass the 'text' option to the kernel via grub (meaning no X). When attempting to load into X windows from xen I get a black screen (no cursor, no login sound, etc) and when comparing xorg.0.log's it seems the xen version just ends at the point where it would normally print details about the video card.

The first response to this sort of problem, as I've observed elsewhere, is "load the open source driver". I know that's an option and I've actually confirmed that it works (only with Mate). So what's the problem you ask? Support for my video cards seems to be a work in progress according to the xorg radeon feature matrix. 3D support is sketchy and there is no support for HDMI audio if I decide to use it. There is power management, my main concern, but it's said to introduce visual defects (dynPM). In an ideal world I'd be using the open source driver. Now that I got that out of the way some details.

Software:
Mint 14 Cinnamon - I've since installed the Linux-meta-mate package due to another issue and have switched my default session to Mate. I'll probably back everything up and do a fresh install of Mate soon.
Xen 4.1.3 (xen-system-amd64)
fglrx (Amd's official version 13.1 at the moment. I first tried the packages available to mint.)
Custom Kernel built from ubuntu git (branch 3.5.0-17.28)- Now before you point fingers I can confirm that this issue is the same regardless of which kernel I load - stock Mint or my custom. I built the custom because I needed kernel options not turned on in the Mint version. I'm happy to test things on the stock kernel. Just throwing that out there because you can see as much in my Xorg.0.log below.

inxi -SGx (taken w/o Xen):
Code: Select all
System:    Host: dvx Kernel: 3.5.5-dom0+ x86_64 (64 bit, gcc: 4.7.2) Desktop: N/A Distro: Linux Mint 14 Nadia
Graphics:  Card-1: Advanced Micro Devices [AMD] nee ATI Cape Verde PRO [Radeon HD 7700 Series] bus-ID: 01:00.0
           Card-2: Advanced Micro Devices [AMD] nee ATI PITCAIRN [Radeon HD 7800] bus-ID: 02:00.0
           X.Org: 1.13.0 driver: fglrx Resolution: 1680x1050@60.0hz
           GLX Renderer: AMD Radeon HD 7700 Series GLX Version: 4.2.12002 - CPC 9.012 Direct Rendering: Yes


/etc/X11/xorg.conf (created with aticonfig):
Code: Select all
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Normal Xorg.0.log (shortened to the point where two diverge):
Code: Select all
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    14.319] X Protocol Version 11, Revision 0
[    14.319] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[    14.319] Current Operating System: Linux dvx 3.5.5-dom0+ #1 SMP Thu Apr 4 20:14:51 MST 2013 x86_64
[    14.319] Kernel command line: BOOT_IMAGE=/vmlinuz-3.5.5-dom0+ root=/dev/mapper/xen-root ro quiet splash vt.handoff=7
[    14.319] Build Date: 27 November 2012  07:44:35AM
[    14.319] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support)
[    14.319] Current version of pixman: 0.26.0
[    14.319]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    14.319] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.319] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  8 07:38:24 2013
[    14.320] (==) Using config file: "/etc/X11/xorg.conf"
[    14.320] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    14.331] (==) ServerLayout "aticonfig Layout"
[    14.331] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    14.331] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    14.332] (**) |   |-->Device "aticonfig-Device[0]-0"
[    14.332] (==) Automatically adding devices
[    14.332] (==) Automatically enabling devices
[    14.332] (==) Automatically adding GPU devices
[    14.336] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    14.336]    Entry deleted from font path.
[    14.336] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    14.336]    Entry deleted from font path.
[    14.336] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    14.336]    Entry deleted from font path.
[    14.347] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    14.347]    Entry deleted from font path.
[    14.347] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    14.347]    Entry deleted from font path.
[    14.347] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    14.347]    Entry deleted from font path.
[    14.347] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    14.347] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    14.347] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    14.347] (II) Loader magic: 0x7f4ae07cdc40
[    14.347] (II) Module ABI versions:
[    14.347]    X.Org ANSI C Emulation: 0.4
[    14.347]    X.Org Video Driver: 13.0
[    14.347]    X.Org XInput driver : 18.0
[    14.347]    X.Org Server Extension : 7.0
[    14.351] (--) PCI:*(0:1:0:0) 1002:683f:1682:3242 rev 0, Mem @ 0xc0000000/268435456, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    14.351] (--) PCI: (0:2:0:0) 1002:6818:1682:3250 rev 0, Mem @ 0xb0000000/268435456, 0xfe900000/262144, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[    14.351] (II) Open ACPI successful (/var/run/acpid.socket)
[    14.351] Initializing built-in extension Generic Event Extension
[    14.351] Initializing built-in extension SHAPE
[    14.351] Initializing built-in extension MIT-SHM
[    14.351] Initializing built-in extension XInputExtension
[    14.351] Initializing built-in extension XTEST
[    14.351] Initializing built-in extension BIG-REQUESTS
[    14.351] Initializing built-in extension SYNC
[    14.351] Initializing built-in extension XKEYBOARD
[    14.351] Initializing built-in extension XC-MISC
[    14.352] Initializing built-in extension SECURITY
[    14.352] Initializing built-in extension XINERAMA
[    14.352] Initializing built-in extension XFIXES
[    14.352] Initializing built-in extension RENDER
[    14.352] Initializing built-in extension RANDR
[    14.352] Initializing built-in extension COMPOSITE
[    14.352] Initializing built-in extension DAMAGE
[    14.352] Initializing built-in extension MIT-SCREEN-SAVER
[    14.352] Initializing built-in extension DOUBLE-BUFFER
[    14.352] Initializing built-in extension RECORD
[    14.352] Initializing built-in extension DPMS
[    14.352] Initializing built-in extension X-Resource
[    14.352] Initializing built-in extension XVideo
[    14.352] Initializing built-in extension XVideo-MotionCompensation
[    14.352] Initializing built-in extension XFree86-VidModeExtension
[    14.352] Initializing built-in extension XFree86-DGA
[    14.352] Initializing built-in extension XFree86-DRI
[    14.352] Initializing built-in extension DRI2
[    14.352] (II) "glx" will be loaded by default.
[    14.352] (II) LoadModule: "glx"
[    14.364] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
[    14.364] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    14.364]    compiled for 6.9.0, module version = 1.0.0
[    14.365] Loading extension GLX
[    14.365] (II) LoadModule: "fglrx"
[    14.365] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[    14.388] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    14.388]    compiled for 1.4.99.906, module version = 9.1.11
[    14.388]    Module class: X.Org Video Driver
[    14.388] (II) Loading sub module "fglrxdrm"
[    14.388] (II) LoadModule: "fglrxdrm"
[    14.388] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    14.388] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    14.388]    compiled for 1.4.99.906, module version = 9.1.11
[    14.388] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[    14.388] (II) AMD Proprietary Linux Driver Release Identifier: 9.012                               
[    14.388] (II) AMD Proprietary Linux Driver Build Date: Dec 19 2012 14:41:10
[    14.388] (++) using VT number 8
[    14.391] (WW) Falling back to old probe method for fglrx
[    14.407] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    14.411] ukiDynamicMajor: found major device number 249
[    14.411] ukiDynamicMajor: found major device number 249
[    14.411] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    14.411] ukiOpenDevice: node name is /dev/ati/card0
[    14.411] ukiOpenDevice: open result is 10, (OK)
[    14.468] ukiOpenByBusid: ukiOpenMinor returns 10
[    14.468] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:0) found
[    14.470] (--) Chipset Supported AMD Graphics Processor (0x683F) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:3:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:9:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:3) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    14.470] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
[    14.470] (**) ChipID override: 0x6818
[    14.470] (**) Chipset Supported AMD Graphics Processor (0x6818) found
[    14.470] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    14.470] (II) AMD Video driver is signed
[    14.470] (II) fglrx(0): pEnt->device->identifier=0x7f4ae25bac50
[    14.470] (II) pEnt->device->identifier=(nil)
[    14.471] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[    14.471] (II) Loading sub module "vgahw"
[    14.471] (II) LoadModule: "vgahw"
[    14.472] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    14.472] (II) Module vgahw: vendor="X.Org Foundation"
[    14.472]    compiled for 1.13.0, module version = 0.1.0
[    14.472]    ABI class: X.Org Video Driver, version 13.0
[    14.472] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    14.472] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    14.472] (==) fglrx(0): Default visual is TrueColor
[    14.472] (**) fglrx(0): Option "DPMS" "true"
[    14.472] (==) fglrx(0): RGB weight 888
[    14.472] (II) fglrx(0): Using 8 bits per RGB
[    14.472] (==) fglrx(0): Buffer Tiling is ON
[    14.472] (II) Loading sub module "fglrxdrm"
[    14.472] (II) LoadModule: "fglrxdrm"
[    14.473] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    14.473] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    14.473]    compiled for 1.4.99.906, module version = 9.1.11
[    14.475] ukiDynamicMajor: found major device number 249
[    14.475] ukiDynamicMajor: found major device number 249
[    14.475] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    14.475] ukiOpenDevice: node name is /dev/ati/card0
[    14.475] ukiOpenDevice: open result is 14, (OK)
[    14.475] ukiOpenByBusid: ukiOpenMinor returns 14
[    14.475] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    14.475] ukiDynamicMajor: found major device number 249
[    14.475] ukiDynamicMajor: found major device number 249
[    14.475] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[    14.475] ukiOpenDevice: node name is /dev/ati/card0
[    14.475] ukiOpenDevice: open result is 15, (OK)
[    14.475] ukiOpenByBusid: ukiOpenMinor returns 15
[    14.475] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    14.475] ukiOpenDevice: node name is /dev/ati/card1
[    14.750] ukiOpenDevice: open result is 15, (OK)
[    14.750] ukiOpenByBusid: ukiOpenMinor returns 15
[    14.750] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[    14.750] (**) fglrx(0): NoAccel = NO
[    14.750] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[    14.750] (--) fglrx(0): Chipset: "AMD Radeon HD 7700 Series " (Chipset = 0x683f)
[    14.750] (--) fglrx(0): (PciSubVendor = 0x1682, PciSubDevice = 0x3242)
[    14.750] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[    14.750] (--) fglrx(0): Linear framebuffer (phys) at 0xc0000000
[    14.750] (--) fglrx(0): MMIO registers at 0xfea00000
[    14.750] (--) fglrx(0): I/O port at 0x0000e000
[    14.751] (==) fglrx(0): ROM-BIOS at 0x000c0000
[    14.758] (II) fglrx(0): AC Adapter is used
[    14.772] (II) fglrx(0): Primary V_BIOS segment is: 0xc000


Xen Xorg.0.log:
Code: Select all
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    20.039] X Protocol Version 11, Revision 0
[    20.039] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[    20.039] Current Operating System: Linux dvx 3.5.5-dom0+ #1 SMP Thu Apr 4 20:14:51 MST 2013 x86_64
[    20.039] Kernel command line: placeholder root=/dev/mapper/xen-root ro nomodeset quiet splash xen-pciback.hide=(02:00.0)(02:00.1) radeon.blacklist=1
[    20.040] Build Date: 27 November 2012  07:44:35AM
[    20.040] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support)
[    20.040] Current version of pixman: 0.26.0
[    20.040]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    20.040] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    20.040] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  8 07:36:37 2013
[    20.040] (==) Using config file: "/etc/X11/xorg.conf"
[    20.040] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    20.046] (==) ServerLayout "aticonfig Layout"
[    20.046] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    20.046] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    20.046] (**) |   |-->Device "aticonfig-Device[0]-0"
[    20.046] (==) Automatically adding devices
[    20.046] (==) Automatically enabling devices
[    20.046] (==) Automatically adding GPU devices
[    20.059] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    20.059]    Entry deleted from font path.
[    20.059] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    20.059]    Entry deleted from font path.
[    20.059] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    20.059]    Entry deleted from font path.
[    20.070] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    20.070]    Entry deleted from font path.
[    20.070] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    20.070]    Entry deleted from font path.
[    20.070] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    20.070]    Entry deleted from font path.
[    20.070] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    20.070] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    20.070] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    20.070] (II) Loader magic: 0x7f88687d5c40
[    20.070] (II) Module ABI versions:
[    20.070]    X.Org ANSI C Emulation: 0.4
[    20.070]    X.Org Video Driver: 13.0
[    20.070]    X.Org XInput driver : 18.0
[    20.070]    X.Org Server Extension : 7.0
[    20.073] (--) PCI:*(0:1:0:0) 1002:683f:1682:3242 rev 0, Mem @ 0xc0000000/268435456, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    20.073] (--) PCI: (0:2:0:0) 1002:6818:1682:3250 rev 0, Mem @ 0xb0000000/268435456, 0xfe900000/262144, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[    20.074] (II) Open ACPI successful (/var/run/acpid.socket)
[    20.074] Initializing built-in extension Generic Event Extension
[    20.074] Initializing built-in extension SHAPE
[    20.074] Initializing built-in extension MIT-SHM
[    20.074] Initializing built-in extension XInputExtension
[    20.074] Initializing built-in extension XTEST
[    20.074] Initializing built-in extension BIG-REQUESTS
[    20.074] Initializing built-in extension SYNC
[    20.074] Initializing built-in extension XKEYBOARD
[    20.074] Initializing built-in extension XC-MISC
[    20.074] Initializing built-in extension SECURITY
[    20.074] Initializing built-in extension XINERAMA
[    20.074] Initializing built-in extension XFIXES
[    20.074] Initializing built-in extension RENDER
[    20.074] Initializing built-in extension RANDR
[    20.074] Initializing built-in extension COMPOSITE
[    20.074] Initializing built-in extension DAMAGE
[    20.074] Initializing built-in extension MIT-SCREEN-SAVER
[    20.074] Initializing built-in extension D

Not sure why but the forum gobbled the end of this post when I edited it.
Last edited by Locuust on Wed Apr 10, 2013 1:52 am, edited 3 times in total.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Linux Mint is funded by ads and donations.
 

Re: Fglrx + Xen = No X

Postby powerhouse on Mon Apr 08, 2013 5:54 pm

Hello Locuust,

Please also post your /etc/default/grub file.

On a side note, I do not have a /etc/X11/xorg.conf file at all.

I installed the default package suggested by Linux Mint. Check the following steps to see if you did anything different:

1. Install LM, then Xen.

2. Install the pciback script and edit the grub file to add the iommu etc. entries. Here is an example:
Code: Select all
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:4G"


Create the pciback.conf file. See how-to for all the steps up until part 3, point 9 - do everything except reboot until you are done with the Xen host configuration!

3. Reboot into Xen and install the proprietary fglrx driver (I used the default one, not the latest). You can use:

Code: Select all
ubuntu-drivers list

to have Linux Mint detect the HD 7700 card and list the available drivers.

Here is what I get:
Code: Select all
# ubuntu-drivers list
nvidia-current
fglrx-updates
nvidia-experimental-310
fglrx
nvidia-current-updates
nvidia-experimental-304


Note: I have an AMD card and an Nvidia card, the latter of which I pass to Windows.

For you it should show two options:
fglrx
fglrx-updates

Try the second and if that fails, the first.

4. Edit once more the /etc/default/grub file and blacklist the radeon driver:

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="radeon.blacklist=1"


Note: Usually the fglrx driver should blacklist the radeon driver by placing a file (actually a link) named fglrx.conf into /etc/modprobe.d with the following content:
Code: Select all
# This file was installed by fglrx
# Do not edit this file manually

blacklist radeon
alias fglrx fglrx
alias radeon off
alias lbm-radeon off


However, you may have seen the posts in the how-to that this doesn't always work, so use the grub method. Don't forget to run update-grub after you edit the /etc/default/grub file!

5. Check that your graphics card is detached:

Code: Select all
sudo xm pci-list-assignable-devices


Your PCI devices including the graphics card with the PCI ID 02:00.0 (and 02:00.1 for the audio device) should be listed.

You can also use lspci to list the drivers associated with your graphics cards:

Code: Select all
lspci -v | grep -A 20 -i amd

and look for the "Kernel driver in use: fglrx_pci" entry for your HD 7700, and pciback for the HD 7800.


Here my reasoning:

You may have installed the fglrx driver while running the regular Linux Mint, not the Xen hypervisor. In that case the driver would see 2 graphics cards which may affect the configuration. So when you start Xen it won't work.

Another problem may be the blacklisting of the radeon driver. But I doubt this since you said it works under normal boot (non-Xen).

Finally there could be a problem with the proprietary driver attaching itself to the second graphics card while booting, before the pciback script is able to detach the card. If that is the case, you may need to include the xen-pciback module in the initramfs and run update-initramfs.

To do so, just edit the /etc/initramfs-tools/modules file as follows:
Code: Select all
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
xen-pciback passthrough=1


and run sudo update-initramfs. It will run for a while and produce a new initrd.img... under /boot.

I'm not sure the following will work, but it may be worth a try. Edit the /etc/default/grub file to include:

Code: Select all
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:4G xen-pciback.hide=(02:00.0,02:001,etc.)"


Remark: The above is supposed to work with pciback compiled into the kernel - see http://wiki.xen.org/wiki/Xen_PCI_Passthrough.

Last not least: Read the ATI graphics driver how-tos and forum posts to see if there are some driver-related issues and solutions.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Mon Apr 08, 2013 6:52 pm

powerhouse wrote:Please also post your /etc/default/grub file.


As you can see in my /etc/default/grub I've had fun trying different options (please excuse the mess) -
Code: Select all
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Basic Kernel
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
# Basic Kernel and Recovery
GRUB_CMDLINE_LINUX=""
# Xen Hypervisor (Xen.gz)
GRUB_CMDLINE_XEN_DEFAULT="dom0_max_vcpus=2 dom0_vcpus_pin"
# Xen Hypervisor and Recovery
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:4096M,max:4096M"
# Kernel w/Xen
GRUB_CMDLINE_LINUX_XEN_REPLACE_DEFAULT="quiet splash xen-pciback.hide=(02:00.0)(02:00.1) radeon.blacklist=1"
# Kernel w/Xen and Recovery
GRUB_CMDLINE_LINUX_XEN_REPLACE="nomodeset" #"text"

# Notes: "nomodeset" kernel mode setting (kms), "text" for no X windows, Blacklist Open source radeon.blacklist=1

On a side note, I do not have a /etc/X11/xorg.conf file at all.

I get that it's not absolutely necessary but I created one for sake of being thorough. I've tried it without too.
2. Install the pciback script and edit the grub file to add the iommu etc. entries. Here is an example:
Code: Select all
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:4G"

Create the pciback.conf file. See how-to for all the steps up until part 3, point 9 - do everything except reboot until you are done with the Xen host configuration!


As you can see I've done much the same as you in my xen cmdline. As far as the pciback.conf I've already told you I chose the statically compiled route. If anything I should be removing any trace of pciback to see if it's causing a problem here. But I've already tried that. Sorry, but I think we should concentrate on one problem at a time. Right now I'm focused on getting a solution for fglrx in Dom0. Besides I've already confirmed that pciback works just fine as I've configured it.
3. Reboot into Xen and install the proprietary fglrx driver (I used the default one, not the latest). You can use:
Code: Select all
ubuntu-drivers list

to have Linux Mint detect the HD 7700 card and list the available drivers.
Here is what I get:
Code: Select all
# ubuntu-drivers list
nvidia-current
fglrx-updates
nvidia-experimental-310
fglrx
nvidia-current-updates
nvidia-experimental-304

I've already tried both versions. I only have the latest AMD drivers loaded in the hopes that a patch addressed my problem.
Note: I have an AMD card and an Nvidia card, the latter of which I pass to Windows.
For you it should show two options:
fglrx
fglrx-updates

Try the second and if that fails, the first.

Yup, that's exactly what I did before trying the amd one as a last resort.
4. Edit once more the /etc/default/grub file and blacklist the radeon driver:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="radeon.blacklist=1"

You can see in my original post of my xorg.0.log that I had the radeon blacklisted on my Xen boot.
Note: Usually the fglrx driver should blacklist the radeon driver by placing a file (actually a link) named fglrx.conf into /etc/modprobe.d with the following content:

Yeah, I noticed that when I went to blacklist another module that was giving me problems. I did notice that after doing the grub blacklist that two errors I had been getting went away. One about /dev/fb0 not being found and the other about a DRI device. If I'm not mistaken that refers to a framebuffer and a direct rendering interface. Sadly they weren't the source of my problem as there is no mention of them in my Xen log.
However, you may have seen the posts in the how-to that this doesn't always work, so use the grub method. Don't forget to run update-grub after you edit the /etc/default/grub file!

Many a times I curse at myself for forgetting to do so, but out of habit I hit 'e' before selecting a grub menu item to make sure my changes took place.
5. Check that your graphics card is detached:
Code: Select all
sudo xm pci-list-assignable-devices

Your PCI devices including the graphics card with the PCI ID 02:00.0 (and 02:00.1 for the audio device) should be listed.
You can also use lspci to list the drivers associated with your graphics cards:
Code: Select all
lspci -v | grep -A 20 -i amd

and look for the "Kernel driver in use: fglrx_pci" entry for your HD 7700, and pciback for the HD 7800.

I'm not in Xen right now (don't have X with this driver installed after all) so I can't post my output directly. But I have verified this is the case.
Here my reasoning:
You may have installed the fglrx driver while running the regular Linux Mint, not the Xen hypervisor. In that case the driver would see 2 graphics cards which may affect the configuration. So when you start Xen it won't work.
Another problem may be the blacklisting of the radeon driver. But I doubt this since you said it works under normal boot (non-Xen).

Hmmm. I do believe I tried reinstalling fgrlx while in a Xen terminal and the first time I installed it I was in Dom0. But I'll try uninstalling and reinstalling everything one more time to be sure I'm not mistaken. Is there actually a config file besides xorg.conf that dictates which cards to use? I had assumed this wasn't the case because of the necessity of blacklisting drivers. I just assumed xorg was detecting all available hardware and matching them with all available drivers (well in a first come first serve manner).
Finally there could be a problem with the proprietary driver attaching itself to the second graphics card while booting, before the pciback script is able to detach the card. If that is the case, you may need to include the xen-pciback module in the initramfs and run update-initramfs.
To do so, just edit the /etc/initramfs-tools/modules file as follows:

Well the thought of xorg trying to use the second card had crossed my mind. That's why I disabled pciback at one point to see if it was conflicting with the driver process.
I'm not sure the following will work, but it may be worth a try. Edit the /etc/default/grub file to include:
Code: Select all
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:4G xen-pciback.hide=(02:00.0,02:001,etc.)"

This is how I'm doing pciback. I've compiled the the module into the kernel so that I don't have to worry about the timing of the reservation. It happens as soon as the kernel loads.
Last not least: Read the ATI graphics driver how-tos and forum posts to see if there are some driver-related issues and solutions.

Believe me I've looked. The unnofficial AMD driver wiki seems to have the best howto's. Such as - http://wiki.cchtml.com/index.php/Ubuntu ... st.2Ffglrx Which I'll be using once again to do my reinstall. There are a lot of posts that come close to my situation but the solution still evades me. I'm thinking that the solution is either going to be very very simple and staring me in the face or I've stumbled on to a really unique issue.

Thanks for the reply. I'll try reloading the driver again inside Xen.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby Locuust on Mon Apr 08, 2013 7:38 pm

Update

What I did -
0) Removed pci-back from grub to prove that it's not part of the boot issue.
1) Boot into Xen with the 'text' option to disable X temporarily.
2) Uninstalled the fglrx driver.
3) Reinstalled the Radeon driver (open source).
4) Removed 'text' and 'blacklist' from grub.
5) Rebooted into Xen again.
6) Grabbed a copy of my xorg.0.log just in case and confirmed Open source and X are still happy.
7) Reinstalled Fglrx.
8 ) Blacklisted Radeon again. Btw I've been wondering why everyone is so focused on blacklisting the xorg radeon driver? It would be a simple matter to just remove it. So I'm assuming that there is a reason nobody does? Some shared libraries?
9) Rebooted in to Xen once again and confirmed the issue still exists. Black screen.

Xorg (Xen + Reinstalled fglrx - pciback):
Code: Select all
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    25.485] X Protocol Version 11, Revision 0
[    25.485] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[    25.485] Current Operating System: Linux dvx 3.5.5-dom0+ #1 SMP Thu Apr 4 20:14:51 MST 2013 x86_64
[    25.485] Kernel command line: placeholder root=/dev/mapper/xen-root ro nomodeset quiet splash radeon.blacklist=1
[    25.485] Build Date: 27 November 2012  07:44:35AM
[    25.485] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support)
[    25.485] Current version of pixman: 0.26.0
[    25.485]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    25.485] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.486] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  8 16:20:15 2013
[    25.540] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    25.566] (==) No Layout section.  Using the first Screen section.
[    25.566] (==) No screen section available. Using defaults.
[    25.566] (**) |-->Screen "Default Screen Section" (0)
[    25.566] (**) |   |-->Monitor "<default monitor>"
[    25.567] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    25.567] (==) Automatically adding devices
[    25.567] (==) Automatically enabling devices
[    25.567] (==) Automatically adding GPU devices
[    25.618] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    25.618]    Entry deleted from font path.
[    25.619] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    25.619]    Entry deleted from font path.
[    25.619] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    25.619]    Entry deleted from font path.
[    25.646] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    25.646]    Entry deleted from font path.
[    25.646] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    25.646]    Entry deleted from font path.
[    25.646] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    25.646]    Entry deleted from font path.
[    25.646] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    25.646] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    25.646] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    25.646] (II) Loader magic: 0x7f39030cdc40
[    25.646] (II) Module ABI versions:
[    25.646]    X.Org ANSI C Emulation: 0.4
[    25.646]    X.Org Video Driver: 13.0
[    25.646]    X.Org XInput driver : 18.0
[    25.646]    X.Org Server Extension : 7.0
[    25.653] (--) PCI:*(0:1:0:0) 1002:683f:1682:3242 rev 0, Mem @ 0xc0000000/268435456, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    25.653] (--) PCI: (0:2:0:0) 1002:6818:1682:3250 rev 0, Mem @ 0xb0000000/268435456, 0xfe900000/262144, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[    25.654] (II) Open ACPI successful (/var/run/acpid.socket)
[    25.662] Initializing built-in extension Generic Event Extension
[    25.662] Initializing built-in extension SHAPE
[    25.662] Initializing built-in extension MIT-SHM
[    25.662] Initializing built-in extension XInputExtension
[    25.662] Initializing built-in extension XTEST
[    25.662] Initializing built-in extension BIG-REQUESTS
[    25.662] Initializing built-in extension SYNC
[    25.662] Initializing built-in extension XKEYBOARD
[    25.662] Initializing built-in extension XC-MISC
[    25.662] Initializing built-in extension SECURITY
[    25.662] Initializing built-in extension XINERAMA
[    25.662] Initializing built-in extension XFIXES
[    25.662] Initializing built-in extension RENDER
[    25.662] Initializing built-in extension RANDR
[    25.662] Initializing built-in extension COMPOSITE
[    25.662] Initializing built-in extension DAMAGE
[    25.663] Initializing built-in extension MIT-SCREEN-SAVER
[    25.663] Initializing built-in extension DOUBLE-BUFFER
[    25.663] Initializing built-in extension RECORD
[    25.663] Initializing built-in extension DPMS
[    25.663] Initializing built-in extension X-Resource
[    25.663] Initializing built-in extension XVideo
[    25.663] Initializing built-in extension XVideo-MotionCompensation
[    25.663] Initializing built-in extension XFree86-VidModeExtension
[    25.663] Initializing built-in extension XFree86-DGA
[    25.663] Initializing built-in extension XFree86-DRI
[    25.663] Initializing built-in extension DRI2
[    25.663] (II) LoadModule: "glx"
[    25.773] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
[    25.831] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    25.831]    compiled for 6.9.0, module version = 1.0.0
[    25.832] Loading extension GLX
[    25.832] (==) Matched fglrx as autoconfigured driver 0
[    25.832] (==) Matched ati as autoconfigured driver 1
[    25.832] (==) Matched vesa as autoconfigured driver 2
[    25.832] (==) Matched modesetting as autoconfigured driver 3
[    25.832] (==) Matched fbdev as autoconfigured driver 4
[    25.832] (==) Assigned the driver to the xf86ConfigLayout
[    25.832] (II) LoadModule: "fglrx"
[    25.832] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[    26.108] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    26.108]    compiled for 1.4.99.906, module version = 9.1.11
[    26.108]    Module class: X.Org Video Driver
[    26.109] (II) Loading sub module "fglrxdrm"
[    26.109] (II) LoadModule: "fglrxdrm"
[    26.109] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    26.126] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    26.126]    compiled for 1.4.99.906, module version = 9.1.11
[    26.126] (II) LoadModule: "ati"
[    26.134] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    26.139] (II) Module ati: vendor="X.Org Foundation"
[    26.139]    compiled for 1.13.0, module version = 6.99.99
[    26.139]    Module class: X.Org Video Driver
[    26.139]    ABI class: X.Org Video Driver, version 13.0
[    26.139] (II) LoadModule: "radeon"
[    26.139] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    26.150] (II) Module radeon: vendor="X.Org Foundation"
[    26.150]    compiled for 1.13.0, module version = 6.99.99
[    26.150]    Module class: X.Org Video Driver
[    26.150]    ABI class: X.Org Video Driver, version 13.0
[    26.150] (II) LoadModule: "vesa"
[    26.151] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    26.160] (II) Module vesa: vendor="X.Org Foundation"
[    26.160]    compiled for 1.12.99.902, module version = 2.3.2
[    26.160]    Module class: X.Org Video Driver
[    26.160]    ABI class: X.Org Video Driver, version 13.0
[    26.160] (II) LoadModule: "modesetting"
[    26.160] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    26.165] (II) Module modesetting: vendor="X.Org Foundation"
[    26.166]    compiled for 1.13.0, module version = 0.5.0
[    26.166]    Module class: X.Org Video Driver
[    26.166]    ABI class: X.Org Video Driver, version 13.0
[    26.166] (II) LoadModule: "fbdev"
[    26.166] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    26.167] (II) Module fbdev: vendor="X.Org Foundation"
[    26.167]    compiled for 1.12.99.902, module version = 0.4.3
[    26.167]    Module class: X.Org Video Driver
[    26.167]    ABI class: X.Org Video Driver, version 13.0
[    26.167] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[    26.167] (II) AMD Proprietary Linux Driver Release Identifier: 9.012                               
[    26.167] (II) AMD Proprietary Linux Driver Build Date: Dec 19 2012 14:41:10
[    26.167] (II) RADEON: Driver for ATI Radeon chipsets:
**Long list of supported radeon chipsets deleted for sake of space.**
[    26.175] (II) VESA: driver for VESA chipsets: vesa
[    26.175] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    26.175] (II) FBDEV: driver for framebuffer: fbdev
[    26.175] (++) using VT number 8
[    26.177] (WW) Falling back to old probe method for fglrx
[    26.219] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    26.223] ukiDynamicMajor: found major device number 249
[    26.229] (--) Assigning device section with no busID to primary device
[    26.229] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:0) found
[    26.229] (--) Chipset Supported AMD Graphics Processor (0x683F) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:3:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:9:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:3) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
[    26.230] (**) ChipID override: 0x6818
[    26.230] (**) Chipset Supported AMD Graphics Processor (0x6818) found
[    26.231] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    26.231] (II) AMD Video driver is signed
[    26.232] (II) fglrx(0): pEnt->device->identifier=0x7f3902e76d37
[    26.232] (II) pEnt->device->identifier=(nil)
[    26.232] (WW) Falling back to old probe method for vesa
[    26.232] (WW) Falling back to old probe method for modesetting
[    26.232] (EE) open /dev/dri/card0: No such file or directory
[    26.232] (WW) Falling back to old probe method for fbdev
[    26.232] (II) Loading sub module "fbdevhw"
[    26.232] (II) LoadModule: "fbdevhw"
[    26.233] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    26.271] (II) Module fbdevhw: vendor="X.Org Foundation"
[    26.271]    compiled for 1.13.0, module version = 0.0.2
[    26.272]    ABI class: X.Org Video Driver, version 13.0
[    26.272] (EE) open /dev/fb0: No such file or directory
[    26.272] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[    26.275] (II) Loading sub module "vgahw"
[    26.275] (II) LoadModule: "vgahw"
[    26.279] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    26.280] (II) Module vgahw: vendor="X.Org Foundation"
[    26.280]    compiled for 1.13.0, module version = 0.1.0
[    26.280]    ABI class: X.Org Video Driver, version 13.0
[    26.280] (II) fglrx(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    26.280] (==) fglrx(0): Depth 24, (==) framebuffer bpp 32
[    26.280] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    26.280] (==) fglrx(0): Default visual is TrueColor
[    26.280] (==) fglrx(0): RGB weight 888
[    26.280] (II) fglrx(0): Using 8 bits per RGB
[    26.280] (==) fglrx(0): Buffer Tiling is ON
[    26.290] (II) Loading sub module "fglrxdrm"
[    26.290] (II) LoadModule: "fglrxdrm"
[    26.291] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    26.291] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    26.291]    compiled for 1.4.99.906, module version = 9.1.11
[    26.302] ukiDynamicMajor: found major device number 249
[    26.302] ukiDynamicMajor: found major device number 249
[    26.302] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    26.303] ukiOpenDevice: node name is /dev/ati/card0
[    26.304] ukiOpenDevice: open result is 12, (OK)

Seems to stop in the same location as the previous log.

*edit* Oh, forgot to mention I deleted my xorg.conf for this run.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Tue Apr 09, 2013 6:19 am

Yea, it must be frustrating to be so close but yet...

Let me suggest to take a step at a time and compare your xorg.0.log file with mine. Have a look at your log at 26.177 and see what I have here:
Code: Select all
[    23.047] (WW) Falling back to old probe method for fglrx
[    23.049] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    23.052] ukiDynamicMajor: found major device number 250
[    23.052] (--) Assigning device section with no busID to primary device
[    23.052] (--) Chipset Supported AMD Graphics Processor (0x6779) found
[    23.052] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    23.054] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    23.054] (II) AMD Video driver is signed
[    23.055] (II) fglrx(0): pEnt->device->identifier=0x7fb58c5c5d37
[    23.055] (WW) Falling back to old probe method for vesa
[    23.055] (WW) Falling back to old probe method for modesetting
[    23.055] (EE) open /dev/dri/card0: No such file or directory
[    23.055] (WW) Falling back to old probe method for fbdev
[    23.055] (II) Loading sub module "fbdevhw"
[    23.055] (II) LoadModule: "fbdevhw"
[    23.055] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    23.055] (II) Module fbdevhw: vendor="X.Org Foundation"
[    23.055]    compiled for 1.13.0, module version = 0.0.2
[    23.055]    ABI class: X.Org Video Driver, version 13.0
[    23.055] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[    23.056] (II) Loading sub module "vgahw"
[    23.056] (II) LoadModule: "vgahw"
[    23.057] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    23.057] (II) Module vgahw: vendor="X.Org Foundation"
[    23.057]    compiled for 1.13.0, module version = 0.1.0
[    23.057]    ABI class: X.Org Video Driver, version 13.0
[    23.057] (II) fglrx(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    23.057] (==) fglrx(0): Depth 24, (==) framebuffer bpp 32
[    23.057] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    23.057] (==) fglrx(0): Default visual is TrueColor
[    23.057] (==) fglrx(0): RGB weight 888
[    23.057] (II) fglrx(0): Using 8 bits per RGB
[    23.057] (==) fglrx(0): Buffer Tiling is ON
[    23.057] (II) Loading sub module "fglrxdrm"
[    23.057] (II) LoadModule: "fglrxdrm"
[    23.057] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/linux/libfglrxdrm.so
[    23.057] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    23.057]    compiled for 1.4.99.906, module version = 9.0.2
[    23.059] ukiDynamicMajor: found major device number 250
[    23.059] ukiDynamicMajor: found major device number 250
[    23.059] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    23.059] ukiOpenDevice: node name is /dev/ati/card0
[    23.059] ukiOpenDevice: open result is 11, (OK)
[    23.185] ukiOpenByBusid: ukiOpenMinor returns 11
[    23.185] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    23.185] (**) fglrx(0): NoAccel = NO
[    23.185] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[    23.185] (--) fglrx(0): Chipset: "AMD Radeon HD 6450" (Chipset = 0x6779)
[    23.185] (--) fglrx(0): (PciSubVendor = 0x174b, PciSubDevice = 0xe164)
[    23.185] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[    23.185] (--) fglrx(0): Linear framebuffer (phys) at 0xc0000000
[    23.185] (--) fglrx(0): MMIO registers at 0xfa820000
[    23.185] (--) fglrx(0): I/O port at 0x0000e000
[    23.185] (==) fglrx(0): ROM-BIOS at 0x000c0000
[    23.185] (II) fglrx(0): AC Adapter is used
[    23.186] (EE) fglrx(0): V_BIOS address 0x730 out of range


In your log you see:
Code: Select all
[    26.229] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:0) found
[    26.229] (--) Chipset Supported AMD Graphics Processor (0x683F) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:2) found
[    26.230] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
...
[    26.291] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    26.291]    compiled for 1.4.99.906, module version = 9.1.11
[    26.302] ukiDynamicMajor: found major device number 249
[    26.302] ukiDynamicMajor: found major device number 249
[    26.302] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    26.303] ukiOpenDevice: node name is /dev/ati/card0
[    26.304] ukiOpenDevice: open result is 12, (OK)


Here is what I would try now:
Add nomodeset as a grub boot option. See http://askubuntu.com/questions/207175/what-does-nomodeset-do.

See if that works.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Tue Apr 09, 2013 12:11 pm

Indeed it is...
I was wondering last night if there's a way to make the Xorg.0.log log debug level info. Maybe then I'd get a clue about why it's hanging just before announcing the card I have? I'll look into that. Oh, btw that portion where it's scanning my PCI devices, I think that only happens when a new driver is installed. If you look at my original Xen Xorg.0.log it doesn't do that. Not sure if that was the difference you were trying to point out. You'll also see that I've been using nomodeset from the beginning. I haven't had the splash disabled though.
[ 20.039] Kernel command line: placeholder root=/dev/mapper/xen-root ro nomodeset quiet splash xen-pciback.hide=(02:00.0)(02:00.1) radeon.blacklist=1

[ 25.485] Kernel command line: placeholder root=/dev/mapper/xen-root ro nomodeset quiet splash radeon.blacklist=1


Update:
So I tried it without the splash screen and I also tried adding something to an xorg.conf as mentioned here - https://fedoraproject.org/wiki/How_to_d ... g_problems

No luck. Xorg.0.log:
Code: Select all
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    23.941] X Protocol Version 11, Revision 0
[    23.941] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[    23.941] Current Operating System: Linux dvx 3.5.5-dom0+ #1 SMP Thu Apr 4 20:14:51 MST 2013 x86_64
[    23.941] Kernel command line: placeholder root=/dev/mapper/xen-root ro nomodeset radeon.blacklist=1
[    23.941] Build Date: 27 November 2012  07:44:35AM
[    23.941] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support)
[    23.941] Current version of pixman: 0.26.0
[    23.941]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    23.941] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.942] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr  9 09:22:18 2013
[    23.942] (==) Using config file: "/etc/X11/xorg.conf"
[    23.942] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    24.029] (==) ServerLayout "aticonfig Layout"
[    24.029] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    24.029] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    24.029] (**) |   |-->Device "aticonfig-Device[0]-0"
[    24.029] (==) Automatically adding devices
[    24.029] (==) Automatically enabling devices
[    24.029] (==) Automatically adding GPU devices
[    24.030] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    24.030]    Entry deleted from font path.
[    24.030] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    24.030] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    24.030] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    24.030] (II) Loader magic: 0x7fc9371cdc40
[    24.030] (II) Module ABI versions:
[    24.030]    X.Org ANSI C Emulation: 0.4
[    24.030]    X.Org Video Driver: 13.0
[    24.030]    X.Org XInput driver : 18.0
[    24.030]    X.Org Server Extension : 7.0
[    24.037] (--) PCI:*(0:1:0:0) 1002:683f:1682:3242 rev 0, Mem @ 0xc0000000/268435456, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    24.037] (--) PCI: (0:2:0:0) 1002:6818:1682:3250 rev 0, Mem @ 0xb0000000/268435456, 0xfe900000/262144, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[    24.037] (II) Open ACPI successful (/var/run/acpid.socket)
[    24.037] Initializing built-in extension Generic Event Extension
[    24.037] Initializing built-in extension SHAPE
[    24.037] Initializing built-in extension MIT-SHM
[    24.037] Initializing built-in extension XInputExtension
[    24.037] Initializing built-in extension XTEST
[    24.037] Initializing built-in extension BIG-REQUESTS
[    24.037] Initializing built-in extension SYNC
[    24.037] Initializing built-in extension XKEYBOARD
[    24.037] Initializing built-in extension XC-MISC
[    24.037] Initializing built-in extension SECURITY
[    24.037] Initializing built-in extension XINERAMA
[    24.037] Initializing built-in extension XFIXES
[    24.037] Initializing built-in extension RENDER
[    24.037] Initializing built-in extension RANDR
[    24.037] Initializing built-in extension COMPOSITE
[    24.038] Initializing built-in extension DAMAGE
[    24.038] Initializing built-in extension MIT-SCREEN-SAVER
[    24.038] Initializing built-in extension DOUBLE-BUFFER
[    24.038] Initializing built-in extension RECORD
[    24.038] Initializing built-in extension DPMS
[    24.038] Initializing built-in extension X-Resource
[    24.038] Initializing built-in extension XVideo
[    24.038] Initializing built-in extension XVideo-MotionCompensation
[    24.038] Initializing built-in extension XFree86-VidModeExtension
[    24.038] Initializing built-in extension XFree86-DGA
[    24.038] Initializing built-in extension XFree86-DRI
[    24.038] Initializing built-in extension DRI2
[    24.038] (II) "glx" will be loaded by default.
[    24.038] (II) LoadModule: "glx"
[    24.061] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
[    24.063] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    24.063]    compiled for 6.9.0, module version = 1.0.0
[    24.063] Loading extension GLX
[    24.063] (II) LoadModule: "fglrx"
[    24.064] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[    24.086] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    24.086]    compiled for 1.4.99.906, module version = 9.1.11
[    24.086]    Module class: X.Org Video Driver
[    24.086] (II) Loading sub module "fglrxdrm"
[    24.086] (II) LoadModule: "fglrxdrm"
[    24.087] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    24.087] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    24.087]    compiled for 1.4.99.906, module version = 9.1.11
[    24.087] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[    24.087] (II) AMD Proprietary Linux Driver Release Identifier: 9.012                               
[    24.087] (II) AMD Proprietary Linux Driver Build Date: Dec 19 2012 14:41:10
[    24.087] (++) using VT number 8
[    24.089] (WW) Falling back to old probe method for fglrx
[    24.094] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    24.098] ukiDynamicMajor: found major device number 250
[    24.098] ukiDynamicMajor: found major device number 250
[    24.098] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    24.098] ukiOpenDevice: node name is /dev/ati/card0
[    24.098] ukiOpenDevice: open result is 8, (OK)


I think I put the "AccelDFS" in the right spot -
Code: Select all
Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
   Option "AccelDFS" "off"
EndSection


*edit* oops that was a Radeon driver option - http://manpages.ubuntu.com/manpages/luc ... eon.4.html So it doesn't really matter if I had it in the right spot.

Update 2
Well I tried running Xen in text mode again and started X with more detailed logging -
Code: Select all
startx -- -logverbose 9 -verbose 9

Doesn't seem like it did much though. It appears that the blacklist doesn't work if X isn't started as part of the boot process (must get passed through the bootup scripts) as I did get some of the old Radeon errors again. Log ends the same way -
Code: Select all
[    84.231] (II) Loading sub module "fglrxdrm"
[    84.231] (II) LoadModule: "fglrxdrm"
[    84.231] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
[    84.231] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    84.231]    compiled for 1.4.99.906, module version = 9.1.11
[    84.234] ukiDynamicMajor: found major device number 250
[    84.234] ukiDynamicMajor: found major device number 250
[    84.234] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    84.234] ukiOpenDevice: node name is /dev/ati/card0
[    84.234] ukiOpenDevice: open result is 14, (OK)

Btw, I had to chown .Xauthourity in my home directory. It was set to root so I couldn't startx.

Anyways, I was hoping for more info but no luck.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Tue Apr 09, 2013 11:02 pm

OK, probably time to start at square 1.

1. Purge the fglrx driver and remove the radeon.blacklist to boot the OS driver next time, and remove the pciback entry from grub. Update-grub. Also remove the xorg.conf file (copy it to a safe location just in case). Reinstate the pciback script.
2. Boot the standard Xen-kernel, not the one you compiled.
3. When in Xen, check sudo xm pci-list-assignable-devices - your second graphic card 02:00.0 and 02:00.1 should be listed. If not, try to run the pciback script manually. If that doesn't help either, remove or disable the pciback script and add the pciback entry to grub, next reboot into your compiled kernel.
4. Once you got your 2nd graphics card listed as assignable, run the AMD fglrx installer. I would try the driver from the repos, that can be installed via synaptic. Then blacklist the radeon driver!
5. Reboot and cross your fingers.

When you install fglrx, the second graphics adapter should have the pciback driver. Check with lspci -v to make sure.

After you installed the fglrx driver and blacklisted radeon, the boot process should first attach the pciback driver to the 2nd graphics card (so that it appears in xm pci-list-assignable-devices). Then it should prevent the radeon driver from loading, and start the fglrx driver instead.

Again, try with the standard kernel and Xen, not the kernel you compiled. I didn't have to compile any kernel to make it work. Only if you can't get pciback to grab your second graphics card, remove the pciback script and use your compiled kernel with pciback grub option. Make sure to install fglrx while booted into Xen.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Tue Apr 09, 2013 11:43 pm

powerhouse wrote:OK, probably time to start at square 1.

1. Purge the fglrx driver and remove the radeon.blacklist to boot the OS driver next time, and remove the pciback entry from grub. Update-grub. Also remove the xorg.conf file (copy it to a safe location just in case). Reinstate the pciback script.

I've already done this step above.
2. Boot the standard Xen-kernel, not the one you compiled.

I've never used a custom Xen hypervisor. I'm assuming you meant use the standard Mint kernel. I have done so, but I can try again.
3. When in Xen, check sudo xm pci-list-assignable-devices - your second graphic card 02:00.0 and 02:00.1 should be listed. If not, try to run the pciback script manually. If that doesn't help either, remove or disable the pciback script and add the pciback entry to grub, next reboot into your compiled kernel.

I know you're trying to help me but I'm puzzled why you keep trying to get me to use the pciback script when it's not necessary for the task at hand. My problem isn't doing pci passthrough after all. It's getting fglrx to work in Dom0 which doesn't require immou at all.
4. Once you got your 2nd graphics card listed as assignable, run the AMD fglrx installer. I would try the driver from the repos, that can be installed via synaptic. Then blacklist the radeon driver!

I've tried this once already per your request to install the fglrx driver from within Xen (at which point I already had my second card assignable and listed in xm pci-list-assignable-devices).
5. Reboot and cross your fingers.

I do appreciate the responses, but I feel like I'm beating a dead horse at this point. Not your fault. I've just been over these permutations a lot over the last week and half. I was hoping someone might know of something I haven't tried.

When you install fglrx, the second graphics adapter should have the pciback driver. Check with lspci -v to make sure.

After you installed the fglrx driver and blacklisted radeon, the boot process should first attach the pciback driver to the 2nd graphics card (so that it appears in xm pci-list-assignable-devices). Then it should prevent the radeon driver from loading, and start the fglrx driver instead.

I thought I had mentioned that I already had this working in this thread or the vga passthrough thread. I apologize if I hadn't but again my problem is not with vga passthrough. That works.

Again, try with the standard kernel and Xen, not the kernel you compiled. I didn't have to compile any kernel to make it work. Only if you can't get pciback to grab your second graphics card, remove the pciback script and use your compiled kernel with pciback grub option. Make sure to install fglrx while booted into Xen.

Never had a problem with fglrx attaching to the correct video card in lspci. Just that X windows won't boot.

Today I found two links to problems that resemble mine (w/o Xen though), but unfortunately no solution is forthcoming.
http://ati.cchtml.com/show_bug.cgi?id=743 Notice that this is a 7000 series GPU. This bug report is pretty detailed. The xorg.0.log looks like mine and they've even tried the beta driver.
http://forums.gentoo.org/viewtopic-t-95 ... art-0.html 7000 series as well.
I'm beginning to think this is an issue with these newer boards. Iirc, I haven't seen anyone report success with a 7000 series in Dom0 with fglrx. The first link even says they can get it to work with the open source driver like me.

Thanks for trying to help but I think I'm going to call it. I might just go back to dual booting until these drivers and/or Xen has baked a little more.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Fri Apr 12, 2013 2:05 pm

Have been away for some days.

I agree with you - it does look like a driver issue, or perhaps an issue with your specific card. If you have any option to try another AMD card for dom0, that would help locate the problem (or even solve it).

The reason I was so adamant about going through the steps again was that I too had a black screen at first, and only the steps I described helped to solve the issue.

There is a long thread over at overclock.net with some very knowledgeable people there: http://www.overclock.net/t/1205216/guide-create-a-gaming-virtual-machine. You may want to scan the thread for info on your graphics card, or ask for advise there.

I'm afraid I'm no expert on graphics cards and drivers. Good luck!
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Fri Apr 12, 2013 7:28 pm

powerhouse wrote:Have been away for some days.

I agree with you - it does look like a driver issue, or perhaps an issue with your specific card. If you have any option to try another AMD card for dom0, that would help locate the problem (or even solve it).

The reason I was so adamant about going through the steps again was that I too had a black screen at first, and only the steps I described helped to solve the issue.


I guess my hangup is that, vga passthrough or not, the Radeon driver works fine under Dom0. I even made sure it wasn't the issue with Fglrx by turning passthrough off and on (or rather pci-back). In the end I'm not sure if we are getting no video for the same reasons. /shrug. Who knows at this point.

There is a long thread over at overclock.net with some very knowledgeable people there: http://www.overclock.net/t/1205216/guide-create-a-gaming-virtual-machine. You may want to scan the thread for info on your graphics card, or ask for advise there.


I might have to check it out some. I never really saw their posts show up in my searches so maybe I missed something.

I'm afraid I'm no expert on graphics cards and drivers. Good luck!


Nor I. I'm just stubbornly trying to troubleshoot this. I've tried 3 different distro's now. The other two I couldn't even get fglrx to load properly. Opensuse comes with a Xen kernel and Xen 4.2 so I thought it might have a better chance of working (Suse, like AMD, made contributions to Xen 4.2). At least insomuch that it was significantly different from my Mint install (the definition of crazy is to try the same thing expecting a different result). But alas Suse's driver support is lackluster and I couldn't get either the community provided fglrx package or the AMD version to load atop my Xen kernel (the former always loading on the standard kernel and the later complaining about missing header files that were loaded). Started to load Arch Linux and then realized that they are on Xorg Server 1.14 and Fglrx only supports 1.13. /sigh. Guess that's what you get with bleeding edge rolling releases. I could have backported to get fglrx loaded on it but then it just felt like I was missing the point of Arch Linux. So I've come full circle and will probably reload Mint 14 Mate, get vga passthrough working, and use the open source Radeon in my Dom0. Though, I'll probably still dabble with Arch on the side.

If only Nvidia cards at least worked under Dom0. Their proprietary drivers supported Xorg Server 1.14 before it's release and their release schedule is more aggressive.

(oh, and it turns out the "Xen" kernel on opensuse doesn't have pci-back compiled into the kernel so it does you a whole lot of good. :( )

2 Weeks on one problem is enough for me.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Sat Apr 13, 2013 8:02 am

2 weeks is a lot of time spent to troubleshoot one problem. But at least it looks like you learned a bit on the way. Thanks for your input on Arch and Suse - I'm quite surprised that Suse doesn't have pciback in the kernel.

Yes, it would be great if Nvidia drivers would work with dom0. I totally agree with you that when Nvidia proprietary drivers work, they are great. Also, Nvidia has a much longer support cycle for their graphics cards.

Finally, have a look at this thread to see if it helps: http://askubuntu.com/questions/251045/how-can-i-run-x-on-1-out-of-2-gpus-connected.

It also explains why the pciback stuff and the video card on dom0 is related. With pciback grabbing the second VGA, the fglrx driver should only see the first card and configure it. This is why I insisted on getting pciback working and then installing the fglrx driver in dom0. Anyway, you tried it and it didn't work.

The thread above also explains how to edit the xorg.conf file to make X work with only one graphics card out of two.

EDIT: Here is a tutorial on how to install the AMD driver manually under Ubuntu - http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29. Do it within dom0 and the second VGA attached to pciback. Note that some of the package requirements may differ.
Again, in my case I used the driver package from the Linux Mint repository, not this manual install method. Just an option you may not have explored.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Sat Apr 13, 2013 12:32 pm

You'd think Nvidia would be more willing to contribute to virtualization projects to sell more video cards, but if their latest trade show is any indication they're looking to get into grid/cloud computing with their Arm+GPU combo's. I guess that makes sense considering the Desktop PC market is in a slump right now. Will they get more involved now that valve is talking about the steambox? Hard to say. Nvidia did bow out of the bidding for the next console generations so maybe they've decided to go all in on hybrid server computing. Time will tell who made the better bet between AMD and Nvidia. Hey, if Nvidia stops focusing on the desktop GPU market maybe they can lend some of their programmers to AMD for driver development? :P
Finally, have a look at this thread to see if it helps: http://askubuntu.com/questions/251045/how-can-i-run-x-on-1-out-of-2-gpus-connected.
It also explains why the pciback stuff and the video card on dom0 is related. With pciback grabbing the second VGA, the fglrx driver should only see the first card and configure it. This is why I insisted on getting pciback working and then installing the fglrx driver in dom0. Anyway, you tried it and it didn't work.

Right, but my point was that I wasn't worried about passthrough or disabling any cards at this point. I just wanted normal video support under Xen. If that worked then I could go on to the next step. /shrug. It's water under the bridge now since I've already done all that.
The thread above also explains how to edit the xorg.conf file to make X work with only one graphics card out of two.

Yeah, that's what I was doing with the xorg.conf I posted ;)
EDIT: Here is a tutorial on how to install the AMD driver manually under Ubuntu - http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29. Do it within dom0 and the second VGA attached to pciback. Note that some of the package requirements may differ.

I don't know if I posted it in this thread or the other one, but I've already tried the Quantal version of that guide (what Mint 14 is based on). Thats what I was reinstalling in the posts above.
Again, in my case I used the driver package from the Linux Mint repository, not this manual install method. Just an option you may not have explored.

I don't really think it matters the version at this point, but again I've tried both of the packages in the repos.

Well, I got LM14 Mate loaded last night. Going to mess around with Xen again later (sticking, for better or worse, with the open source driver). I was tempted to give KVM another whirl after reading some of the last thread you posted, but then I noticed what kernel versions they were using and I changed my mind. Back in 2009 I tried to do vga passthrough with KVM (before it was common knowledge that iommu support was spotty). I even wrote a Howto while I was doing it but I don't think I ever posted it. The strange thing was that I actually got my windows guest to see my nvidia card (device manager), but I wasn't able to install drivers for it. Of course to get even that far I had to compile new kernels, qemu, etc. Suffice to say I'm not so quick to travel down that path of bleeding edge again.

lol. I found my old KVM howto here's some highlights -
Versions I'm running as of this writing -
Mint 8 Helena 64bit
qemu-kvm 0.12.1.1 (compiled)
bridge-utils 1.4-5 (package on repos)
.
.
git checkout Ubuntu-2.6.31-17.54 -b amdquad
.
.
Now you should have two files. i.e. qemu-kvm-0.12.1.1.tar.gz and kvm-kmod-2.6.31.6b.tar.bz2
.
.
sudo modprobe kvm
sudo modprobe kvm-amd or sudo modprobe kvm-intel


Oh, yeah. I think this was before KVM was even in the mainline kernel. I had to compile it as a kernel mod separately. And it appears it was a beta version I was using. lol. Good times....
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby gordon.cooke on Mon Apr 15, 2013 11:07 pm

I am also having som trouble with fglrx drivers. But I am seeing some very odd behavior.

Linux Mint 13
AMD Redeon HD5450 graphics card
Linux 3.2.0-23-generic (x86-64) kernel under XEN, right off repos
currently using fglrx-updates driver. Have also tried the fglrx and radeon drivers.

At first I tried changing between Radeon, fglrs, and fglrx-updates with various success and failure. At first tonightI could only get into gnome-fallback under Xen, then a lot of fails. But here is the very odd behavior I am seeing: with fglrx-updates driver-
  • If I try to boot into Xen, it fails to load X
  • reboot into Mint 13 -> loads fine into Cinamon desktop
  • reboot into Xen -> loads fine into Cinamon desktop
  • reboot into Xen (without changing anything) -> X fails to loads
  • reboot into Mint 13 (without any changes) -> loads fine into Cinamon
  • reboot into Xen (without changing anything) -> loads fine into Cinamon
and I can continue that cycle.

What is changing after a Xen version loads up that is undoing what makes it work? But is being corrected when (non Xen) Mint13 loads up? Im not noticing any changes in xorg.conf.

Right now I am booted under Xen in a working cinamon desktop
For reference
/etc/X11/xorg.conf
Code: Select all
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx-updates"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


/etc/default/grub
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Xen 4.1-amd64"
#GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset radeon.blacklist=1"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:8G"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


/boot/grub/grub.cfg (is it something to do with gfxmode?)
Code: Select all
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="Xen 4.1-amd64"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos2)'
search --no-floppy --fs-uuid --set=root 3fa699ed-5e28-40f7-8082-a575890b8cd4
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
  set locale_dir=($root)/grub/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=3
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
   set gfxpayload="$1"
   if [ "$1" = "keep" ]; then
      set vt_handoff=vt.handoff=7
   else
      set vt_handoff=
   fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda1)' --class linuxmint --class gnu-linux --class gnu --class os {
   recordfail
   gfxmode $linux_gfx_mode
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   linux   /vmlinuz-3.2.0-23-generic root=UUID=3fa699ed-5e28-40f7-8082-a575890b8cd4 ro   quiet splash nomodeset radeon.blacklist=1 $vt_handoff
   initrd   /initrd.img-3.2.0-23-generic
}
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda1) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
   recordfail
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   echo   'Loading Linux 3.2.0-23-generic ...'
   linux   /vmlinuz-3.2.0-23-generic root=UUID=3fa699ed-5e28-40f7-8082-a575890b8cd4 ro recovery nomodeset
   echo   'Loading initial ramdisk ...'
   initrd   /initrd.img-3.2.0-23-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
submenu "Xen 4.1-amd64" {
menuentry 'LinuxMint GNU/Linux, with Xen 4.1-amd64 and Linux 3.2.0-23-generic' --class linuxmint --class gnu-linux --class gnu --class os --class xen {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   echo   'Loading Xen 4.1-amd64 ...'
   multiboot   /xen-4.1-amd64.gz placeholder iommu=1 dom0_mem=min:2048M,max:8G
   echo   'Loading Linux 3.2.0-23-generic ...'
   module   /vmlinuz-3.2.0-23-generic placeholder root=UUID=3fa699ed-5e28-40f7-8082-a575890b8cd4 ro  quiet splash nomodeset radeon.blacklist=1
   echo   'Loading initial ramdisk ...'
   module   /initrd.img-3.2.0-23-generic
}
menuentry 'LinuxMint GNU/Linux, with Xen 4.1-amd64 and Linux 3.2.0-23-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os --class xen {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   echo   'Loading Xen 4.1-amd64 ...'
   multiboot   /xen-4.1-amd64.gz placeholder iommu=1 dom0_mem=min:2048M,max:8G
   echo   'Loading Linux 3.2.0-23-generic ...'
   module   /vmlinuz-3.2.0-23-generic placeholder root=UUID=3fa699ed-5e28-40f7-8082-a575890b8cd4 ro single
   echo   'Loading initial ramdisk ...'
   module   /initrd.img-3.2.0-23-generic
}
}
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   linux16   /memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root ca975d11-7bc3-431b-8527-1afd9224639a
   linux16   /memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


and some system info: Yes, I have a third graphics card- an old (c.1996) pci video card Ive been trying to get working but have not worked on yet. Could that be at issue? But without Xen it is not an issue.
Code: Select all
username@vmhost ~ $     inxi -Fxz
System:    Host: vmhost Kernel: 3.2.0-23-generic x86_64 (64 bit, gcc: 4.6.3) Desktop: Gnome Distro: Linux Mint 13 Maya
Machine:   Mobo: MSI model: 970A-G43 (MS-7693) version: 3.0 Bios: American Megatrends version: V10.0 date: 12/26/2012
CPU:       Single core AMD FX-8320 Eight-Core (-UP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3) bmips: 7000.37
           Clock Speeds: 1: 3500.188 MHz 2: 3500.188 MHz 3: 3500.188 MHz 4: 3500.188 MHz 5: 3500.188 MHz 6: 3500.188 MHz 7: 3500.188 MHz 8: 3500.188 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD] nee ATI Cedar PRO [Radeon HD 5450] bus-ID: 01:00.0
           Card-2: Advanced Micro Devices [AMD] nee ATI Cedar PRO [Radeon HD 5450] bus-ID: 02:00.0
           Card-3: S3 86c764/765 [Trio32/64/64V+] bus-ID: 05:05.0
           X.Org: 1.11.3 drivers: ati,fglrx (unloaded: vesa,fbdev,radeon) Resolution: 1280x1024@60.0hz
           GLX Renderer: ATI Radeon HD 5450 GLX Version: 4.2.11903 - CPC Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Card-2: 2x Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series] driver: snd_hda_intelpciback bus-ID: 02:00.1
           Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: c000 bus-ID: 06:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 3160.6GB (28.1% used) 1: /dev/sda ST3160815AS 160.0GB 38C
           2: /dev/sdb WDC_WD30EZRX 3000.6GB 33C
Partition: ID: / size: 15G used: 12G (84%) fs: ext4 ID: /boot size: 2.0G used: 453M (25%) fs: ext3
           ID: swap-1 size: 16.78GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 29.0C mobo: N/A gpu: 56.00C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 193 Uptime: 19 min Memory: 721.4/6603.1MB Runlevel: 2 Gcc sys: 4.6.3 Client: Shell inxi: 1.7.33

and I did check that my second video card is available for passing through to win7 domU (not currently running)
Code: Select all
gordon@vmhost ~ $  sudo xm pci-list-assignable-devices
0000:02:00.0   <- video
0000:02:00.1   <- hdmi audio
0000:00:16.0   <- usb
0000:00:16.2   <- usb
------------------------------------------------------------------------
Mint 13 64bit Cinnamon
Asus U56E Laptop, Core i5-2410M, Intel graphics, 6GB RAM
Mint 9 64bit
Averatec 2573 Laptop, AMD Turion 64x2, ATI Graphics, Atheros wireless, 3GB RAM
User avatar
gordon.cooke
Level 3
Level 3
 
Posts: 151
Joined: Tue Dec 01, 2009 9:48 pm
Location: New York

Re: Fglrx + Xen = No X

Postby Locuust on Mon Apr 15, 2013 11:36 pm

Whoa. That is strange. It alternates between working and failing between boots with no user modification? On HD 5000 cards too. Maybe my theory was incorrect. What exactly do you mean X fails to load? Do you get a black screen like me? Or are you getting some sort of error when X attempts to load?

I'd be interested in seeing your Xorg.0.log.old log after booting into Mint w/o Xen (after a X failure).
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Tue Apr 16, 2013 5:17 pm

@gordon.cooke:

That's quite an interesting phenomena. My guess would be gfxmode, too. But I'm really just guessing.

Do any of the nomodeset etc. grub parameters help?

One way of better analyzing the issue is to enable ssh access (install the openssh server) and connect to your PC remotely from another PC (in case you get a black screen and have no console).

Also check for Cinnamon related issues - there is an entirely different forum thread here (i.e. not the main edition).

EDIT: and try "radeon.blacklist=1" as the first boot option before quiet, nomodeset etc.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Tue Apr 16, 2013 7:36 pm

@Powerhouse
afaik gfxmode is purely for grub - http://www.gnu.org/software/grub/manual ... ml#gfxmode
His /etc/defaults/grub already contains "radeon.blacklist=1" and "nomodeset".
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Tue Apr 16, 2013 11:37 pm

Locuust wrote:@Powerhouse
afaik gfxmode is purely for grub - http://www.gnu.org/software/grub/manual ... ml#gfxmode
His /etc/defaults/grub already contains "radeon.blacklist=1" and "nomodeset".


gfxmode: What I meant is the last successful graphics mode or fallback mode. Not sure how it's called, but grub / xorg has the option to boot the last graphics mode that was successfully loaded, in other words, at some point it saves the graphics mode that it uses for the next time you boot. This could potentially toggle the mode.

radeon.blacklist=1: Yes, I saw that, but it's the last option in the line. I think it should come as the first option, before all the other options. Because if the kernel boot parameters are executed in the order they appear, that would make a difference.

Here are the /etc/default/grub settings for reference:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="radeon.blacklist=1"
GRUB_CMDLINE_LINUX=
GRUB_CMDLINE_XEN="iommu=1 dom0_mem=min:2048M,max:6G"


I would remove quiet and splash to see what's going on while booting. Also, try with and without "nomodeset".
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Wed Apr 17, 2013 9:11 am

In other news it seems my onboard audio doesn't work passed through (win7 driver issues). I should have tried it sooner. So I canceled my USB soundcard order before it shipped so I can try some things. I might end up having to get a proper internal soundcard if I want decent audio for my Win7 DomU.

This - http://www.gossamer-threads.com/lists/xen/users/256539 suggests that an older kernel might actually work. So I'll probably load Mint 13 to try it. I'm also going to give KVM a try in another distro that has a newer kernel. Not to mention KVM will probably bypass this issue with Fglrx. Here's hoping I can iron out everything this week.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Re: Fglrx + Xen = No X

Postby powerhouse on Wed Apr 17, 2013 2:47 pm

Locuust wrote:In other news it seems my onboard audio doesn't work passed through (win7 driver issues). I should have tried it sooner. So I canceled my USB soundcard order before it shipped so I can try some things. I might end up having to get a proper internal soundcard if I want decent audio for my Win7 DomU.

This - http://www.gossamer-threads.com/lists/xen/users/256539 suggests that an older kernel might actually work. So I'll probably load Mint 13 to try it. I'm also going to give KVM a try in another distro that has a newer kernel. Not to mention KVM will probably bypass this issue with Fglrx. Here's hoping I can iron out everything this week.


1. To get sound in Windows domU, you plug a USB sound card into a passed-through USB port and connect the headphone output to the line input on the motherboard. You don't pass through the onboard sound. If you were to pass through the onboard sound, you'd be loosing sound under Linux / dom0.

2. Yes, I believe KVM doesn't have issues with fglrx, so this could be an alternative. For instructions in KVM VGA passthrough, see also http://www.overclock.net/t/1205216/guide-create-a-gaming-virtual-machine/600#post_19770787. The poster of this mini-how-to appears to be very knowledgeable and it's worth to look up his posts in the thread I linked.

@gordon.cooke: If you can't make fglrx / Xen work the way you want, you may as well consider kvm. I haven't tried it, but several people on the forum I linked above have reported success.

Perhaps one of you will be able to post a kvm how-to for Linux Mint?
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: Fglrx + Xen = No X

Postby Locuust on Wed Apr 17, 2013 3:14 pm

powerhouse wrote:1. To get sound in Windows domU, you plug a USB sound card into a passed-through USB port and connect the headphone output to the line input on the motherboard. You don't pass through the onboard sound. If you were to pass through the onboard sound, you'd be loosing sound under Linux / dom0.

Lol. I know how you did it, but I want to have the option of having a surround sound setup while playing games in DomU (or 3D audio with headphones). My plan all along as to use the USB soundcard for Dom0.
2. Yes, I believe KVM doesn't have issues with fglrx, so this could be an alternative. For instructions in KVM VGA passthrough, see also http://www.overclock.net/t/1205216/guide-create-a-gaming-virtual-machine/600#post_19770787. The poster of this mini-how-to appears to be very knowledgeable and it's worth to look up his posts in the thread I linked.

Will check it out once I've tested things under Mint 13. It looks pretty detailed, but man using an RC kernel... I hope it doesn't come to that. The VFIO stuff sounds cool, but it's essentially a rewrite of what KVM had done with x86 specific VGA passthrough. Unless I misunderstood and it makes it easier to implement in some way I'm hoping the old x86 approach will be enough to get me by. We'll see.
Perhaps one of you will be able to post a kvm how-to for Linux Mint?

Lol, I dunno. I wrote a KVM howto in vain last time. I might go back and do one after the fact if it does indeed work.
Locuust
Level 3
Level 3
 
Posts: 156
Joined: Thu Oct 02, 2008 4:54 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 10 guests