Power Management Issue?

Forum rules
Before you post please read this

Power Management Issue?

Postby Jeff045430 on Sat Apr 13, 2013 3:29 pm

I was running Linux Mint 13 Cinnamon for quite awhile. I had configured Cinnamon power management to never turn off my screen which worked fine. Recently I installed the KDE desktop via Synaptic and configured the KDE power management settings to never turn off my monitor, but the monitor turns off after 10 minutes despite the my settings. My guess is that the default Cinnamon power management settings are causing this to occur, however I can not see a way to access the Cinnamon power management settings from within KDE to correct the matter.

I'm open to any suggestions that will stop my monitor from turning off.
Jeff045430
Level 1
Level 1
 
Posts: 2
Joined: Sat Apr 13, 2013 3:09 pm

Linux Mint is funded by ads and donations.
 

Re: Power Management Issue?

Postby skidaddy45 on Sun Apr 21, 2013 10:53 am

the following is a script that works temporaly. I can't believe no one is finding the solution to this problem it is ruinning my otherwise great setup too.


place this in a text editor (kate) then save it as (blocksaver). Use dolphin to change properties to make it executeable. Then use a teminal cd to directory you saved it in and run it. you will probably have to call it with command ./blocksaver. Regular user not root. Also it has to be run everytime you log in. Argavating but better than the screen blanking.

#!/bin/bash
clear
xset -dpms
xset s off
echo "Finished have a good day."



If you find a more permanant solution for gods sake let me know.
skidaddy45
Level 1
Level 1
 
Posts: 2
Joined: Mon May 28, 2012 12:34 pm

Re: Power Management Issue?

Postby Jeff045430 on Fri May 03, 2013 6:44 pm

Thanks for the script.

I put your script in AutoStart which works for me. I considered putting it in the /etc/profile.d folder which should also work, but I havent tried doing so.
Jeff045430
Level 1
Level 1
 
Posts: 2
Joined: Sat Apr 13, 2013 3:09 pm

Re: Power Management Issue?

Postby homerscousin on Sun May 05, 2013 8:34 pm

I saw the same thing in 13 KDE. It wasn't until 14 KDE and I updated that to 4.10 that everything seemed perfect. I was experimenting just a couple days ago turning off startup services. I unchecked the box for power management. That's in kde's system settings, startup and shutdown, service manager. I had my monitor set to turn off after 150 minutes. That worked ok. After turning off the service, the monitor stayed on past the 150 minutes. Probably forever. This is a desktop rig, so I don't have much need for power reductions that someone may want on a laptop. It may work if you don't mind the other features that will be off as well. I turned the service back on, I want the monitor off after a typical full lenght movie and I'm already sleeping.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)


Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests