Install latest Cinnamon (1.7.3) in LMDE

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby mockturtl on Sat Apr 13, 2013 5:11 pm

Monsta wrote:
urbiental wrote:i used this preferences and list

These preferences are too high, I think, especially 600 for Testing.
Specifically:

Code: Select all
$ man apt_preferences
APT_PREFERENCES(5)                                                                            APT                                                                           APT_PREFERENCES(5)

NAME
       apt_preferences - Preference control file for APT
...
 How APT Interprets Priorities
       Priorities (P) assigned in the APT preferences file must be positive or negative integers. They are interpreted as follows (roughly speaking):

       P >= 1000
           causes a version to be installed even if this constitutes a downgrade of the package

       990 <= P < 1000
           causes a version to be installed even if it does not come from the target release, unless the installed version is more recent

       500 <= P < 990
           causes a version to be installed unless there is a version available belonging to the target release or the installed version is more recent

       100 <= P < 500
           causes a version to be installed unless there is a version available belonging to some other distribution or the installed version is more recent

       0 < P < 100
           causes a version to be installed only if there is no installed version of the package

       P < 0
           prevents the version from being installed
Also, the "origin" directive doesn't account for mirrors.

Another tip, to freeze a single package, don't pin it: `aptitude hold/unhold` it.

You'll forget what you've frozen (and go mad figuring out why your upgrades always report "... and 1 not upgraded"). The lookup command is a little esoteric, so create an alias:

Code: Select all
echo "alias apt-held='aptitude search ~ahold'" >> ~/.bash_aliases


Actually, I don't know if you can pin Testing in LMDE at all. IIRC, the release name ("release a=testing") is the same in LMDE's Latest repos.
You can combiner specifiers, comma-separated.
Code: Select all
$ cat /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: release o=linuxmint-debian
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: origin mirror.metrocast.net
Pin-Priority: 700

Package: *
Pin: release o=Debian,a=testing
Pin-Priority: 99

Package: *
Pin: release o=Debian,a=unstable
Pin-Priority: 50

$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import incoming #romeo
           deb-src http://packages.linuxmint.com/ debian main upstream import incoming #romeo
           deb http://mirror.metrocast.net/linuxmint-debian/incoming testing main contrib non-free
           deb-src http://mirror.metrocast.net/linuxmint-debian/incoming testing main contrib non-free
           deb http://mirror.metrocast.net/linuxmint-debian/incoming/security testing/updates main contrib non-free
           deb http://mirror.metrocast.net/linuxmint-debian/incoming/multimedia testing main non-free
           deb http://http.debian.net/debian testing main contrib non-free
           deb http://http.debian.net/debian unstable main contrib non-free
           deb http://http.debian.net/debian experimental main
Note I don't have a pin-priority for experimental: apt understands it should default to 1.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Linux Mint is funded by ads and donations.
 

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sun Apr 14, 2013 5:46 am

ok , i looked into it a little further and have some problem .... investigating :)

Code: Select all
JS ERROR: !!!   Exception was: Error: Requiring Cinnamon, version none: Typelib file for namespace 'Meta', version '3.0' not found
    JS ERROR: !!!     message = '"Requiring Cinnamon, version none: Typelib file for namespace 'Meta', version '3.0' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/environment.js"'
    JS ERROR: !!!     lineNumber = '13'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/environment.js:13
"'
    JS ERROR: !!!   Exception was: Error: Requiring Cinnamon, version none: Typelib file for namespace 'Meta', version '3.0' not found
    JS ERROR: !!!     message = '"Requiring Cinnamon, version none: Typelib file for namespace 'Meta', version '3.0' not found"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/environment.js"'
    JS ERROR: !!!     lineNumber = '13'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/environment.js:13
"'
Window manager warning: Log level 32: Execution of main.js threw exception: Error: Requiring Cinnamon, version none: Typelib file for namespace 'Meta', version '3.0' not found
Last edited by urbiental on Sun Apr 14, 2013 6:15 pm, edited 1 time in total.
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sun Apr 14, 2013 6:14 pm

success !

i also had to update gir1.2-muffin-3.0 to 1.7.xxx via sid .

cinnamon 1.7.3 running now .

BUT :D

cinnamon-settings cannot be started ... apply these changes

Code: Select all
 https://github.com/Lusito/Cinnamon/commit/034f9c886a4b08e214193576b11fb97ba3d62922


but for the "SettingsWidgets.py" file just uncoment the "import gconf" dont write the stuff infront and ure good to go !
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Previous

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 0 guests