Sound Blaster Recon3D Fatal1ty issues

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Sound Blaster Recon3D Fatal1ty issues

Postby Warrigal on Wed Jan 16, 2013 9:27 pm

Hi. I have just installed Mint 14.1, to replace my Windows 8 install.
My Sound Blaster Recon3D Fatal1ty Champion sound card is recognized, but not working.
Does anyone else have one of these cards working ok?
Being a newbie, I am not sure if I am missing something simple.
I read somewhere that from Kernel 3.5 there is support for the 3D Recon series.

My Machine:
AMD Phenom II 1100T
Gigabyte GA-990FXA-UD5
NVIDIA GeForce GTX 560 Ti
Creative SB Recon3D PCIe Audio Controller
Warrigal
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 16, 2013 9:13 pm

Linux Mint is funded by ads and donations.
 

Re: Sound Blaster Recon3D Fatal1ty issues

Postby Dethgrip69 on Sat Apr 27, 2013 2:51 am

Thus far, I have not been able to get this to work either. I have just installed Mint 14.1, previously also tried in Ubuntu 12.04. Neither version of Linux would allow for installing my Fatal1ty card drivers. The drivers load, the install begins, but I get the same message each time: "Product not detected on system!" (or something to that effect). I believe this may be a result of a deal with Microsoft to specifically produce this card for Windows only, as I am also unable to locate any Mac OS-X drivers for the product.

A few facts I have noticed over the last few months while attempting this:
1 - This is a rare issue. Not allot of resources can be found across the web referencing this card, or frequency of the issue.
2 - Either not many people purchase this card, or most users who do, use it with Windows.

The card works fantastically in Windows 7. High quality audio that is clean & crisp. This is not a cheap low end card like the Audigy. The card retails at $150. I paid $100 on Amazon.
For those of us using this product, there seems to be no Linux support. I have considered contacting Creative about the issue, but have been somewhat hesitant, as I had thought I could find something out there to resolve the issue.
So far, it looks like the only option is to hack the OS somehow, or replace the card itself. Neither prospect is very appealing.

My system:
Asus M5A99X EVO mobo
AMD FX 8120 CPU
GSKILL 16GB DDR3 RAM
Asus Radeon HD 7770 1GB
Creative SB Recon3D Fatal1ty PCIe

I will let you know if I am able to find a resolution that is better than either of these. In the meantime, good luck, to both of us.
Dethgrip69
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 27, 2013 2:40 am
Location: Boulder, CO

Re: Sound Blaster Recon3D Fatal1ty issues

Postby rbrick49 on Sun Jul 14, 2013 10:11 pm

I googled today a found there is support for this card on the 3.5 kernel
asrock extreme 4 motherboard,Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz,32 gb ram,asus xonar d2x sound card,g930 headset ,hp 23 inch monitor,external speakers,sda fedora 20 ,sdb sabayon 1407,sdc linuxmint 17 kde.,graphics intel haswell desktop
rbrick49
Level 1
Level 1
 
Posts: 32
Joined: Wed Oct 05, 2011 6:21 pm
Location: Thailand

Re: Sound Blaster Recon3D Fatal1ty issues

Postby mank_in on Mon Jul 15, 2013 12:32 am

This solution didn't works :?:
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Sound Blaster Recon3D Fatal1ty issues

Postby ThE_MarD on Tue Dec 31, 2013 6:28 pm

Heyyo,

Sorry I'm late to the party! :P

So I have my Sound Blaster Recon 3D Fatal1ty Edition working perfectly.. at least in stereo (don't have surround to test) in any Linux distro with kernel 3.9 (despite what that news posts on Phoronix says about 3.5..) but ONLY IN 32bit!!!!! 64bit crackles and doesn't work... also the microphone doesn't work either. :(

So you can try Unbuntu, Kubuntu, Fedora.. Debian.. Mint... only in 32bit.. still nothing as of that kernel 3.11 that I am testing... 64bit is still broken.
ThE_MarD
Level 1
Level 1
 
Posts: 1
Joined: Tue Dec 31, 2013 6:23 pm

Re: Sound Blaster Recon3D Fatal1ty issues

Postby Dethgrip69 on Sun Oct 19, 2014 3:25 pm

ThE_MarD wrote:Heyyo,

Sorry I'm late to the party! :P

So I have my Sound Blaster Recon 3D Fatal1ty Edition working perfectly.. at least in stereo (don't have surround to test) in any Linux distro with kernel 3.9 (despite what that news posts on Phoronix says about 3.5..) but ONLY IN 32bit!!!!! 64bit crackles and doesn't work... also the microphone doesn't work either. :(

So you can try Unbuntu, Kubuntu, Fedora.. Debian.. Mint... only in 32bit.. still nothing as of that kernel 3.11 that I am testing... 64bit is still broken.


Interesting, thank you for that input!

I am still pretty new to Linux, and I don't know much about specific kernel versions, or what to do with/about them. I do need to study up a bit, when I can find time lol...

I guess I'll reinstall using 32 bit & see if that works. Much appreciated!

*deth*
Dethgrip69
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 27, 2013 2:40 am
Location: Boulder, CO


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Jedinovice and 3 guests