Severe ecryptfs bug still present in LMDE?

Questions about applications and software
Forum rules
Before you post please read this

Severe ecryptfs bug still present in LMDE?

Postby Peterle on Tue Apr 30, 2013 3:29 pm

i had tons of unreadable files - AKA I/O errors (not found with badblocks utility, found by aide, by the way) - caused by ecryptfs, on ubuntu (https://bugs.launchpad.net/ecryptfs/+bu ... mments=all).

I'm wondering if it's present also in LMDE 2013-03. it's possible to test the presence of damaged files with the command:

find $HOME/.Private/ -size 0c -exec ls '{}' \; | wc -l

How is possible that this kind of bugs can exist even in ubuntu 12.04 LTS/Maya (which offer the opportunity to encrypt the home partition during the installation process!!!!)?

If ecryptfs is not reliable, is it advisable\possible to encrypt the home partition with LUKS?

Thanx.

P.S.: I've found plenty of information on launchpad.net, now I'm searching here:
http://bugs.debian.org/cgi-bin/pkgrepor ... ptfs-utils
Peterle
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:59 pm

Linux Mint is funded by ads and donations.
 

Re: Severe ecryptfs bug still present in LMDE?

Postby DrHu on Tue Apr 30, 2013 4:18 pm

Don't know, but I would be unmounting the encrypted file partition, if you used that method, before rebooting/logging out or restarting the system

One could always use Truecrypt as an application, since it is cross platform, and it is better to use one tool (popular on windows OS), and become familiar with its operations
--it is hard to totally avoid needing to use a windows OS on occasion, therefore knowing one tool (for encryption) would help.
https://wiki.archlinux.org/index.php/ECryptfs
http://www.makeuseof.com/tag/encrypt-yo ... -ecryptfs/
--also talks about truecrypt methodology..

If you are concerned about encrptfs operation or issues, I would simply use a test directory/folder and work with it for awhile until you are satisfied that it is reliable for your system..
https://launchpad.net/ecryptfs
--some kernel related bugs or version (of encryptfs) may not be related to the version of Linux Mint you are using, always carefully read before deciding the truth of the matter.
User avatar
DrHu
Level 16
Level 16
 
Posts: 6783
Joined: Wed Jun 17, 2009 8:20 pm

Re: Severe ecryptfs bug still present in LMDE?

Postby Peterle on Wed May 01, 2013 5:58 am

Report this message from the upstream forum: are those patches applied to LMDE?
It would be nice to read either: "Yes, LMDE doesn't suffer from this bug" or "Forget about ecryptfs on LMDE, Ubuntu and Debian".

Thanx


From: Sebastian Heinlein <devel@glatzor.de>
To: 690071@bugs.debian.org
Cc: tyhicks@canonical.com
Subject: Re: ecryptfs: corrupted files on a disk full event
Date: Wed, 10 Oct 2012 15:04:10 +0200

Hello Jonathan und Thyler,

Applying all 5 patches fixed all issues for me.

I don't get any zero sized files anymore with a full disk (find
$HOME/.Private/ -size 0c). I can even login with the user having a full
disk (before often a broken .ICEauthority made this inpossible. I could
not see any data corruptions in applications (Evolution, Iceweasel).

The dd command which fills up the disk also exits correctly.

Thanks



Message #32 received at 690071@bugs.debian.org (full text, mbox):
From: Jonathan Nieder <jrnieder@gmail.com>
To: Sebastian Heinlein <devel@glatzor.de>
Cc: 690071@bugs.debian.org, tyhicks@canonical.com
Subject: Re: ecryptfs: corrupted files on a disk full event
Date: Wed, 10 Oct 2012 14:58:56 -0700

tags 690071 - moreinfo
forwarded 690071 http://thread.gmane.org/gmane.comp.file ... eneral/280
quit

Sebastian Heinlein wrote:

> Applying all 5 patches fixed all issues for me.

Thanks; passed upstream. Hopefully these patches can be included in
kernel.org point releases soon so everyone benefits from them.
Peterle
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:59 pm

Re: Severe ecryptfs bug still present in LMDE?

Postby catweazel on Wed May 01, 2013 6:36 am

DrHu wrote:One could always use Truecrypt

+1 for that.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Severe ecryptfs bug still present in LMDE?

Postby Peterle on Wed May 01, 2013 10:28 am

The problem is that people are using ecryptfs in the standard installation process of the most prominent distros. So this is a great issue.
Peterle
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:59 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 7 guests