New EFI boot manager available: rEFInd

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Re: New EFI boot manager available: rEFInd

Postby srs5694 on Thu Mar 28, 2013 12:58 pm

YeeP wrote:For some reason I get a "listing" of two Linux OSes when I come into rEFInd. Any tips on how I can hunt down the cause of this and eliminate it? Thanks!


You may be seeing two different kernels, in which case that's expected and desirable -- if you upgrade your kernel and the new one doesn't work, you can still boot the old one.

If that's not the case, or if you want to override the behavior, there are ways to change how it works, but I can't provide specifics without specific details, like what rEFInd displays as the filename and volume name for each of the options.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Linux Mint is funded by ads and donations.
 

Re: New EFI boot manager available: rEFInd

Postby YeeP on Thu Mar 28, 2013 1:45 pm

I can provide that information.
User avatar
YeeP
Level 2
Level 2
 
Posts: 84
Joined: Thu Apr 26, 2012 5:16 pm

Re: New EFI boot manager available: rEFInd

Postby ajcm on Fri Apr 12, 2013 6:09 pm

Hello to all:

I didn't bought a pre-installed windows 8 OS PC, I only bought one motherboard Asus P8H61-M LX3 PLUS R2.0, Intel i3 core 3200 x2, and 4gb Ram(1066 mhz). I don't like install 2 OS in the same HDD, I have one HDD 500 GB for windows 7 64 bits and other HDD 500 GB to install any linux, I don't like a dual boot. I want to use mode uefi directly to install linux mint 13 64 bits, but I've only been able to install linux mint 14 64 bits uefi mode but with the RUFUS software which create "GPT partition in uefi bios" but this work more slow. Ubuntu 13.04 64 bits beta runs install directly in uefi mode but I don't like Unity, I change the desktop but it don't works fine.. My problem is I don't know much the linux system and less linux programming. I want only install linux mint 13 directly uefi mode. In the bios I have checked AHCI system sata because I have seen It works faster and I think that the uefi mode works more fast. I have two options in the bios:

-Windows UEFI: -Standard.
-Custom: 3 types of files ( It isn't Known for me)

-Other OS.

I am sorry that my English is not very good and I will not be correcting the google translator is very bad.

Thank you very much and I hope your answer.
ajcm
Level 1
Level 1
 
Posts: 2
Joined: Fri Apr 12, 2013 2:54 pm

Re: New EFI boot manager available: rEFInd

Postby srs5694 on Fri Apr 12, 2013 9:41 pm

ajcm,

As your question is about basic OS installation and not about rEFInd per se, I recommend you start a new thread for your question.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: New EFI boot manager available: rEFInd

Postby YeeP on Wed May 01, 2013 2:27 pm

srs5694 - after doing some research on the possible existence of multiple Mint kernels, I can tell you that I only have one. I do have two choices for Linux on the rEFInd menu, as well as the windows 8. So, selected the "other" one, to see what I could find. rEFInd tries to boot into BusyBox v 1.1.9.3. During the process of learning what I could and could not do with EFI, I created a live CD of BusyBox, but never installed it. Somehow it placed the kernel where rEFInd can find it. The boot never completes, as the OS is not "complete".

Any tips on how I can remove this? I am about to update rEFInd to the latest (4-25-13 release). Just in case you want to know what version I am working with.


Thanks!

EDIT:
srs5694 wrote:If that's not the case, or if you want to override the behavior, there are ways to change how it works, but I can't provide specifics without specific details, like what rEFInd displays as the filename and volume name for each of the options.


Ok, here is what is displayed...

For windows 8:
Boot EFI\Microsoft\bootmgfw.efi from 259 MiB FAT volume
For Mint 14:
Boot boot\vmlunuz-3.5.0-17generic from 74GiB ext4 volume
For possible BusyBox:
Boot vmlinuz from 74 Gib ext4 volume

Sorry I didn't include that before.
User avatar
YeeP
Level 2
Level 2
 
Posts: 84
Joined: Thu Apr 26, 2012 5:16 pm

Re: New EFI boot manager available: rEFInd

Postby srs5694 on Wed May 01, 2013 8:02 pm

Your BusyBox boot is actually a boot using your regular Mint kernel; it's just that Mint installs the kernel itself as /boot/vmlinuz-{version} and a symbolic link to it as /vmlinuz. This is an unnecessary link in most cases, although some boot loaders or tools might need it. It's booting into BusyBox because there's (presumably) no refind_linux.conf file in the Linux root (/) directory, so when you boot that OS tag, the kernel is not getting the options it needs to set everything up correctly. The easiest and safest way to get rid of the extra tag is to edit /boot/efi/EFI/refind/refind.conf and add or edit the "dont_scan_dirs" line as follows:

Code: Select all
dont_scan_dirs /


This will cause rEFInd to ignore the /vmlinuz symbolic link (and any other kernel or boot loader in the root of any partition; but you don't seem to have any such boot loaders).
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Re: New EFI boot manager available: rEFInd

Postby YeeP on Thu May 02, 2013 2:02 pm

srs5694 wrote:Your BusyBox boot is actually a boot using your regular Mint kernel; it's just that Mint installs the kernel itself as /boot/vmlinuz-{version} and a symbolic link to it as /vmlinuz. This is an unnecessary link in most cases, although some boot loaders or tools might need it. It's booting into BusyBox because there's (presumably) no refind_linux.conf file in the Linux root (/) directory, so when you boot that OS tag, the kernel is not getting the options it needs to set everything up correctly. The easiest and safest way to get rid of the extra tag is to edit /boot/efi/EFI/refind/refind.conf and add or edit the "dont_scan_dirs" line as follows:

Code: Select all
dont_scan_dirs /


This will cause rEFInd to ignore the /vmlinuz symbolic link (and any other kernel or boot loader in the root of any partition; but you don't seem to have any such boot loaders).


Will try this tonight when I get home. Thank you for the response!
User avatar
YeeP
Level 2
Level 2
 
Posts: 84
Joined: Thu Apr 26, 2012 5:16 pm

Tripple boot on Macbook air - Grub takes over - I hate it

Postby antiduplicity on Thu May 09, 2013 3:10 pm

I am trying to tripple boot on a macbook air. I install rEFind 0.6.10 and then install windows 7. Now I have two choices, mac OSX and windows. I then install mint and when I boot I have three choices, OSX, Linux or Windows. However, both windows and linux boot into grub and I have to make a second selection to choose my OS.

This is unacceptable. So I install mint first and I have two choices in the boot menu, linux and OSX. I then install windows and the mint installation goes away. I cannot see it on the rEFind menu and I cannot see it pressing the option key when I book my mac. So the windows installation nukes the mint kernel or boot loader somehow.

So this is what I want. I want to boot into the rEFind loader and when I choose OSX, I want OSX to boot. When I choose windows, I want windows to boot without grub. When I choose linux, I want mint to boot without grub.

Is this possible?

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: New EFI boot manager available: rEFInd

Postby YeeP on Thu May 09, 2013 4:31 pm

Question: why do you want to select mint, and go to grub?
User avatar
YeeP
Level 2
Level 2
 
Posts: 84
Joined: Thu Apr 26, 2012 5:16 pm

Re: Tripple boot on Macbook air - Grub takes over - I hate i

Postby srs5694 on Thu May 09, 2013 5:51 pm

antiduplicity wrote:So this is what I want. I want to boot into the rEFind loader and when I choose OSX, I want OSX to boot. When I choose windows, I want windows to boot without grub. When I choose linux, I want mint to boot without grub.

Is this possible?


Yes, it's possible. The problem you've had is almost certainly because you installed Mint in BIOS (aka CSM or legacy) mode. If you've still got the situation where you can boot OS X and Windows but not Linux, try this:

  1. In OS X, install the EFI driver for the filesystem you used on the Mint root (/) partition (or the /boot partition, if you've got a separate one). rEFInd comes with drivers for ext2/3fs, ext4fs, and ReiserFS. Installing it involves copying the file to the "drivers" subdirectory of the rEFInd installation directory (/EFI/refind if you used the default installation options). Note that you'll need to create this subdirectory first.
  2. Figure out which partition is your Mint root (/) partition. You can learn this from gdisk or some other text-mode partitioning tool.
  3. Reboot. When rEFInd comes up, you should see one or more new Linux option(s), probably with a generic penguin icon. Highlight one of these, but don't hit Enter. The caption should include a reference to a file whose name begins with "vmlinuz".
  4. Hit F2 or Insert twice. You should see a text-mode line editor launch, displaying options that will be passed to the kernel.
  5. Add "ro root=/dev/sda4" to this list of options, changing "/dev/sda4" to whatever your root (/) partition identifier is. (Note that this will begin with "/dev/sda" unless Linux is on a second disk; only the number will change.)
  6. Press Enter. Linux should boot.
  7. In Linux, run the "mkrlconf.sh" script that comes with rEFInd. This will create a configuration file called /boot/refind_linux.conf, which will eliminate the need to add the boot options when running Linux.

At this point, you should be able to reboot and launch Linux by selecting its icon and hitting Enter. Thereafter, you might want to uninstall the grub-pc package. This should guarantee that it won't cause problems in the future; but it's not really required to do this. You can also reconfigure rEFInd in various ways; see its documentation for details.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: New EFI boot manager available: rEFInd

Postby antiduplicity on Thu May 09, 2013 7:02 pm

YeeP wrote:Question: why do you want to select mint, and go to grub?


First, I don't get your question. These are the reasons I hate grub
1. I got my first computer in October of 1981. There was little software so I wrote my own. I used ANSI and test and it looked just like grub. Computers have come very far and grub is stuck in the 1980s.
2. it captures, rewrites and corrupts my windows MBR without asking. That is rude and unacceptable. If I delete mint, I cannot boot windows. This is evil and I hate it.
3. Grub lists everything including Mac OSX and it cannot boot to it, so it blindly puts things in its list that it cannot do. Bad programming, never updated and I hate it.

That is why I hate grub. Mint is elegant, smooth, modern and easy to look at and use.
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: Tripple boot on Macbook air - Grub takes over - I hate i

Postby antiduplicity on Thu May 09, 2013 8:32 pm

srs5694 wrote:
antiduplicity wrote:So this is what I want. I want to boot into the rEFind loader and when I choose OSX, I want OSX to boot. When I choose windows, I want windows to boot without grub. When I choose linux, I want mint to boot without grub.

Is this possible?


Yes, it's possible. The problem you've had is almost certainly because you installed Mint in BIOS (aka CSM or legacy) mode. If you've still got the situation where you can boot OS X and Windows but not Linux, try this:

  1. In OS X, install the EFI driver for the filesystem you used on the Mint root (/) partition (or the /boot partition, if you've got a separate one). rEFInd comes with drivers for ext2/3fs, ext4fs, and ReiserFS. Installing it involves copying the file to the "drivers" subdirectory of the rEFInd installation directory (/EFI/refind if you used the default installation options). Note that you'll need to create this subdirectory first.
  2. Figure out which partition is your Mint root (/) partition. You can learn this from gdisk or some other text-mode partitioning tool.
  3. Reboot. When rEFInd comes up, you should see one or more new Linux option(s), probably with a generic penguin icon. Highlight one of these, but don't hit Enter. The caption should include a reference to a file whose name begins with "vmlinuz".
  4. Hit F2 or Insert twice. You should see a text-mode line editor launch, displaying options that will be passed to the kernel.
  5. Add "ro root=/dev/sda4" to this list of options, changing "/dev/sda4" to whatever your root (/) partition identifier is. (Note that this will begin with "/dev/sda" unless Linux is on a second disk; only the number will change.)
  6. Press Enter. Linux should boot.
  7. In Linux, run the "mkrlconf.sh" script that comes with rEFInd. This will create a configuration file called /boot/refind_linux.conf, which will eliminate the need to add the boot options when running Linux.

At this point, you should be able to reboot and launch Linux by selecting its icon and hitting Enter. Thereafter, you might want to uninstall the grub-pc package. This should guarantee that it won't cause problems in the future; but it's not really required to do this. You can also reconfigure rEFInd in various ways; see its documentation for details.


Thank you. Now, how do I fix windows which still comes up with grub.
I searched the web to find out how to uninstall grub-pc and cannot find anything intelligent

I also tried to run mkrlconf.sh like "sudo ./mkrlconf.sh" and I am told that the command cannot be found.

Any help on these items would be appreciated. If I need to wipe and reinstall windows I will, I a, just hoping there is a way

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: New EFI boot manager available: rEFInd

Postby YeeP on Thu May 09, 2013 10:14 pm

The reason I asked what I did was you should not need to use grub at all. I have refind running with mint and windows, grub never comes into the picture (visually). I also dislike grub and am glad to not use it.
User avatar
YeeP
Level 2
Level 2
 
Posts: 84
Joined: Thu Apr 26, 2012 5:16 pm

Re: New EFI boot manager available: rEFInd

Postby antiduplicity on Thu May 09, 2013 10:56 pm

YeeP wrote:The reason I asked what I did was you should not need to use grub at all. I have refind running with mint and windows, grub never comes into the picture (visually). I also dislike grub and am glad to not use it.


Have you uninstall grub? I would like to, but I cannot find out how searching the internet.

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: Tripple boot on Macbook air - Grub takes over - I hate i

Postby srs5694 on Thu May 09, 2013 11:03 pm

antiduplicity wrote:Thank you. Now, how do I fix windows which still comes up with grub.


Are you saying that when you select Windows in rEFInd, GRUB appears? If so, I suggest trying either or both of two things:

  • Create a fresh hybrid MBR, being sure to include the Windows partition. (You can omit both the OS X and Linux partitions.) GPT fdisk (gdisk) is the most flexible tool for this, but you could use gptsync, which comes with rEFInd, if you prefer. (Note that you'll need to activate it by uncommenting the "showtools" line in refind.conf and ensuring that the line includes the "gptsync" option. This is deliberately a nuisance to activate because hybrid MBRs are dangerous; even though they're necessary to boot Windows in BIOS mode on Macs, I don't want people accidentally creating them when they aren't needed.)
  • Boot a Windows recovery disc and use its tools to re-install the Windows boot loader. I can't be more specific than this because I work so little with Windows that I'm only vaguely familiar with the procedure.

I searched the web to find out how to uninstall grub-pc and cannot find anything intelligent


Use dpkg, as in "sudo dpkg -P grub-pc", or your favorite GUI package manager.

I also tried to run mkrlconf.sh like "sudo ./mkrlconf.sh" and I am told that the command cannot be found.


It comes with rEFInd; you'll need to extract the rEFInd .zip file, locate the command in the extracted contents, and run it from there.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

mkrconf.sh does not work

Postby antiduplicity on Fri May 10, 2013 12:27 am

Greetings,
I did all the EFI stuff with rEFind and ran mkrconf.sh. The file refind_linux.conf was created in /boot
This is the contents of that file
"Boot with standard options" "ro root=UUID=e302a456-d464-492c-9ea7-c9aea2976cfe quiet splash "
"Boot to single-user mode" "ro root=UUID=e302a456-d464-492c-9ea7-c9aea2976cfe quiet splash single"
"Boot with minimal options" "ro root=UUID=e302a456-d464-492c-9ea7-c9aea2976cfe"

When I boot through rEFind and a bunch of linux stuff appears on the screen and gets stuck at "attached SCSI devices" and never completes boot

now, if I press F2 twice on the rEFind screen and enter ro root=/dev/sda5 Mint boots like a champ

So, what am I missing?

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: New EFI boot manager available: rEFInd

Postby srs5694 on Fri May 10, 2013 12:20 pm

Michael,

Try editing refind_linux.conf and move the "Boot with minimal options" item to the top of the file. That will make it the default. (You can test this without making any changes by hitting F2 or Insert once and selecting "Boot with minimal options" from the menu.) If that doesn't work, try replacing "root=UUID=e302a456-d464-492c-9ea7-c9aea2976cfe" in that line with "root=/dev/sda5"; it's conceivable that the UUID form of specifying the boot device isn't working for some reason.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: New EFI boot manager available: rEFInd

Postby antiduplicity on Fri May 10, 2013 12:43 pm

srs5694 wrote:Michael,

Try editing refind_linux.conf and move the "Boot with minimal options" item to the top of the file. That will make it the default. (You can test this without making any changes by hitting F2 or Insert once and selecting "Boot with minimal options" from the menu.) If that doesn't work, try replacing "root=UUID=e302a456-d464-492c-9ea7-c9aea2976cfe" in that line with "root=/dev/sda5"; it's conceivable that the UUID form of specifying the boot device isn't working for some reason.


Alas, these options do not work. Depending on what I do, the boot will freeze at different points. The ONLY way I can get it to boot is to press F2 twice and enter ro root=/dev/sda5 in the rEFind screen.

What am I missing? :roll:

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Re: New EFI boot manager available: rEFInd

Postby srs5694 on Fri May 10, 2013 6:34 pm

antiduplicity wrote:Alas, these options do not work. Depending on what I do, the boot will freeze at different points. The ONLY way I can get it to boot is to press F2 twice and enter ro root=/dev/sda5 in the rEFind screen.

What am I missing? :roll:


Try writing down the complete entry you see when you edit the boot options (both what was there before and your "ro root=/dev/sda5") and enter them as a new option in refind_linux.conf, at the top of the file. If that works, try removing the "initrd={whatever}" option from your new entry, since rEFInd should be able to add that automatically -- and in fact it does before you edit the options manually.

For debugging purposes, I'd be interested in seeing the output of the following commands from a successful boot:

Code: Select all
df -h
dmesg | grep "command line"
ls -l /boot/[bvi]*


Those may give me some clue about what's going wrong.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: New EFI boot manager available: rEFInd

Postby antiduplicity on Fri May 10, 2013 6:39 pm

srs5694 wrote:
antiduplicity wrote:Alas, these options do not work. Depending on what I do, the boot will freeze at different points. The ONLY way I can get it to boot is to press F2 twice and enter ro root=/dev/sda5 in the rEFind screen.

What am I missing? :roll:


Try writing down the complete entry you see when you edit the boot options (both what was there before and your "ro root=/dev/sda5") and enter them as a new option in refind_linux.conf, at the top of the file. If that works, try removing the "initrd={whatever}" option from your new entry, since rEFInd should be able to add that automatically -- and in fact it does before you edit the options manually.

For debugging purposes, I'd be interested in seeing the output of the following commands from a successful boot:

Code: Select all
df -h
dmesg | grep "command line"
ls -l /boot/[bvi]*


Those may give me some clue about what's going wrong.


Found the problem. I was messing around with the refind.conf and told it not to search for linux installations. Now it comes up with two. One that works find by itself and one that looks for grub unless I edit the paramters. So, hopefully the final tweak. How do I get refind to only display 1 linux icon during boot?

Michael
antiduplicity
Level 1
Level 1
 
Posts: 10
Joined: Wed May 08, 2013 4:05 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Installation & Boot

Who is online

Users browsing this forum: D_M_R and 21 guests