Keyboard shortcuts not working ( mint 14 cinnamon )

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby cpsully69 on Sat Dec 08, 2012 4:00 pm

Thank you electrickite!!!

I've been trying for a week to replace Ctrl-Alt-T from launching terminal to launching terminator (my fav!)

Cinnamon settings wouldn't let me deleted the "Launch Terminal" binding, I could disable it (no effect), and even redefined it to /usr/bin/terminator (no effect).

I REALLY appreciate your contribution!
cpsully69
Level 1
Level 1
 
Posts: 7
Joined: Wed Jun 09, 2010 9:38 am

Linux Mint is funded by ads and donations.
 

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Redsandro on Fri Dec 14, 2012 10:31 pm

aelfinn wrote:It doesn’t seem to resolve my particular problem of trying to assign shortcuts using the Windows, or Super, key. In LM13’s Cinnamon edition, that was still possible. Or is it something about your workaround that prevents that from happening?

I have the same problem. It looks like no one uses the windows/super/mod5 key except us.
Redsandro
Level 3
Level 3
 
Posts: 105
Joined: Sun Jul 17, 2011 6:40 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Fri Dec 14, 2012 10:47 pm

I have the same problem. It looks like no one uses the windows/super/mod5 key except us.


I used to use it for all my custom shortcuts, but I switched to an IBM Type-M keyboard on my Mint 14 machine and it doesn't have a Super key. I kinda miss it (now I'm stuck with the few unused function keys) but my keys are so clicky that I guess it's worth it. :lol:
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby rafi on Wed Jan 02, 2013 11:58 pm

Hi,

I can confirm that the windows key can not be used for a user-defined keyboard shortcut on a fresh install of Linux Mint 14 Nadia (and did not work on Mint 13 Maya either). Also, the above-mentioned workaround does not work.

However, on Linux Mint 13 Maya, the following workaround worked:
Code: Select all
sudo apt-get install gconf-editor
start it up, and then in the tabs navigate to
Code: Select all
apps->metacity->global_keybindings and keybinding_commands
The two parameters did the trick together with the windows key written as <Super>. Well, so I tried this again in Mint 14, but alas, there is no metacity key anymore in gconf-editor. Is there a way to get this key back?

Also, I tried using
Code: Select all
xfce4-keyboard-settings
which had been suggested elsewhere but that, too, did not work for me to assign a keyboard shortcut to the windows key.

Any ideas?

Cheers,
rafi
rafi
Level 1
Level 1
 
Posts: 10
Joined: Wed Jan 02, 2013 11:46 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby rafi on Thu Jan 03, 2013 12:08 am

ah, and I also tried to use xbindkeys but with no success. Seems some nasty gnome catches the pressed keys and uses it for its purposes... rats!
rafi
Level 1
Level 1
 
Posts: 10
Joined: Wed Jan 02, 2013 11:46 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby asobczak on Sun Jan 06, 2013 7:49 am

This seams to be wider problem. It is not only Super-D and other custom keys disappeared. My keyboard, after upgrade, behave unpredictably. I use Super-E to start terminal. Now I need to stroke it twice. Custom shortcuts works 'at their own discretion'.
In Pluma or Gedit, my favourite function Ctr-F is disabled. While in Gedit, Super-E result is added 'e' in code - what a nice experience at next run.
Something definitly not defined in keyboard....hope gurus will fix it
Intel® Sandybridge Desktop 64b Intel® Core™ i3-2120 CPU @ 3.30GHz × 4 MEM 3,8 GiB
Kernel 3.10-2-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Distribution : Linux Mint Debian Edition
User avatar
asobczak
Level 1
Level 1
 
Posts: 30
Joined: Sun Jun 10, 2012 5:32 pm
Location: Warsaw, Poland

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Fri Jan 11, 2013 10:04 pm

Garvan wrote:xkb has a cache, and it does not like to clean it. Try deleting everything in this folder.

Code: Select all
/var/lib/xkb


Garvan
Forgive my noobishness, but what are the potential ill effects of deleting files from this folder?

I am using the workaround posted by electrickite to create custom shortcuts, but none of my keyboard shortcuts (default pre-defined or custom) work consistently. Ctrl-Alt-T launches terminal 1 out of 10 times. Ctrl-Alt-Backspace logs out 1 out of 3 times at best. Custom Ctrl-Shift-X for xkill is probably 1 out of 10 times as well. (Luckily Mint seems to be pretty stable overall so I haven't need xkill -- all 10 attempts were simply testing.)
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Thu Jan 17, 2013 8:54 pm

So I deleted the files in /var/lib/xkb/ and restarted to no avail. Most shortcuts seem to work, but no custom shortcuts and none of the default "launcher" shortcuts. I really just want to be able to open a terminal and use xkill with shortcuts. Has anybody had success recently? I think I'm using the alternate keyboard in electrickite's workaround, however I got it from here before finding this thread. The only difference I can see is in the version I'm using the second instance of
Code: Select all
Name=
says Keyboard Alternate instead of just Keyboard and at the end of the file electrickite's version has this
Code: Select all
# Translators: those are keywords for the keyboard control-center panel
Keywords=Shortcut;Repeat;Blink;
X-Ubuntu-Gettext-Domain=gnome-control-center-2.0
# Translators: those are keywords for the keyboard control-center panel
Keywords=Shortcut;Repeat;Blink;
X-Ubuntu-Gettext-Domain=gnome-control-center-2.0

while the version I'm using just has this
Code: Select all
Keywords=Shortcut;Repeat;Blink;
X-Ubuntu-Gettext-Domain=gnome-control-center-2.0
Everything else seems the same. If anyone has any suggestions I'd really appreciate it. Thanks.
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Fri Jan 18, 2013 7:25 pm

https://bbs.archlinux.org/viewtopic.php?id=150587&p=3

Anyone know if this patch would help? If so, how would I install this patch?
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Sat Jan 19, 2013 8:55 am

Okay, after using the electrickite workaround, there are at least four ways I can think of to set up keyboard shortcuts. None of them are consistently working for me.
1. Cinnamon settings -- keyboard
2. Preferences -- keyboard
2.1. Preferences -- keyboard alternate
3. $ gsettings
4. dconf

Is there something else I can try to get shortcuts for launching a terminal and for xkill working? Thanks.
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Sun Jan 20, 2013 6:33 pm

Since xkbmap sets the ctrl-alt-backspace that always works, is there any xkbmp option/command I can use to reliably start other shortcuts?
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby kiweegie on Tue Jan 29, 2013 6:39 pm

Hey electrickite - you have *no* idea how thankful I am to have found your workaround for keybindings under Cinnamon. I use shutter constantly and love Mint Cinnamon but until today had no way of getting the keybindings to play nice. Your workaround... worked!

I have added your solution (crediting you of course with link back to this post) to http://shutter-project.org/faq-help/set-shutter-as-the-default-screenshot-tool where there are keybinding how-tos for Gnome, Unity, KDE, XFCE and LXDE but oddly (given Mints status as number one on distrowatch) none for either Mate nor Cinnamon.

I'm hoping your workaround helps out other Cinnamon shutter users.

Thanks again.
kiweegie
Level 1
Level 1
 
Posts: 2
Joined: Tue Jan 29, 2013 11:15 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby llogg on Wed Jan 30, 2013 7:43 pm

And now my screen cap shortcuts don't work. Help?
Intel Pentium Dual 2.00 GHz
2Gb RAM
Linux Mint Cinnamon 14
llogg
Level 3
Level 3
 
Posts: 112
Joined: Sat Feb 12, 2011 6:56 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby barcinka on Sat Feb 16, 2013 11:07 am

Thank you, electrickite! Good job :)
Linux Mint 15 Cinnamon 64 bit.
barcinka
Level 1
Level 1
 
Posts: 6
Joined: Sat Feb 16, 2013 11:02 am
Location: Slovakia

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Redsandro on Wed Feb 20, 2013 2:27 pm

Pull request was merged and closed over two months ago, but I haven't received a working update yet. Still need this trickery.

Anyone got the fix yet?
Redsandro
Level 3
Level 3
 
Posts: 105
Joined: Sun Jul 17, 2011 6:40 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Sat Feb 23, 2013 2:22 pm

Redsandro wrote:Pull request was merged and closed over two months ago

Do you have a link for that?
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby dyfet on Wed Apr 03, 2013 1:20 pm

This bug hit me too. I am starting a package of tiny x11 helper apps (http://dev.gnutelephony.org/gitweb/?p=p ... ;a=summary) to do some window management functions that are currently missing in muffin and sometimes elsewhere, starting with one to simply "rotate" workspaces, since the built-in ones for muffin only has options to go left/right, rather than going back to ws 0 after reaching the end of the list. On xfce4 (xfwm has this feature) I normally bind this functionality to super-tab (and rotate back to super-backtab), and really the choice was from kde which uses super-tab to rotate activities...

Anyway yes, creating new custom shortcuts from cinnamon's keyboard control do not seem to work as noted here, though any of the existing built-in muffin/cinnamon shortcuts can be re-pogrammed. New custom keyboard entries can be created instead from gnome control center keyboard control, also as noted in this thread, but they behave strangely if you assign super as part of the sequence. At best, if I hold down super, and press tab twice, it worked, and then kept jumping as expected so long as I kept holding down super and hit tab again after... I decided to assign to control-tab instead :), and that works fine...
"Information in the computer age is the last genuine free market left on earth except those free markets where indigenous people are still surviving"
User avatar
dyfet
Level 1
Level 1
 
Posts: 3
Joined: Thu Sep 08, 2011 6:14 am
Location: Cape May

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby phredbull on Sun May 12, 2013 1:50 am

Redsandro wrote:
aelfinn wrote:It doesn’t seem to resolve my particular problem of trying to assign shortcuts using the Windows, or Super, key. In LM13’s Cinnamon edition, that was still possible. Or is it something about your workaround that prevents that from happening?

I have the same problem. It looks like no one uses the windows/super/mod5 key except us.

I'm using an Apple keyboard & was able to rectify some weirdness here:
System Settings>Keyboard, then on the bottom right is a button that says "Layout Settings"
Under the "Layouts" tab, you can make sure you have the correct keyboard selected, and test all of the keys, w/visual feedback. Then from there, if you click "Options..." on the bottom right, there are a LOT of settings regarding Command, Super, Alt, Ctrl, etc.

Although my Command key still seems to not work in combination with any letter keys or Space.

But I'm STILL having key command issues as well. They work in a way that any tech hates to hear, "intermittently". Usually, the pre-defined ones seem ok, and the ones I set up w/arrow & number keys for workspace & window management seem ok. But for example, I have Alt + w to launch Firefox, and sometimes, it doesn't work. Sometimes, it works after a few tries. And sometimes, it works when I hold the keys for a bit. I can't make any sense out of it, & hope it'll get fixed in an update.
Apple iMac, Core2Duo 2.0gHz, 3gb, ATI Radeon Mobility X1600
-Mint Nadia Cinnamon
-Mac OSX 10.5.8
Compaq Evo N610c, P4M 2.8gHz, 7688mb, ATI Radeon m7500
-LMDE XFCE
-Mint Katya Gnome
-Windoze XP
Ext. HD
-Mint Isadora Fluxbox
USB stick
-#! Statler
User avatar
phredbull
Level 1
Level 1
 
Posts: 42
Joined: Wed Dec 01, 2010 8:55 pm
Location: Chicago, IL, USA

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby cipri_tom on Mon May 20, 2013 3:09 pm

Very interesting is that the shortcut for 'Home Folder' appears not to work ... unless you're insistent haha.
What I mean by that is that a normal press of "Super + E" has no effect, but if you double press it a bit fast, like a double click, that the home folder will pop up. Or if you press it for a bit longer.

EDIT: Cinnamon 1.6.7
cipri_tom
Level 1
Level 1
 
Posts: 9
Joined: Fri Oct 26, 2012 5:11 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon ) [SOL

Postby goinglinux on Fri May 31, 2013 9:55 am

It's fixed in Mint 15 Cinnamon. Thankyou Mint development team!

  • Cinnamon Settings>Switch to Advanced Mode>Keyboard>Keyboard shortcuts>Custom Shortcuts>Add custom shortcut
  • Enter a name and choose a command to run
  • Click "unassigned" twice
  • Press the key combination you want to assign to your shortcut
____________________
Larry Bushey
· Going Linux Podcast ·
http://goinglinux.com
Mint 17 Cinnamon Edition 64-bit · System 76 Galago UltraPro · Core i7 · 16GB RAM · 120 GB mSATA · 512 GB SSD
User avatar
goinglinux
Level 1
Level 1
 
Posts: 34
Joined: Wed May 05, 2010 9:42 am
Location: USA

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Cinnamon

Who is online

Users browsing this forum: Hugo_vH, JonS and 6 guests