LMDE Breakages (Tracking SID)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Mon May 13, 2013 7:44 am

GeneC wrote:
libc6 went through for me. Clean DU just completed.

Code: Select all
Commit Log for Mon May 13 07:05:32 2013


Upgraded the following packages:
bsdutils (1:2.20.1-5.3) to 1:2.20.1-5.4
cdrdao (1:1.2.3-1) to 1:1.2.3-2
console-setup (1.92) to 1.93
console-setup-linux (1.92) to 1.93
cpp-4.7 (4.7.3-3) to 4.7.3-4
desktop-file-utils (0.20-0.1) to 0.21-1
dialog (1.1-20120215-3) to 1.2-20121230-1
g++-4.7 (4.7.3-3) to 4.7.3-4
gcc-4.7 (4.7.3-3) to 4.7.3-4
gcc-4.7-base (4.7.3-3) to 4.7.3-4
gcc-4.8-base (4.8.0-6) to 4.8.0-7
gedit (3.4.2-1) to 3.4.2-1+b1
gir1.2-freedesktop (1.36.0-2) to 1.36.0-2+b1
gir1.2-glib-2.0 (1.36.0-2) to 1.36.0-2+b1
gir1.2-peas-1.0 (1.4.0-2) to 1.4.0-2+b1
gir1.2-totem-1.0 (3.0.1-8) to 3.0.1-8+b1
gjs (1.32.0-5) to 1.32.0-5+b1
gnome-shell (3.4.2-7) to 3.4.2-7+b1
keyboard-configuration (1.92) to 1.93
libbit-vector-perl (7.2-1) to 7.2-2
libblkid1 (2.20.1-5.3) to 2.20.1-5.4
libc-bin (2.17-1) to 2.17-2
libc-dev-bin (2.17-1) to 2.17-2
libc6 (2.17-1) to 2.17-2
libc6-dev (2.17-1) to 2.17-2
libcairo-perl (1.090-2) to 1.103-2
libgbm1 (8.0.5-4) to 8.0.5-4+b1
libgcc-4.7-dev (4.7.3-3) to 4.7.3-4
libgcc1 (1:4.8.0-6) to 1:4.8.0-7
libgfortran3 (4.8.0-6) to 4.8.0-7
libgirepository-1.0-1 (1.36.0-2) to 1.36.0-2+b1
libgjs0b (1.32.0-5) to 1.32.0-5+b1
libgl1-mesa-dri (8.0.5-4) to 8.0.5-4+b1
libgl1-mesa-glx (8.0.5-4) to 8.0.5-4+b1
libglapi-mesa (8.0.5-4) to 8.0.5-4+b1
libglib-perl (3:1.260-1) to 3:1.280-2
libglib2.0-0 (2.36.1-2) to 2.36.1-2build1
libglib2.0-bin (2.36.1-2) to 2.36.1-2build1
libglib2.0-data (2.36.1-2) to 2.36.1-2build1
libglu1-mesa (8.0.5-4) to 8.0.5-4+b1
libgomp1 (4.8.0-6) to 4.8.0-7
libitm1 (4.8.0-6) to 4.8.0-7
liblensfun-data (0.2.5-2) to 0.2.7-2
liblensfun0 (0.2.5-2) to 0.2.7-2
libmount1 (2.20.1-5.3) to 2.20.1-5.4
libopenvg1-mesa (8.0.5-4) to 8.0.5-4+b1
libopus0 (0.9.14+20120615-1+nmu1) to 1.1~alpha+20130512-1
libpeas-1.0-0 (1.4.0-2) to 1.4.0-2+b1
libquadmath0 (4.8.0-6) to 4.8.0-7
libseed-gtk3-0 (3.2.0-2) to 3.2.0-2+b1
libstdc++6 (4.8.0-6) to 4.8.0-7
libstdc++6-4.7-dev (4.7.3-3) to 4.7.3-4
libtotem0 (3.0.1-8) to 3.0.1-8+b1
libuuid1 (2.20.1-5.3) to 2.20.1-5.4
locales (2.17-1) to 2.17-2
medit (1.0.93-1) to 1.1.1-2
mount (2.20.1-5.3) to 2.20.1-5.4
multiarch-support (2.17-1) to 2.17-2
python-gobject-2 (2.28.6-12) to 2.28.6-12+b1
python-xapian (1.2.12-2) to 1.2.15-2
totem (3.0.1-8) to 3.0.1-8+b1
totem-mozilla (3.0.1-8) to 3.0.1-8+b1
totem-plugins (3.0.1-8) to 3.0.1-8+b1
util-linux (2.20.1-5.3) to 2.20.1-5.4
uuid-runtime (2.20.1-5.3) to 2.20.1-5.4


Let me ammend that. Problem with Display Manager (MDM). Note this install is LMDE/Gnome (hence MDM).
Choosing 'log-out' or (ctrl+alt+Backspace) yields command line, not MDM.
Cant launch MDM (log-in screen)
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby SirSelim on Tue May 14, 2013 1:30 am

wayne128 wrote:Also, now grub2 is version 2.00.


Have you had any problems with this upgrade? I'm getting a couple of bugs showing up within grub2 when I dist-upgrade:
Code: Select all
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  grub-common grub-pc grub-pc-bin grub2-common
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,104 kB of archives.
After this operation, 3,141 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
critical bugs of grub2-common (1.99-27.1 -> 2.00-14) <unfixed>
 #707653 - grub2-common: After Grub 2.00-14 upgrade, system failed to boot (rescue, old grub 1.99 still in mbr)
critical bugs of grub-pc (1.99-27.1 -> 2.00-14) <unfixed>
 #708123 - [grub-pc] grub2 (2.00-14) fails to install on RAID arrays (rescue, boot is broken)
Summary:
 grub2-common(1 bug), grub-pc(1 bug)
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Tue May 14, 2013 1:48 am

SirSelim wrote:
wayne128 wrote:Also, now grub2 is version 2.00.


Have you had any problems with this upgrade? I'm getting a couple of bugs showing up within grub2 when I dist-upgrade:


@SirSelim,
No, I do not have issue with the listed bugs.
But I have to say this: my method of installing grub2 is different from common method ( of installing onto MBR)

1. I DO NOT have grub2 on MBR. My MBR is controlled by grub legacy.

2. for my Debian-xfce-SID partition, I have its grub2 installed onto the root partition.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Tue May 14, 2013 7:12 am

SirSelim wrote:
wayne128 wrote:Also, now grub2 is version 2.00.


Have you had any problems with this upgrade? I'm getting a couple of bugs showing up within grub2 when I dist-upgrade:


I saw the reported bugs but let grub2 update. No serious issues with a quad boot. Only thing noted is with Grub-Customizer. It no longer lets me choose a custom background picture. The one I had been using for many months no longer loads, nor any other I try. It always defaults to std. background. I still can edit text, order, hide entries, et. Not a big issue.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby gcp on Sat May 18, 2013 3:59 am

If you are a user of nautilus-compare you see its b0rken.
You can repair it with these commands as root:

ln -s /usr/lib/x86_64-linux-gnu/libpython2.7.so /usr/lib/libpython.2.7.so
ln -s /usr/lib/x86_64-linux-gnu/libpython2.7.so.1 /usr/lib/libpython.2.7.so.1
ldconfig
reboot

see https://bugs.launchpad.net/nautilus-compare/+bug/1172953
Looks like a problem with multiarch... :wink:
<login2 debianSID><sudo apt-get dist-upgrade><DONTTHINK><ENTER><WHOCARES><ENTER><OOHHNOO!><HAVENOBACKUP,IM-A-MAN><reinstalling,Windowslike...>
User avatar
gcp
Level 1
Level 1
 
Posts: 27
Joined: Sat Jul 02, 2011 6:24 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GregE on Mon May 20, 2013 7:18 am

Regulus74 wrote:When I launch alacarte:

Traceback (most recent call last):
File "/usr/bin/alacarte", line 23, in <module>
from Alacarte.MainWindow import MainWindow
File "/usr/share/alacarte/Alacarte/MainWindow.py", line 32, in <module>
from Alacarte.MenuEditor import MenuEditor
File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 23, in <module>
from Alacarte import util
File "/usr/share/alacarte/Alacarte/util.py", line 25, in <module>
from gi._glib import GError
ImportError: cannot import name GError

and Nautilus Search button does not work :( :evil:


Hi Regulus, I posted this in the Gnome3 thread a few days ago, but it is not Gnome specific.

If you are sick of the constant battles to keep Alacarte running (and mine is broken again) then try this

https://launchpad.net/menulibre

It is written for Ubuntu but there is nothing Ubuntu specific about it. It installs in opt, and I had to use itself to fix up the menu item for it, but now it is all good.

Menu editing that works.
User avatar
GregE
Level 4
Level 4
 
Posts: 454
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Mon May 20, 2013 4:02 pm

For what it's worth, I've taken a moment to compare the util.py files from both Debian's version and the version shipping in the GNOME 3 PPA for Ubuntu Raring.

Here's what I get:
Code: Select all
22d21
< from gi.repository import Gtk, GdkPixbuf, GMenu, GLib
24,25c23,25
< # XXX: look into pygobject error marshalling
< from gi._glib import GError
---
> import gi
> gi.require_version('Gtk', '3.0')
> from gi.repository import Gtk, GdkPixbuf, GMenu, GLib
37,38d36
<         elif isinstance(item, Sequence):
<             keyfile.set_string_list(DESKTOP_GROUP, key, item)
40a39,40
>         elif isinstance(item, Sequence):
>             keyfile.set_string_list(DESKTOP_GROUP, key, item)
156c156
<     except GError:
---
>     except GLib.GError:


I'm not entirely sure if there are any differences in any of the other files that would also need to be made in order to have Alacarte fully functioning again, so it's definitely easier just to grab the package from the GNOME 3 PPA here, if you would prefer to use it.

I can only imagine Alacarte will eventually be brought up-to-date in Debian for GNOME 3.8 and the changes to the GI repository that are currently breaking the GNOME 3.6 version, but until then borrowing the up-to-date package from the Ubuntu GNOME 3 PPA works.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Wed May 22, 2013 12:57 am

today, trying to d-u..

copy terminal output here

101 upgraded, 21 newly installed, 27 to remove and 3 not upgraded.

since I am running xfce, how to allow d-u to remove xfce? :lol:
may be xfce 4.10 is coming into sid..
so holding on. :mrgreen:

Code: Select all
The following packages will be REMOVED:
  orage task-xfce-desktop xfce4 xfce4-battery-plugin xfce4-clipman-plugin
  xfce4-cpufreq-plugin xfce4-cpugraph-plugin xfce4-datetime-plugin xfce4-dict
  xfce4-diskperf-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-goodies
  xfce4-mailwatch-plugin xfce4-mount-plugin xfce4-netload-plugin
  xfce4-notes-plugin xfce4-places-plugin xfce4-quicklauncher-plugin
  xfce4-sensors-plugin xfce4-smartbookmark-plugin xfce4-systemload-plugin
  xfce4-timer-plugin xfce4-verve-plugin xfce4-wavelan-plugin
  xfce4-weather-plugin xfce4-xkb-plugin
The following NEW packages will be installed:
  evince-common evince-gtk libdjvulibre-text libdjvulibre21 libevdocument3-4
  libevview3-3 libgtksourceview2.0-0 libgtksourceview2.0-common libgxps2
  libkpathsea6 libmnl0 libspectre1 libt1-5 libxfce4util6
  linux-headers-3.8-2-686-pae linux-headers-3.8-2-common
  linux-image-3.8-2-686-pae python3 python3-minimal python3.2
  python3.2-minimal
The following packages have been kept back:
  libsnmp-base xfce4-appfinder xfce4-session
The following packages will be upgraded:
  acl dnsmasq-base enchant exo-utils file fonts-opensymbol gtk2-engines-xfce
  libacl1 libattr1 libavcodec53 libavformat53 libavutil51
  libcommons-compress-java libenchant1c2a libevent-2.0-5 libexo-1-0
  libexo-common libexo-helpers libfftw3-3 libfftw3-double3 libfftw3-single3
  libgarcon-1-0 libgarcon-common libgeoip1 libmad0 libmagic1
  libnetfilter-conntrack3 libnl-3-200 libnl-genl-3-200 libnl-route-3-200
  libpostproc52 libpython2.7 libpython2.7-dev libpython2.7-minimal
  libpython2.7-stdlib libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge
  libreoffice-filter-mobiledev libreoffice-gtk libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libselinux1 libsemanage-common libsemanage1 libsepol1 libsqlite3-0 libssh2-1
  libstartup-notification0 libswscale2 libthunarx-2-0 libtumbler-1-0
  libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfcegui4-4
  libxfconf-0-2 linux-headers-686-pae linux-image-686-pae mousepad os-prober
  printer-driver-m2300w printer-driver-ptouch python-uno python2.7
  python2.7-dev python2.7-minimal sgml-data task-desktop task-english
  task-laptop task-print-server tasksel tasksel-data thunar thunar-data
  thunar-volman tumbler tumbler-common ucf uno-libs3 ure
  xfce-keyboard-shortcuts xfce4-mixer xfce4-panel xfce4-power-manager
  xfce4-power-manager-data xfce4-settings xfce4-terminal xfconf xfdesktop4
  xfdesktop4-data xfwm4
101 upgraded, 21 newly installed, 27 to remove and 3 not upgraded.
Need to get 164 MB of archives.
After this operation, 125 MB of additional disk space will be used.
Do you want to continue [Y/n]?
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

kernel 3.8

Postby wayne128 on Wed May 22, 2013 1:14 am

Separate subject: Kernel 3.8
=======================
I played with several distros release recently, ubuntu1304/xubuntu/kubuntu/netrunner/mint15rc/etc

and one observation, from testing them over 4 computers.
Mint15RC cannot boot two of the 4 computers
kubuntu/netrunner have lots of kernel panic on their default 3.8.0-19/2x kernel.
xubuntu, still similar to last few release, always busy asking me to send crash report.

a quick test on netrunner 1306 beta installing kernel 3.9.3 resolved kernel panic for the last 10 reboots.
have been playing with it for last few days.
very nice distros :mrgreen:

While I do not know what was the real issue on frequent kernel panic and crash over these computers ( yeah, may be just the hardware or me :mrgreen: ), it seems to suggest kernel 3.8 is not too happy with these 4 computers... exception is Debian-xfce-sid, which is
3.8-1-686-pae. I was thinking to install new Debian sid kernel but is holding on due to 'xfce-removal' as in above post.

May be others can give some hints.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: kernel 3.8

Postby GregE on Wed May 22, 2013 2:53 am

wayne128 wrote:Separate subject: Kernel 3.8
kubuntu/netrunner have lots of kernel panic on their default 3.8.0-19/2x kernel.
xubuntu, still similar to last few release, always busy asking me to send crash report.


I have read that 3.8 kernel oops are a plague in Ubuntu land, particularly Xubuntu. I cannot confirm, my Xubuntu box with an AMD E350 has had no issues. My main desktop running Sid/Gnome-Shell with retrofitted Mint bits and a standard Debian 3.8 kernel is rock solid. I would expect Ubuntu to quickly fix whatever is causing the issue for them.

Anyway, I would not be assuming hardware in this case. Debian is in the process of updating to a newer gcc base which is probably why it wants to un-install xfce. A few days wait will probably fix the dependency issues.

On a different note Sid and a new 3.8 kernel on my notebook now loads Broadcom wifi without having to muck about with firmware or modprobe. That is a great leap forward (for me).
User avatar
GregE
Level 4
Level 4
 
Posts: 454
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Wed May 22, 2013 8:18 am

wayne128 wrote:today, trying to d-u..

copy terminal output here

101 upgraded, 21 newly installed, 27 to remove and 3 not upgraded.

since I am running xfce, how to allow d-u to remove xfce? :lol:
may be xfce 4.10 is coming into sid..
so holding on. :mrgreen:

Code: Select all
The following packages will be REMOVED:
  orage task-xfce-desktop xfce4 xfce4-battery-plugin xfce4-clipman-plugin
  xfce4-cpufreq-plugin xfce4-cpugraph-plugin xfce4-datetime-plugin xfce4-dict
  xfce4-diskperf-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-goodies
  xfce4-mailwatch-plugin xfce4-mount-plugin xfce4-netload-plugin
  xfce4-notes-plugin xfce4-places-plugin xfce4-quicklauncher-plugin
  xfce4-sensors-plugin xfce4-smartbookmark-plugin xfce4-systemload-plugin
  xfce4-timer-plugin xfce4-verve-plugin xfce4-wavelan-plugin
  xfce4-weather-plugin xfce4-xkb-plugin
The following NEW packages will be installed:
  evince-common evince-gtk libdjvulibre-text libdjvulibre21 libevdocument3-4
  libevview3-3 libgtksourceview2.0-0 libgtksourceview2.0-common libgxps2
  libkpathsea6 libmnl0 libspectre1 libt1-5 libxfce4util6
  linux-headers-3.8-2-686-pae linux-headers-3.8-2-common
  linux-image-3.8-2-686-pae python3 python3-minimal python3.2
  python3.2-minimal
The following packages have been kept back:
  libsnmp-base xfce4-appfinder xfce4-session
The following packages will be upgraded:
  acl dnsmasq-base enchant exo-utils file fonts-opensymbol gtk2-engines-xfce
  libacl1 libattr1 libavcodec53 libavformat53 libavutil51
  libcommons-compress-java libenchant1c2a libevent-2.0-5 libexo-1-0
  libexo-common libexo-helpers libfftw3-3 libfftw3-double3 libfftw3-single3
  libgarcon-1-0 libgarcon-common libgeoip1 libmad0 libmagic1
  libnetfilter-conntrack3 libnl-3-200 libnl-genl-3-200 libnl-route-3-200
  libpostproc52 libpython2.7 libpython2.7-dev libpython2.7-minimal
  libpython2.7-stdlib libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge
  libreoffice-filter-mobiledev libreoffice-gtk libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libselinux1 libsemanage-common libsemanage1 libsepol1 libsqlite3-0 libssh2-1
  libstartup-notification0 libswscale2 libthunarx-2-0 libtumbler-1-0
  libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfcegui4-4
  libxfconf-0-2 linux-headers-686-pae linux-image-686-pae mousepad os-prober
  printer-driver-m2300w printer-driver-ptouch python-uno python2.7
  python2.7-dev python2.7-minimal sgml-data task-desktop task-english
  task-laptop task-print-server tasksel tasksel-data thunar thunar-data
  thunar-volman tumbler tumbler-common ucf uno-libs3 ure
  xfce-keyboard-shortcuts xfce4-mixer xfce4-panel xfce4-power-manager
  xfce4-power-manager-data xfce4-settings xfce4-terminal xfconf xfdesktop4
  xfdesktop4-data xfwm4
101 upgraded, 21 newly installed, 27 to remove and 3 not upgraded.
Need to get 164 MB of archives.
After this operation, 125 MB of additional disk space will be used.
Do you want to continue [Y/n]?


Hi Wayne

Yes, XFCE 4.10 is coming into SID. Might be a little bumpy ride, with some hold-backs, if you see lots of removals best to wait a day or two and check again before DU.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby Gerd50 on Thu May 23, 2013 7:08 am

I have set the package xfce4-panel on hold. DU worked without removing xfce plugins.
Icedove update removed the package icedove-l10n-de. I have installed l10n language pack
from experimental repos and it works.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Thu May 23, 2013 7:27 am

Hi Gerd.. :D
Nice to see you again. Long time..

Yes, things are a bit jumbled right now with lots of XFCE 4.10 coming into SID.

Code: Select all
Calculating upgrade... Done

The following packages will be REMOVED:
  libxfce4ui-utils xfce4-appfinder xfce4-session

The following NEW packages will be installed:
  libavutil52 libharfbuzz0 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libx264-133 xfce4-utils xinput

The following packages have been kept back:
  libsnmp-base

The following packages will be upgraded:
  binfmt-support gir1.2-pango-1.0 libavcodec54 libavformat54 libfftw3-3 libfftw3-double3 libfftw3-single3 libkpathsea6 libpango1.0-0 libpci3 libpostproc52 libswscale2
  libva-x11-1 libva1 openssh-client pciutils xfce4-battery-plugin xfce4-cellmodem-plugin xfce4-clipman xfce4-clipman-plugin xfce4-timer-plugin xfce4-weather-plugin
  xfce4-xkb-plugin xfdesktop4 xfdesktop4-data
25 upgraded, 10 newly installed, 3 to remove and 1 not upgraded.
Need to get 14.1 MB of archives.
After this operation, 4,694 kB of additional disk space will be used.
Do you want to continue [Y/n]?


I am not about to give up xfce4-appfinder and xfce4-session Time to wait for them to catch up with the other packages... :wink:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby Gerd50 on Thu May 23, 2013 10:30 am

Hi Gene,

yes long time and it was a good time. 14 month without xfce trouble and since i have it, i'm not interested
in gnomecinnamonmate or something else. But now it's time to keep an eye on it :wink:

xfce-appfinder and -session are also kept back, if xfce4-panel is on hold.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Sun May 26, 2013 3:40 am

Post by GregE » Wed May 22, 2013 3:53 pm
I have read that 3.8 kernel oops are a plague in Ubuntu land, particularly Xubuntu.

Anyway, I would not be assuming hardware in this case.

On a different note Sid and a new 3.8 kernel on my notebook now loads Broadcom wifi without having to muck about with firmware or modprobe. That is a great leap forward (for me).

Thanks GregE.
Tested more ( several distros with kernel 3.8) and it seems no hardware issues.
A few distros suddenly stopped booting. Reinstall grub2 had zero effect.
could have been more on kernel issues.
So not going to stay with 3.8 ( except debian since it still have no issues after some 50-60 reboots).




Thanks GeneC , no rush..

Hi Wayne

Yes, XFCE 4.10 is coming into SID. Might be a little bumpy ride, with some hold-backs, if you see lots of removals best to wait a day or two and check again before DU.



Getting closer... not yet...

221 upgraded, 52 newly installed, 5 to remove and 4 not upgraded


Code: Select all
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  xfce4-goodies xfce4-sensors-plugin xfce4-smartbookmark-plugin
  xfce4-verve-plugin xfce4-wavelan-plugin
The following NEW packages will be installed:
  app-install-data apt-xapian-index at-spi2-core evince-common evince-gtk
  gir1.2-gnomekeyring-1.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0
  libatk-bridge2.0-0 libatspi2.0-0 libauthen-sasl-perl libdjvulibre-text
  libdjvulibre21 libelfg0 libevdocument3-4 libevview3-3 libglib2.0-bin
  libgoa-1.0-0 libgoa-1.0-common libgtksourceview2.0-0
  libgtksourceview2.0-common libgxps2 libharfbuzz0 libjson-glib-1.0-0
  libkpathsea6 libmnl0 libnet-smtp-ssl-perl libpackagekit-glib2-14
  libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangox-1.0-0
  libpangoxft-1.0-0 librest-0.7-0 libsecret-1-0 libsecret-common libspectre1
  libt1-5 libudisks2-0 libxfce4util6 linux-headers-3.8-2-686-pae
  linux-headers-3.8-2-common linux-image-3.8-2-686-pae
  packagekit-backend-aptcc python-aptdaemon.pkcompat python-packagekit
  python-xapian python3 python3-minimal python3.2 python3.2-minimal udisks2
The following packages have been kept back:
  libsnmp-base xfce4 xfce4-appfinder xfce4-session
The following packages will be upgraded:
  acl aisleriot ant ant-optional bc dc dnsmasq-base enchant exo-utils file
  fonts-opensymbol gir1.2-gtk-3.0 gir1.2-pango-1.0 gnome-accessibility-themes
  gnome-themes-standard gnome-themes-standard-data grep gtk2-engines-oxygen
  gtk2-engines-xfce gvfs gvfs-backends gvfs-common gvfs-daemons gvfs-libs
  libacl1 libatkmm-1.6-1 libattr1 libavcodec53 libavformat53 libavutil51
  libcommons-compress-java libcommons-logging-java libenchant1c2a
  libevent-2.0-5 libexo-1-0 libexo-common libexo-helpers libfftw3-3
  libfftw3-double3 libfftw3-single3 libfs6 libgail-3-0 libgarcon-1-0
  libgarcon-common libgeoclue0 libgeoip1 libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libglibmm-2.4-1c2a libglu1-mesa libgmp10 libgmpxx4ldbl
  libgnutls-openssl27 libgnutls26 libgtk-3-0 libgtk-3-bin libgtk-3-common
  liblwp-protocol-https-perl libmad0 libmagic1 libmailtools-perl
  libnetfilter-conntrack3 libnfsidmap2 libnl-3-200 libnl-genl-3-200
  libnl-route-3-200 libpango1.0-0 libpci3 libpostproc52 libpython2.7
  libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libqt4-network
  libqt4-xml libqtcore4 libqtdbus4 libqtgui4 libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common
  libreoffice-math libreoffice-style-galaxy libreoffice-style-tango
  libreoffice-writer librsvg2-2 librsvg2-common libselinux1 libsemanage-common
  libsemanage1 libsepol1 libsqlite3-0 libssh2-1 libssl-dev libssl-doc
  libssl1.0.0 libstartup-notification0 libswscale2 libthunarx-2-0
  libtumbler-1-0 libva-x11-1 libva1 libvisio-0.0-0 libx11-6 libx11-data
  libx11-xcb1 libxcb-composite0 libxcb-dri2-0 libxcb-glx0 libxcb-randr0
  libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xfixes0 libxcb-xv0 libxcb1
  libxcursor1 libxext6 libxfce4ui-1-0 libxfce4util-bin libxfce4util-common
  libxfcegui4-4 libxfconf-0-2 libxfixes3 libxi6 libxinerama1 libxrandr2
  libxrender1 libxres1 libxt6 libxtst6 libxv1 libxvmc1 libxxf86dga1
  libxxf86vm1 linux-headers-686-pae linux-image-686-pae manpages manpages-dev
  mousepad mtools openssh-client openssl orage os-prober pciutils
  printer-driver-m2300w printer-driver-ptouch python-cups python-cupshelpers
  python-pyinotify python-uno python2.7 python2.7-dev python2.7-minimal
  ristretto sgml-data synaptic system-config-printer
  system-config-printer-udev task-desktop task-english task-laptop
  task-print-server task-xfce-desktop tasksel tasksel-data thunar thunar-data
  thunar-volman tumbler tumbler-common tzdata tzdata-java ucf uno-libs3 ure
  xfburn xfce-keyboard-shortcuts xfce4-battery-plugin xfce4-clipman
  xfce4-clipman-plugin xfce4-cpufreq-plugin xfce4-cpugraph-plugin
  xfce4-datetime-plugin xfce4-dict xfce4-diskperf-plugin xfce4-fsguard-plugin
  xfce4-genmon-plugin xfce4-mailwatch-plugin xfce4-mixer xfce4-mount-plugin
  xfce4-netload-plugin xfce4-notes xfce4-notes-plugin xfce4-notifyd
  xfce4-panel xfce4-places-plugin xfce4-power-manager xfce4-power-manager-data
  xfce4-quicklauncher-plugin xfce4-settings xfce4-systemload-plugin
  xfce4-terminal xfce4-timer-plugin xfce4-weather-plugin xfce4-xkb-plugin
  xfconf xfdesktop4 xfdesktop4-data xfwm4 xserver-xorg-video-openchrome
221 upgraded, 52 newly installed, 5 to remove and 4 not upgraded.
Need to get 254 MB of archives.
After this operation, 183 MB of additional disk space will be used.
Do you want to continue [Y/n]?
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GregE on Sun May 26, 2013 7:00 am

wayne128 wrote:Getting closer... not yet...

221 upgraded, 52 newly installed, 5 to remove and 4 not upgraded


Code: Select all
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  xfce4-goodies xfce4-sensors-plugin xfce4-smartbookmark-plugin
  xfce4-verve-plugin xfce4-wavelan-plugin
 


Just me butting in for what it is worth, xfce4-goodies is a meta package that can be deleted without issue. I have never had any use for smartbook, verve or wavelan. Sensors would only be important if you actually run monitors. I guess I am suggesting that you let them get deleted if you do not actually have any use for them, but that is up to you. You can always re-install later.
User avatar
GregE
Level 4
Level 4
 
Posts: 454
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Sun May 26, 2013 7:42 am

Hi greg... :)

Yes, xfce4-goodies has been removed from xfce 4.10 (I have been using xfce 4.10 from the siduction xfcenext repo for quite a few months now), and it looks like as such it will not make its way back. No big loss.. I would let them be removed, then you can add individual panel applets.
Last edited by GeneC on Sun May 26, 2013 7:47 am, edited 1 time in total.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Sun May 26, 2013 7:46 am

OK for the fun and learning of it.

Clone the OS: 12 minutes with fsarchiver..

d-u.

reboot, working :mrgreen:
lost sensors-plugin as expected.

trying to install sensors, as I used it all the time :lol:


Code: Select all
root@debian:/home/wayne# apt-get install xfce4-sensors-plugin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xfce4-sensors-plugin : Depends: xfce4-panel (< 4.9) but 4.10.1-1 is to be installed
E: Unable to correct problems, you have held broken packages.




edit
Code: Select all
The following packages have been kept back:
  libsnmp-base xfce4 xfce4-appfinder xfce4-session
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Last edited by wayne128 on Sun May 26, 2013 7:50 am, edited 1 time in total.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Sun May 26, 2013 7:49 am

Hi Wayne.. :)

If there is an applet that you really need that is now missing, perhaps compile it from source..

http://archive.xfce.org/src/panel-plugins
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1560
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby woodsman4 on Mon May 27, 2013 7:40 pm

ia32-crossover doesnt install in sid because it depends on lib32asound2, which is no longer in sid and conflicts/is replaced by libasound2:i386
woodsman4
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 06, 2013 4:23 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests