SOLVED: Why can't KDE keep the right time on reboot

Forum rules
Before you post please read this

SOLVED: Why can't KDE keep the right time on reboot

Postby colyn on Sun May 19, 2013 10:53 pm

Running KDE 4.10.3 and everytime I reboot I have to reset the time. It will jump several hours. NTP is installed and my BIOS time is correct..

Can't set to get the time automatically..
Last edited by colyn on Wed May 22, 2013 8:12 am, edited 1 time in total.
User avatar
colyn
Level 6
Level 6
 
Posts: 1143
Joined: Sat Aug 14, 2010 1:37 pm
Location: I'm right here..Can't ya see me?

Linux Mint is funded by ads and donations.
 

Re: Why can't KDE keep the right time on reboot

Postby xenopeek on Mon May 20, 2013 2:52 am

Only Linux, or also Windows on your machine?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14505
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Why can't KDE keep the right time on reboot

Postby J_C on Mon May 20, 2013 5:18 am

It's not just you Colyn, since daylight saving began here in the UK (British Summer Time) my laptop completely refuses to keep the advance of 1 hour.
I have tried automatically changing it and it always reverts to UTC but the time zone remains as London, manually change it and it reverts back to UTC on reboot. I've even changed the BIOS clock and selected 'use system time' and upon reboot it goes back to how it was. :?

Also a quick google will show that it's not just us. It would seem I'm one of luckier ones with my mere hour difference, like yourself many people's clocks are out by several hours. :roll:


I cannot test on Windows, I don't use it at home. But to me this seems to be a KDE issue. I'm also running 4.10.
OS: Linux Mint 13 KDE4.10 64 bit
Laptop: Acer 6930g, Intel Core2 Duo 2.0GHz, 3GB DDR2, NVIDIA GeForce 9300M GS
Docked: Asus xonar u7 DAC, NAD 3020e Amp, Celestion DL4-II Speakers
Portrait thanks to slide23.blogspot.co.uk
User avatar
J_C
Level 1
Level 1
 
Posts: 29
Joined: Wed Aug 01, 2012 7:21 am
Location: England

Re: Why can't KDE keep the right time on reboot

Postby colyn on Mon May 20, 2013 8:04 am

xenopeek wrote:Only Linux, or also Windows on your machine?


Just Linux. Windows is banned on all my computers..
User avatar
colyn
Level 6
Level 6
 
Posts: 1143
Joined: Sat Aug 14, 2010 1:37 pm
Location: I'm right here..Can't ya see me?

Re: Why can't KDE keep the right time on reboot

Postby anandrkris on Mon May 20, 2013 9:14 am

colyn wrote:Running KDE 4.10.3 and everytime I reboot I have to reset the time. It will jump several hours. NTP is installed and my BIOS time is correct..

Can't set to get the time automatically..

See if the below command works. Worked for me in 4.10.1.
Code: Select all
sudo dpkg-reconfigure tzdata

More here - viewtopic.php?f=56&t=128331
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 831
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Why can't KDE keep the right time on reboot

Postby J_C on Tue May 21, 2013 4:05 am

Well that was nice and easy!

Problem solved, many thanks anandrkris :D

Hopefully will work for you too Colyn, just a couple of simple steps to follow in the terminal.
OS: Linux Mint 13 KDE4.10 64 bit
Laptop: Acer 6930g, Intel Core2 Duo 2.0GHz, 3GB DDR2, NVIDIA GeForce 9300M GS
Docked: Asus xonar u7 DAC, NAD 3020e Amp, Celestion DL4-II Speakers
Portrait thanks to slide23.blogspot.co.uk
User avatar
J_C
Level 1
Level 1
 
Posts: 29
Joined: Wed Aug 01, 2012 7:21 am
Location: England

Re: Why can't KDE keep the right time on reboot

Postby anandrkris on Tue May 21, 2013 5:49 am

Glad it worked. :) Even I had struggled with it for quite sometime.
I had raised this in KDE Bug tracker when i was getting an error while changing time.
Aaron J. Seigo - This is a system integration issue. It requires that the time setting service be installed and given privileges via PolicyKit to be able to be run by the user.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 831
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Why can't KDE keep the right time on reboot

Postby colyn on Wed May 22, 2013 8:11 am

J_C wrote:Hopefully will work for you too Colyn, just a couple of simple steps to follow in the terminal.


This seems to have done the trick even after a power outage and reboot.
User avatar
colyn
Level 6
Level 6
 
Posts: 1143
Joined: Sat Aug 14, 2010 1:37 pm
Location: I'm right here..Can't ya see me?

Re: SOLVED: Why can't KDE keep the right time on reboot

Postby wushaman on Thu May 23, 2013 4:55 pm

colyn wrote:Running KDE 4.10.3 and everytime I reboot I have to reset the time. It will jump several hours. NTP is installed and my BIOS time is correct..

Can't set to get the time automatically..


Same thing bothered me for a few days, Thanks anandrkris I hope the time stays correct after a reboot.....


Rebooted and time is still correct.
wushaman
Level 1
Level 1
 
Posts: 4
Joined: Mon Jan 30, 2012 4:05 am

Re: SOLVED: Why can't KDE keep the right time on reboot

Postby wushaman on Thu May 23, 2013 5:14 pm

Something is wrong in the Date & Time - KDE Control Module. Whetever I choose for pool.ntp.org it gives the same time for my time zone. My time zone is Amsterdam, Zagreb, Sarajevo., Belgrade ...Every time I try to adjust time automatically from this KDE Module the time is set back for 2 hours.
wushaman
Level 1
Level 1
 
Posts: 4
Joined: Mon Jan 30, 2012 4:05 am

Re: SOLVED: Why can't KDE keep the right time on reboot

Postby anandrkris on Fri May 24, 2013 5:30 am

wushaman wrote:Something is wrong in the Date & Time - KDE Control Module. Whetever I choose for pool.ntp.org it gives the same time for my time zone. My time zone is Amsterdam, Zagreb, Sarajevo., Belgrade ...Every time I try to adjust time automatically from this KDE Module the time is set back for 2 hours.

Suggest to raise a bug on this problem since many of us have experienced the issue.
https://bugs.kde.org/show_bug.cgi?id=317089 - Add here, if you feel it is related to KDE rather than Mint.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 831
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: SOLVED: Why can't KDE keep the right time on reboot

Postby igor83 on Thu May 30, 2013 11:39 pm

anandrkris wrote:
wushaman wrote:Something is wrong in the Date & Time - KDE Control Module. Whetever I choose for pool.ntp.org it gives the same time for my time zone. My time zone is Amsterdam, Zagreb, Sarajevo., Belgrade ...Every time I try to adjust time automatically from this KDE Module the time is set back for 2 hours.

Suggest to raise a bug on this problem since many of us have experienced the issue.
https://bugs.kde.org/show_bug.cgi?id=317089 - Add here, if you feel it is related to KDE rather than Mint.


No need--same bug cropped up in Kubuntu 13.04 and same solution fixed it. The problem was KDE's, not Mint's.

I wish somebody over on the KDE team would slowdown on releasing stuff. For my part, I'd rather wait a year for the next version than have to deal with so many random bugs. Of course, on the other hand, it was my choice to go with the latest versions--could have stuck with KDE 4.9.5 and been perfectly happy.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests