How to disable the touchpad?<Solved>

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

How to disable the touchpad?<Solved>

Postby johninreno on Mon Feb 04, 2013 7:43 pm

I am trying Linux Mint Nadia on an HP tx1000 and would like to disable the touchpad. I have a wireless USB mouse that works great but I can't use the keyboard without my big fat palms hitting the touchpad. I am hoping for a disable/enable capability like newer laptops.

john
Last edited by johninreno on Tue Feb 05, 2013 7:24 pm, edited 1 time in total.
john
Linux Newbie Mint 14.1
johninreno
Level 1
Level 1
 
Posts: 3
Joined: Wed Jan 30, 2013 9:19 pm

Linux Mint is funded by ads and donations.
 

Re: How to disable the touchpad?

Postby tdockery97 on Tue Feb 05, 2013 5:19 am

Simple. Just type the following command in Terminal:

Code: Select all
synclient TouchpadOff=1


It is case-sensitive so be sure and type it exactly (or just copy/paste it in Terminal).
Image
Mint 17.2 Cinnamon
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4971
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: How to disable the touchpad?

Postby AlbertP on Tue Feb 05, 2013 6:31 am

You can also enable "palm detection" in gpointing-device-settings (you can get that program from the repository). Also, many laptops including my HP have a touchpad on/off button, or an Fn key combination to turn off the touchpad.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6669
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How to disable the touchpad?

Postby johninreno on Tue Feb 05, 2013 7:22 pm

tdockery97 wrote:Simple. Just type the following command in Terminal:

Code: Select all
synclient TouchpadOff=1


It is case-sensitive so be sure and type it exactly (or just copy/paste it in Terminal).


Simple and it works! Thank you
john
Linux Newbie Mint 14.1
johninreno
Level 1
Level 1
 
Posts: 3
Joined: Wed Jan 30, 2013 9:19 pm

Re: How to disable the touchpad?<Solved>

Postby tux-sven on Fri May 31, 2013 3:59 pm

Thanks tdockery97! I worked well on LMDE also.
I could take off the computer-owners taped hard-paper over the touchpad now... :lol:
And i also checked that I could put it on again with:
Code: Select all
synclient TouchpadOff=0
User avatar
tux-sven
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: How to disable the touchpad?<Solved>

Postby leverettson on Wed Jul 10, 2013 4:31 pm

gpointing-device-settings did the trick for me. :D
leverettson
Level 1
Level 1
 
Posts: 1
Joined: Sun Jun 09, 2013 2:32 pm

Re: How to disable the touchpad?

Postby chipps61 on Sun Apr 12, 2015 12:32 am

tdockery97 wrote:Simple. Just type the following command in Terminal:

Code: Select all
synclient TouchpadOff=1


It is case-sensitive so be sure and type it exactly (or just copy/paste it in Terminal).


Completely awesome advice, works beautifully on my HP Pavillion, found this thread on a quickie google search. Is there a way to make that something permanent that runs every time the system boots? I'm revisiting Mint for the first time since Mint 10 and am liking what I see. Running 17.1 Cinnamon 64 bit.
chipps61
Level 2
Level 2
 
Posts: 72
Joined: Tue Jan 19, 2010 9:19 pm
Location: Zelienople, PA

Re: How to disable the touchpad?<Solved>

Postby galileo6 on Sun Apr 12, 2015 6:50 am

Trying with synclient resulted in this:
Couldn't find synaptics properties. No synaptics driver loaded?
It seems that the touchpad is activated when the screen is lowered and then reactivated.
galileo6
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 11, 2015 3:08 pm

Re: How to disable the touchpad?

Postby galileo6 on Sun Apr 12, 2015 7:08 am



I partially solved my problem having read
https://help.ubuntu.com/community/SynapticsTouchpad
I input into the terminal
xinput set-prop 13 "Device Enabled" 0
with 13 being device ID of my touchpad. I'd now like to make sure that this runs automatically every time I start Linux Mint. How can I do that?
galileo6
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 11, 2015 3:08 pm

Re: How to disable the touchpad?<Solved>

Postby AlbertP on Sun Apr 12, 2015 12:20 pm

You can run it automatically after logging in by adding the command in Startup Applications, which is available in the menu.

By the way chipps and galileo6, you are responding to a thread of 3 years old which is marked as "solved". It is not your thread either but johninreno's thread. I recommend you to start your own thread if you run into further problems. It is not a problem to start your own thread and post a link/reference/quote to this thread to make clear that your terminal commands came from here.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6669
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How to disable the touchpad?<Solved>

Postby chipps61 on Sun Apr 12, 2015 11:26 pm

AlbertP wrote:You can run it automatically after logging in by adding the command in Startup Applications, which is available in the menu.

By the way chipps and galileo6, you are responding to a thread of 3 years old which is marked as "solved". It is not your thread either but johninreno's thread. I recommend you to start your own thread if you run into further problems. It is not a problem to start your own thread and post a link/reference/quote to this thread to make clear that your terminal commands came from here.


Perfect, thank you, exactly what I was looking for and works as advertised. I am aware it's an old thread, I found it via google - not trying to add anything new, just thought it was appropriate to say thank you.
chipps61
Level 2
Level 2
 
Posts: 72
Joined: Tue Jan 19, 2010 9:19 pm
Location: Zelienople, PA

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 11 guests