[SOLVED] high Xorg CPU usage

Questions about hardware and drivers
Forum rules
Before you post please read this

[SOLVED] high Xorg CPU usage

Postby tjfitz on Sun Jun 02, 2013 9:49 pm

Hello, top is reporting Xorg CPU usage hovering around 30% when I have firefox open and the computer is idle, and around 20% when idle and only my terminal and top running. Just moving the mouse pointer around adds another ~5%.

I've been hunting around the web for a solution, and the only one I found that seems applicable to my situation is to add the "nomodeset" parameter to my boot options. I did that and saw no improvement, and I don't know what to do next. It hasn't always been like this. I suspect this is related to a kernel update, but I can't put my finger on which or when.

Thanks in advance.
Last edited by tjfitz on Sat Jun 08, 2013 1:11 pm, edited 1 time in total.
IBM T42 with LMDE Xfce, 1GHz processor, 2 GB RAM.
tjfitz
Level 1
Level 1
 
Posts: 11
Joined: Tue Jan 08, 2013 2:37 am
Location: Utah, USA

Linux Mint is funded by ads and donations.
 

Re: high Xorg CPU usage

Postby tjfitz on Thu Jun 06, 2013 7:20 am

Anybody?
IBM T42 with LMDE Xfce, 1GHz processor, 2 GB RAM.
tjfitz
Level 1
Level 1
 
Posts: 11
Joined: Tue Jan 08, 2013 2:37 am
Location: Utah, USA

Re: high Xorg CPU usage

Postby tjfitz on Sat Jun 08, 2013 1:10 pm

I discovered the problem. I was using the Aurora style and tried the MurrineAzul style, and Xorg CPU usage dropped to <6% when idle. I tried several styles and noted significant differences for some of them. Very strange...
IBM T42 with LMDE Xfce, 1GHz processor, 2 GB RAM.
tjfitz
Level 1
Level 1
 
Posts: 11
Joined: Tue Jan 08, 2013 2:37 am
Location: Utah, USA

Re: [SOLVED] high Xorg CPU usage

Postby DrHu on Sat Jun 08, 2013 1:20 pm

Its only strange if you think all software will be perfect, the developers (authors) of these style/themes which aren't difficult to do, mainly being an adaption from a basic or other style set, already existing..
    --won't likely be tested against all environments, that they are offered for.. (desktops, that is)

So we could expect different writers of these themes/styles to have or not have better coding (or tighter coding)

Abut the general issue, unless a theme is causing some system slowdowns but doesn't have any other artifacts, such as quirky display results, then I generally ignore it
    Cpu percentage doesn't bother me if the overall system is AOK! (apps run fine, and displays are fine..)
    --if it did, I would be in an unending quest to wring every ounce of performance from my system: that I think is a waste of my time
User avatar
DrHu
Level 16
Level 16
 
Posts: 6714
Joined: Wed Jun 17, 2009 8:20 pm

Re: [SOLVED] high Xorg CPU usage

Postby tjfitz on Sat Jun 08, 2013 2:04 pm

DrHu wrote:Cpu percentage doesn't bother me if the overall system is AOK! (apps run fine, and displays are fine..)

Perhaps you didn't notice the specs on my computer, listed in my sig. :roll:
IBM T42 with LMDE Xfce, 1GHz processor, 2 GB RAM.
tjfitz
Level 1
Level 1
 
Posts: 11
Joined: Tue Jan 08, 2013 2:37 am
Location: Utah, USA


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 6 guests