X won't start, red screen when I switch to a different tty

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

X won't start, red screen when I switch to a different tty

Postby ChickenBandit on Mon Jun 10, 2013 1:22 am

Hi everyone!

Been trying for the last several days to get Nvidia's proprietary drivers working correctly on my computer. I've tried half a dozen different distros, and I've tried various guides to install the drivers correctly, and nothing has worked. I've tried completely blacklisting and purging Nouveau and installing the drivers found here: http://www.nvidia.com/content/DriverDow ... pe=GeForce

Basically what happens now is I disable Nouveau, reboot, install the nvidia drivers, reboot, and then X fails to start (just a black screen). If I don't remove Nouveau first then the proprietary drivers won't even install. When I try to switch to a different tty it shows up for a a few seconds, but then my screen turns solid red and I can't do anything. I have a GTX 680.

Anyways, if you guys have any advice on how I can finally get the proprietary drivers to work correctly, that would be wonderful. Let me know if you need any other details. Thanks!

EDIT: Also, I'm fairly new to Linux, so go easy on me. Though I work in IT (with Windows mostly) so don't go too easy.
ChickenBandit
Level 1
Level 1
 
Posts: 1
Joined: Mon Jun 10, 2013 1:09 am

Linux Mint is funded by ads and donations.
 

Re: X won't start, red screen when I switch to a different t

Postby gollum17 on Tue Jun 11, 2013 8:06 pm

Hmm I'll assume you can still boot into the linux terminal?

If so you can download the latest smxi script package from smxi.org by typing this in.
Code: Select all
 
sudo smxi -! 21

if that doesn't work let me know, but it should automatically install.

Once it does, all you have to do is be root (type su in terminal and enter your password), and type sgfxi. It will automatically detect and download the correct driver for your card, and it will also remove all conflicting nouveau drivers with some user input required.

Running TN's Msg and Chubbz
Current Setup
============================
MSI Neo V-2 MB || LGA 775 Pentium 4 Prescott 3.2Ghz oced to 3.5ghz || BFG Nvidia 6200 256Mb || Dell 80GB IDE HDD || 2GB Dual Channel Memory || Creative SB Live! Sound Card || Logitech 450 Watt PSU ||
gollum17
Level 1
Level 1
 
Posts: 45
Joined: Tue Feb 19, 2013 2:42 pm
Location: Ohio


Return to Hardware Support

Who is online

Users browsing this forum: nickshoe and 16 guests