KDE 15 RC - lock screen doesn't "lock"

Forums for the KDE Edition
Forum rules
Before you post please read this

KDE 15 RC - lock screen doesn't "lock"

Postby t-ray on Mon Jul 15, 2013 12:54 pm

I installed the 15 RC over the weekend on my new work laptop. Loving it so far. However, the screensaver / lock screen isn't functioning correctly. When I leave and come back, the lock screen is visible. However, simply moving the mouse (at all), or pressing any key on the keyboard, dismisses the lock screen and goes back to the desktop.

Is there some setting somewhere (I'm completely new to KDE) that I'm missing, or is this a defect?
t-ray
Level 1
Level 1
 
Posts: 27
Joined: Wed Mar 27, 2013 2:55 pm

Linux Mint is funded by ads and donations.
 

Re: KDE 15 RC - lock screen doesn't "lock"

Postby Scythe on Mon Jul 15, 2013 6:35 pm

I just put the KDE RC on today. I am not get the behavior you are describing. Seems to work as designed - i.e., when the screen saver is active and I move the mouse or hit a key, the lock screen password entry comes up.
Scythe
Level 1
Level 1
 
Posts: 7
Joined: Sun Jul 07, 2013 9:29 am

Re: KDE 15 RC - lock screen doesn't "lock"

Postby Stel on Sat Jul 20, 2013 7:21 pm

Alt+F2 and type screen locker. "Screen locker settings" will appear in the list as you are typing. Click on it. Check the box next to "require password after" .
Stel
Level 1
Level 1
 
Posts: 16
Joined: Wed Jul 20, 2011 6:30 am

Re: KDE 15 RC - lock screen doesn't "lock"

Postby waardd on Wed Sep 11, 2013 9:23 am

I found my answer to this.....
I use mint from USB stick to boot my dell lattitude and didn't get it to lock.

This is what i did to make the buttun in 'menu' work and make a keyboard shortcut:

Open Software manager
Remove all cinnamon-screensaver
Remove all gnome-screensaver
Install all from xscreensaver
Edit the following file (as root): /usr/share/cinnamon/applets/menu@cinnamon.org/applet.js
(search for 'Lock' and edit the entrys as below (the lines with xscreensaver in them))

Code: Select all
    //Lock screen
        let button = new SystemButton(this, "gnome-lockscreen", launchers.length + 3);       
        button.actor.connect('enter-event', Lang.bind(this, function() {
                this.selectedAppTitle.set_text(_("Lock screen"));
                this.selectedAppDescription.set_text(_("Lock the screen"));           
            }));
        button.actor.connect('leave-event', Lang.bind(this, function() {
                this.selectedAppTitle.set_text("");
                this.selectedAppDescription.set_text("");
            }));       
        button.actor.connect('clicked', Lang.bind(this, function() {           
            this.menu.close();
           
            let screensaver_settings = new Gio.Settings({ schema: "org.cinnamon.screensaver" });                       
            let screensaver_dialog = Gio.file_new_for_path("/usr/bin/xscreensaver-command");   
            if (screensaver_dialog.query_exists(null)) {
                if (screensaver_settings.get_boolean("ask-for-away-message")) {                                   
                    Util.spawnCommandLine("xscreensaver-command -lock");
                }
                else {
                    Util.spawnCommandLine("xscreensaver-command -lock");
                }
            }
            else {               
                this._screenSaverProxy.LockRemote();
            }                       
        }));
       
        this.leftBox.add_actor(button.actor, { y_align: St.Align.END, y_fill: false });

Go to system settings and view in advanced mode. Go to keyboard and make a new keyboard shortcut (ctrl_alt_x) for the command xscreensaver-command -lock

Reboot the system or restart cinnamon to make it work.
waardd
Level 1
Level 1
 
Posts: 1
Joined: Wed Sep 11, 2013 9:14 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 7 guests