Window startup positions and jumps

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Window startup positions and jumps

Postby msmeyer on Mon Jul 09, 2012 12:30 pm

Hi,

I am using newest Linux Mint 13 with Cinnamon with a dual-monitor setup (two 1920x1200 screens). The primary monitor is the right one, this is also where the task bar sits.

I have some problems with Window startup positions and windows "jumping" between monitors:

- When I open e.g. Mozilla Thunderbird, the animation seems to open it on the primary (right) monitor. However, immediately after the animation is finished, the Thunderbird window jumps to the second (left) monitor and stays there.

- When I open Chromium, the animation opens it on the right monitor and it stays there. However, when I click on the address bar to enter a URL the window immediately jumps to the left monitor. When I move the window back to the right monitor, it stays there, even when I click on the address bar again ;-)

Sometimes, there are other effects with other applications, but these two are always reproducible.

I am not sure what the expected behaviour is for opening windows. I would prefer when windows would always be opened on my primary (right) monitor but e.g. I think Microsoft Windows automatically opens windows on the secondary monitor if the primary monitor already has a Window and the secondary is empty. However, I consider it a bug when the animation is not consistent with the actual position of the opened Window and the problem with Chromium jumping when I click on its URL bar is just plain annoying...

Other than that, Cinnamon is absolutely great.

Any help greatly appreciated!

Best regards,
Markus
msmeyer
Level 1
Level 1
 
Posts: 1
Joined: Fri Jul 06, 2012 2:35 am

Linux Mint is funded by ads and donations.
 

Re: Window startup positions and jumps

Postby yadakhov on Mon Dec 03, 2012 9:49 am

I'm getting the same problem where Chromium would switch to the left screen. I have not found a solution for it.

One way I think to get around it is to make the Left Screen the primary screen.

I notice that this bug does not appear is XCFE.
yadakhov
Level 1
Level 1
 
Posts: 1
Joined: Wed Nov 21, 2012 1:53 pm

Re: Window startup positions and jumps

Postby griemer on Thu Jan 17, 2013 6:46 am

This also happens in Mint 14 Mate
griemer
Level 1
Level 1
 
Posts: 7
Joined: Mon Dec 17, 2012 5:38 am

Re: Window startup positions and jumps

Postby martinlauridsen on Tue Jul 23, 2013 7:31 am

Hi. I created a user just to reply to this.

I installed Mint 15 with Cinnamon yesterday and found this thread because I was having the same problem. I seem to have solved it by going to Displays and switching off my laptop monitor. Then I applied and kept the settings. Afterwards, I extended the monitors again so I was using external + laptop monitors, and the problem was gone.

Hope you can reproduce this!
martinlauridsen
Level 1
Level 1
 
Posts: 1
Joined: Tue Jul 23, 2013 7:29 am


Return to Cinnamon

Who is online

Users browsing this forum: The Big O and 6 guests