No system sounds=grayed out, crackling sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No system sounds=grayed out, crackling sound

Postby lumio83 on Tue Jul 23, 2013 5:39 pm

Hi. I am new user of LMDE2013 and i have problem with pulseaudio. System sounds are grayed and also test speakers sounds do not work. I am experiencing also crackling/noise playback through Pulseaudio output under VLC. Sound card is standard Realtek ALC888.
lumio83
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 23, 2013 5:32 pm

Linux Mint is funded by ads and donations.
 

Re: No system sounds=grayed out, crackling sound

Postby rpr-nospam on Thu Jul 25, 2013 7:55 pm

Regarding the crackling playback from VLC the following was helpful for me:
Edit /etc/pulse/default.pa file and replace
Code: Select all
load-module module-udev-detect
with
Code: Select all
load-module module-udev-detect tsched=0

Then restart /usr/bin/pulseaudio from command line using this command:
Code: Select all
$ sudo pkill pulseaudio


I also don't have system sounds on LMDE x64 with Cinnamon. I tried some suggestions from viewtopic.php?f=49&t=104761 but to no avail.
Could you post some screenshots regarding this issue? Or at least the version of gnome-control-center package installed on your system:
Code: Select all
$ dpkg -l gnome-control-center


-- rpr.
rpr-nospam
Level 1
Level 1
 
Posts: 31
Joined: Sat Jan 05, 2013 3:13 pm

Re: No system sounds=grayed out, crackling sound

Postby rpr-nospam on Fri Jul 26, 2013 7:07 am

Finally I've got system sounds on LMDE x64 with Cinnamon.

I've found some helpful hints on a Debian forum (http://forums.debian.net/viewtopic.php?f=6&t=75040). First, check you have the following packages installed:
Code: Select all
$ sudo apt-get install gnome-session-canberra libcanberra-gtk-module libcanberra-gtk3-module libcanberra-pulse sound-theme-freedesktop


Then change the following settings in /etc/pulse/daemon.conf (I've got this from an Ubuntu machinge with the same hardware):
Code: Select all
flat-volumes = no
default-fragments = 8
default-fragment-size-msec = 10
deferred-volume-safety-margin-usec = 1

and restart pulseaudio with
Code: Select all
$ sudo pkill pulseaudio


Finally, enable system sounds in GNOME (for the current user):
Code: Select all
$ gsettings set org.gnome.desktop.sound event-sounds true
$ gsettings set org.gnome.desktop.sound input-feedback-sounds true
$ gsettings set org.gnome.desktop.sound theme-name 'LinuxMint'

The last line sets the sound theme. You probably have 'LinuxMint' and 'freedesktop'.

Now you can try to play a sound from a theme:
Code: Select all
$ canberra-gtk-play -f /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg

If you get the sound then you can try to logout/login to check the sounds with real events.

Hope this helps.
-- rpr.

Edit: libcanberra-pulse package added
Last edited by rpr-nospam on Sun Jul 28, 2013 9:18 am, edited 1 time in total.
rpr-nospam
Level 1
Level 1
 
Posts: 31
Joined: Sat Jan 05, 2013 3:13 pm

Re: No system sounds=grayed out, crackling sound

Postby lumio83 on Fri Jul 26, 2013 4:23 pm

Thank You for your suggestions, will try that later, unfortunately i dont have LMDE currently installed. I will try it in next few days.
lumio83
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 23, 2013 5:32 pm

Re: No system sounds=grayed out, crackling sound

Postby lumio83 on Sat Jul 27, 2013 12:52 pm

Hi, today i have tryed installing LMDE 201204 and updating it to actual UP6. System sounds works ok. Only test speaker sounds does not work.
lumio83
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 23, 2013 5:32 pm

Re: No system sounds=grayed out, crackling sound

Postby rpr-nospam on Sun Jul 28, 2013 7:30 am

lumio83 wrote:Hi, today i have tryed installing LMDE 201204 and updating it to actual UP6. System sounds works ok. Only test speaker sounds does not work.


According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=645845 the libcanberra-pulse package is required for the test speakers dialog to work in gnome-control-center. It solved the issue in my case.

I wonder why the libcanberra-pulse package is not installed automatically with gnome-control-center. Maybe some of the libcanberra* packages doesn't have the all dependences set correctly.

Edit: I've found out that the gnome-core package depends on libcanberra-pulse. gnome-core is installed with GNOME Desktop environment but not in LMDE. I'd say that LMDE developers could fix this as LMDE uses many components from GNOME (e.g. gnome-control-center) but without installling gnome-core and its dependences. Also, Debian maintainers could fix this -- see Debian bug 563382.

-- rpr.
rpr-nospam
Level 1
Level 1
 
Posts: 31
Joined: Sat Jan 05, 2013 3:13 pm


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest