Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Postby delve on Thu May 30, 2013 9:26 am

Hello,

I`m big fan of LM and i currently use LM 14, that`s working pretty well. I don`t remember having any issues while installing LM14.
Yesterday LM15 came out and I wanted to upgrade, but I faced some problems while installing:
When i was booting to LM5, the X server didn`t start. I tried to start it manually, but i got segmentation fault. Then i booted into LM15 in compatibility mode and have installed it. I thought, that when the system is installed, i could install propietary driver, that will hopefully resolve the problem. After that, I have managed to install AMD graphics driver. I rebooted and was pleased, that now i was able to boot into LM15. But when i logged in, the popup window appeared claiming that Cinnamon crashed adn every time i tried to restart it, the crash occured again.

I don`t quite get it, LM14 runs on my notebook well, but there is problem with LM15.
Can somebody help me please solve this problem?

My notebook is Asus K50AB series with ATI Mobility™ Radeon® HD 4570

Thanks
delve
Level 1
Level 1
 
Posts: 1
Joined: Thu May 30, 2013 9:05 am

Linux Mint is funded by ads and donations.
 

Re: Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Postby atedude on Tue Jul 30, 2013 2:14 am

Please tell me how you got it installed, every time i try , I have so many issues I just give up.
I have a ACER aspire 5738pg
with the ATI Mobility™ Radeon® HD 4570
atedude
Level 1
Level 1
 
Posts: 1
Joined: Tue Jul 30, 2013 2:07 am

Re: Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Postby DonaldP. on Tue Aug 06, 2013 5:29 am

Hi,

http://wiki.cchtml.com/index.php/Hardware
...4570 is not on the list... :roll:

I have Mint15 Linux 3.8.0-19-generic #30-Ubuntu x86_64 working on an acer aspire 5738DG laptop with HD4570 and I never got the driver working. Please, somebody help here, because I really need OpenGL working.

I followed this link:
http://askubuntu.com/questions/285609/how-to-install-amd-ati-radeon-graphics-hd-6770m-on-ubuntu-13-04-64bit

As far as I understand is this card a little bit outdated. ATIs site is suggesting to use catalyt 13.1 instead of 13.3. Following the steps in the link I til the point of building the package

Code: Select all
sudo ./amd-catalyst-XX.X-linux-x86.x86_64.run --buildpkg Ubuntu/raring


But 13.1 shows only this packagelist:
Code: Select all
Ubuntu Packages:
   Ubuntu/gutsy
   Ubuntu/hardy
   Ubuntu/intrepid
   Ubuntu/jaunty
   Ubuntu/karmic
   Ubuntu/lucid
   Ubuntu/maverick
   Ubuntu/natty
   Ubuntu/oneiric
   Ubuntu/precise
   Ubuntu/source


Does catalyst 13.1 work with Mint15 :?:

I tried :
Code: Select all
Host amd # ./amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run --buildpkg Ubuntu/precise

Generating package: Ubuntu/precise
Package /home/User/amd/fglrx_8.970-0ubuntu1_amd64.deb has been successfully generated
Package /home/User/amd/fglrx-dev_8.970-0ubuntu1_amd64.deb has been successfully generated
Package /home/User/amd/fglrx-amdcccle_8.970-0ubuntu1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.QPhltJ

Host amd #  dpkg -i fglrx*.deb

Selecting previously unselected package fglrx.
(Reading database ... 309170 files and directories currently installed.)
Unpacking fglrx (from fglrx_8.970-0ubuntu1_amd64.deb) ...
/usr/share/ati/fglrx-uninstall.sh: 32: /usr/share/ati/fglrx-uninstall.sh: cannot create /etc/ati/fglrx-uninstall.log: Directory nonexistent

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the AMD driver
 is not installed, the AMD driver is only partially installed,
 or the current AMD driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the force option
 re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: error processing fglrx_8.970-0ubuntu1_amd64.deb (--install):
 subprocess new pre-installation script returned error exit status 1
Selecting previously unselected package fglrx-amdcccle.
Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.970-0ubuntu1_amd64.deb) ...
Selecting previously unselected package fglrx-dev.
Unpacking fglrx-dev (from fglrx-dev_8.970-0ubuntu1_amd64.deb) ...
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
 fglrx-amdcccle depends on fglrx; however:
  Package fglrx is not installed.

dpkg: error processing fglrx-amdcccle (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fglrx-dev:
 fglrx-dev depends on fglrx; however:
  Package fglrx is not installed.

dpkg: error processing fglrx-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 fglrx_8.970-0ubuntu1_amd64.deb
 fglrx-amdcccle
 fglrx-dev



I would be so happy to have this working out, because without proper drivers it seems like the GPU is always running a little bit out of control and the laptop gets sometimes up to 80°C. Booting windows this never happens.


-------

Installing the catalystdriver there is this message:
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended. See /usr/share/ati/fglrx-install.log for more details.

fglrx-install.log:
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers. /lib/modules/3.8.0-19-generic/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.


ok. here (http://askubuntu.com/questions/301973/p ... eon-hd2600) they write, that fglrx is not working in 13.04.
DonaldP.
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 06, 2013 5:25 am

Re: Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Postby Mark Phelps on Wed Aug 07, 2013 1:01 pm

AMD dropped restricted driver support for their HD series prior to 5x when the X-server got upgraded from 1.12 5to 1.13. In term of Ubuntu versions, that means the last one that supported restricted drivers for the HD 2x/3x/4x series was 12.04.1. In Mint terms, that takes you back to Mint 13. Nothing newer will work with restricted drivers and the HD 2x/3x/4x series cards.
Mark Phelps
Level 5
Level 5
 
Posts: 749
Joined: Mon Jun 10, 2013 4:39 pm

Re: Linux mint 15 & ATI Mobility™ Radeon® HD 4570

Postby DonaldP. on Wed Aug 07, 2013 4:39 pm

thanks mark,

I just installed ubuntu 12.04 on another partition and installed 13.1drivers with little success. The system boots up in low graphics mode. I have to downgrade xorg. But I dont know if its worth it, because there are some people claiming performance is not good. So I have to buy a new laptop one day soon, if the laptop continues with this temperatures ...its not only the hot cpu, also the HD (up to 70°C) and the RAM(60°C), just enough to boil water on the mount everest. :)

so long
DonaldP.
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 06, 2013 5:25 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 23 guests