[Solved]*: Disable Low Disk Space Warning for One Partition?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[Solved]*: Disable Low Disk Space Warning for One Partition?

Postby timber on Sat Aug 10, 2013 10:59 am

I'm running LMDE Cinnamon - Kernel 3.2.0-4-amd64

I have a static sized VDI file (Virtualbox virtual Hard Drive) on a separate partition which is mounted via fstab and accessed by Virtualbox.
Since the file size is static, I use nearly all of the partition. (Can't see any reason to make the partition any larger than needed).

Cinnamon (or LMDE) sees the disk as nearly full (which it is) so it warns me at least every boot (I keep getting the Low Disk Warning).
The OS is just doing it's job but I'd like to disable the warning for this one partition if possible.
Cinnamon doesn't give me an option at the warning to disable it.
Is there a fstab flag to stop the warning perhaps or a system setting that I don't know about?
Any hints, tips or tricks to stop the warning? (I would like to keep the warning for any other partitions for obvious reasons).

Thanks for any information you can provide.

Dave

* Marked as [Solved] for my system, fix may not work for others.
Last edited by timber on Sat Aug 10, 2013 9:21 pm, edited 2 times in total.
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Linux Mint is funded by ads and donations.
 

[Solved]*: Disable Low Disk Space Warning for One Partition?

Postby timber on Sat Aug 10, 2013 7:48 pm

Warning: Do not attempt to change any settings unless you know what you are doing! I have system backups, multiple boots and this installation is not the one I use daily. (In other words, doing the following could well bork my system).
With that said, this is a work-around that seems to have worked to disable the Low Disk Warning for a single partition on my system.
The warnings are normally a great help to let us know that we need to do some housework on our system, my use of the partition is a non-standard one where I know the partition is full and I want it that way. (In this case, the warning is not needed or wanted).

After a bit of digging, I found the following link. https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/881376
The link is evidently for a Ubuntu bug and I have no idea how accurate any of the information provided there is. (I only provide it as a source of my research).

My interest was specifically in comment #26 (David Lesieur (davidlesieur) wrote on 2013-04-09:)

Code: Select all
gsettings set org.gnome.settings-daemon.plugins.housekeeping ignore-paths "['/my/mount/path/to/ignore', '/my/other/mount/path/to/ignore']"


As noted, the partition on my system that keeps getting the warning is a VirtualBox .vdi file (virtual disk), I have it designated in fstab as /VBhold - Containing the virtual disk is this partition's only purpose.
I replaced the path in the code noted above as follows
and invoked at the command line:

Code: Select all
gsettings set org.gnome.settings-daemon.plugins.housekeeping ignore-paths "['/VBhold']"


So far, so good. :)
I logged out and back in and no warning ... previously the warning would pop up within a few moments after login.

Again, please don't try this at home, this is the first time I've used the "gsettings" command and don't know much about it other than what the 'man' pages tell me. Hopefully a more experienced user will chime in to let us know more about this command and potential consequences of it's use.

* I'm going to mark this as [Solved] but this is specific to my system only.
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests