How I Fixed My HDMI Sound LM15 xfce

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

How I Fixed My HDMI Sound LM15 xfce

Postby DragUnChained on Mon Aug 05, 2013 6:33 pm

So after several, several hours attempting to fix my HDMI sound coming from my AMD HD7950, I have finally fixed it. What exactly fixed it? I am not certain. Here is the Please excuse my dear aunt sally :

First, I downloaded the most recent amd catalyst drivers which is 13.4 (not counting beta 13.8) and I installed them. That did not help. Next...

I edited the grub boot menu first by opening terminal and typing in:

Code: Select all
cd /etc/default


from there you can type:

Code: Select all
ls


that gives you a list like this:

Code: Select all
acpid         bsdmainutils   grub        ntfs-3g     speech-dispatcher
acpi-support  cacerts        halt        ntpdate     timidity
add-apt-key   console-setup  hddtemp     pulseaudio  ufw
alsa          crda           im-config   rcS         useradd
anacron       cron           irqbalance  rkhunter    winbind
apport        cryptdisks     kerneloops  rsync
avahi-daemon  cups           keyboard    rsyslog
bootlogd      dbus           locale      samba
brltty        devpts         nss         saned


what you want to edit is the file named "grub" so to do that, simply type in console:

Code: Select all
gksudo gedit grub


for those of you who do not know, you can not edit this file without administrative privileges so the easiest way to edit it is gksudo.

all of the contents within that grub boot file will be opened up in a separate window. you want to scroll to the line that reads:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and you need to add radeon.audio=1 to it, so that it now reads like this:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

save the file after editing it. I just clicked save on top of window.

as always, after editing the grub file you need to type this into terminal:
Code: Select all
update-grub


after it finishes (5 seconds) go ahead and type:
Code: Select all
sudo reboot now

to restart your computer.

Now ok, welcome back! Some of you may have HDMI sound now, others may not. This did not fix my issue. It may have contributed to fixing it but not by itself for sure. What to do now if this did not work? I'll tell ya! (install pavucontrol;which is pulse audio control)

Bring up terminal and 64 bit systems will type:
Code: Select all
sudo apt-get install pavucontrol

32 bit systems type:
Code: Select all
sudo apt-get install pavucontrol:i386


after it installs, go ahead and open it up. (type pulse in the search bar where applications are)

I went to the playback tab and clicked on "Built in Audio: Digital Stereo and changed it to my graphics card HDMI port. Still nothing... Hmm. Next I went to the last tab, Configuration and in there I toggled the first profile option to "Off" and than back on again by selecting the below built in audio HDMI option. Instantly Lil Wayne started blaring through my speakers and I never thought I would be so happy to hear his voice (Pandora)

I hope I helped someone out there and if anyone can add to this or even drop a line saying hey man THANKS, that would be great. I am new to Linux altogether and I always make it a habit to post when I fix something even if the fix is elsewhere on the interwebz, that way it makes peoples lives easier. Thanks for letting me share my experience!
DragUnChained
Level 1
Level 1
 
Posts: 2
Joined: Sat Aug 03, 2013 7:02 pm

Linux Mint is funded by ads and donations.
 

Re: How I Fixed My HDMI Sound LM15 xfce

Postby tosh124 on Sun Aug 11, 2013 4:04 am

Cheers Mate, fixed my problem!
I think it was the pulse audio that did it, now just need to sort our my media centre :)
Col
tosh124
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 20, 2010 4:37 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Horck and 7 guests