System tray: Icons missing

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

System tray: Icons missing

Postby PinkShinyRose on Wed Jun 05, 2013 1:31 pm

Several system tray icons are missing, although most icons are present (missing: liferea, rhythmbox and banshee, present: dropbox, update manager, skype, azureus, pidgin, vlc and the system icons). Some more icons might be missing, as I am not sure which programs should have a system tray icon. The liferea icon has been fixed.

I am using linux mint 15, 64-bit, cinnamon. The root partition was formatted before installation, but I initially used an existing home folder (from mint 13). However, the behaviour persists in a new account. The same icons are missing in cinnamon, KDE and XFCE (which is why I posted this here, there is no general desktop forum to post this). I also tested with the live CD, and the icons are missing there as well.

Initially system tray icons do move, and there seems to be an attempt to render the icon, however, only a black bar is included for less than 50th of a second (see attachment for screenshot).

Searches resulted in several articles about completely missing system trays and some patched issues from older distros. It also resulted in this possibly relevant old thread: viewtopic.php?f=109&t=112348, this unfortunately did not offer a solution.

I really hope someone can help me fix this, the missing media player icons are not really a problem, but liferea becomes much less useful without a tray icon.

To fix this I tried:
    -changing the desktop theme
    -using a different desktop manager
    -using a new user
    -reinstalling affected programs
    -reinstalling cinnamon

Searches performed in duckduckgo:
    -system tray site:linuxmint.com
    -linux mint 15 system tray
    -linux mint 15 system tray incomplete
    -linux mint 15 icons missing
    -linux mint 15 notification area icons missing
    -linux mint 15 system tray icons missing
    (forum search ignored tray, which complicated a proper search)

Output from inxi -Fxz:
Code: Select all
System:    Host: xxxxxx Kernel: 3.8.0-19-generic x86_64 (64 bit, gcc: 4.7.3) Desktop: N/A Distro: Linux Mint 15 Olivia
Machine:   Mobo: Medion model: X6816 version: 1.0 Bios: American Megatrends version: 206 date: 11/21/2011
CPU:       Quad core Intel Core i7-2670QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17558
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz 5: 800.00 MHz 6: 800.00 MHz 7: 2201.00 MHz 8: 800.00 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF106M [GeForce GT 555M] bus-ID: 01:00.0
           X.org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) tty size: 154x24 Advanced Data: N/A for root
Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network:   Card-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi ver: in-tree: bus-ID: 03:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 9000 bus-ID: 05:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 750.2GB (37.9% used) 1: id: /dev/sda model: SAMSUNG_HN size: 750.2GB temp: 39C
Partition: ID: / size: 28G used: 11G (40%) fs: ext4 ID: /home size: 351G used: 255G (77%) fs: ext3
           ID: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 63.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 240 Uptime: 1:31 Memory: 1902.9/5879.9MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4

Output from banshee:
Code: Select all
[Info  19:13:52.185] Running Banshee 2.6.0: [Ubuntu quantal (development branch) (linux-gnu, x86_64) @ 2012-10-09 14:30:02 UTC]
[Warn  19:13:53.066] Caught an exception - System.ApplicationException: Invalid frame dimensions (in `Hyena.Gui')
  at Hyena.Widgets.AnimatedImage.ExtractFrames () [0x00000] in <filename unknown>:0
  at Hyena.Widgets.AnimatedImage.Load () [0x00000] in <filename unknown>:0
  at Banshee.Gui.Widgets.TaskStatusIcon..ctor () [0x00000] in <filename unknown>:0
[Info  19:13:53.204] Updating web proxy from GConf
[Info  19:13:53.287] All services are started 0,888474
[Info  19:13:54.606] nereid Client Started
[Info  19:13:54.706] GStreamer version 0.10.36.0, gapless: True, replaygain: False
[Info  19:13:54.821] AppleDeviceSource is ignoring unmounted volume groot
[Info  19:13:54.832] AppleDeviceSource is ignoring unmounted volume ubuntu
[Info  19:13:54.832] AppleDeviceSource is ignoring unmounted volume fedora
[Info  19:13:54.833] AppleDeviceSource is ignoring unmounted volume boot
[Info  19:13:54.835] AppleDeviceSource is ignoring unmounted volume klein
[Info  19:13:54.835] AppleDeviceSource is ignoring unmounted volume data
[Info  19:13:54.836] AppleDeviceSource is ignoring unmounted volume recover


Liferea did not display any terminal output
Attachments
icon_render_fail.png
Black bar shown left of the battery icon is displayed when starting liferea for less than 50th of a second.
Last edited by PinkShinyRose on Thu Sep 05, 2013 5:14 pm, edited 1 time in total.
PinkShinyRose
Level 1
Level 1
 
Posts: 6
Joined: Sun Jun 03, 2012 8:26 pm

Linux Mint is funded by ads and donations.
 

Re: System tray: Icons missing

Postby hal8000 on Wed Jun 05, 2013 4:14 pm

Which version of Mint 15 are you using ?
RC (release candidate was released 16th May) the stable version on 29th May, see release information below:
http://www.linuxmint.com/

If its RC then it may be an idea to either upgrade or install from the latest version.

However black lines are graphic glitches and looking at the output from inxi your Nvidia graphics card is not using the Nouveau
or Nvidia driver, instead the Intel driver is loaded.

Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
Card-2: NVIDIA GF106M [GeForce GT 555M] bus-ID: 01:00.0
X.org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) tty size: 154x24 Advanced Data: N/A for root

If your motherboard has onboard graphics and you have an Nvidia card then connect your monitor to the Nvidia card and either install the open source Nouveau driver, or the proprieatry Nvidia driver.

There are quite a lot of pages about Nvidia drivers, some are old, below is a more updated post, though I'd google a few pages first to see which driver is best suited for your card

http://www.howtoeverything.net/linux/ha ... linux-mint
User avatar
hal8000
Level 4
Level 4
 
Posts: 234
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: System tray: Icons missing

Postby PinkShinyRose on Sat Jun 15, 2013 10:07 am

Thank you for your feedback, there is however a complication.

The complicated part is: the video card is controlled by a nvidia optimus controller. I use bumblebee to start applications using the nvidia card. It seems to function properly for that purpose (glx-spheres speed is about doubled). I did try starting cinnamon using the nvidia card (typing "optirun cinnamon --replace"), though that did not solve the problem. I will post the terminal output, I also used "optirun inxi -Fxz" to see if that is corrected as well.

Nvidia-304 is installed, with nvidia-settings and nvidia-current, but I am unsure whether to ignore the warning from the bumblebee makers that I need to use the driver that is automatically installed with bumblebee.

optirun inxi -Fxz
Code: Select all
System:    Host: xxxx Kernel: 3.8.0-19-generic x86_64 (64 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
Machine:   Mobo: Medion model: X6816 version: 1.0 Bios: American Megatrends version: 206 date: 11/21/2011
CPU:       Quad core Intel Core i7-2670QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17558
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz 5: 800.00 MHz 6: 800.00 MHz 7: 2201.00 MHz 8: 800.00 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF106M [GeForce GT 555M] bus-ID: 01:00.0
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: GeForce GT 555M/PCIe/SSE2 GLX Version: 4.2.0 NVIDIA 304.88 Direct Rendering: Yes
Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network:   Card-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi ver: in-tree: bus-ID: 03:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 9000 bus-ID: 05:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 750.2GB (37.9% used) 1: id: /dev/sda model: SAMSUNG_HN size: 750.2GB
Partition: ID: / size: 28G used: 11G (40%) fs: ext4 ID: /home size: 351G used: 255G (77%) fs: ext3
           ID: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 72.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 5:10 Memory: 1797.5/5879.9MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4


cinnamon --replace (no nvidia card):
Code: Select all
xxxx@xxxx ~ $ cinnamon --replace

(cinnamon:6148): Gtk-WARNING **: Theme parsing error: unity-greeter.css:3:37: Expected ',' in color definition
      JS LOG: About to start Cinnamon
Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)
      JS LOG: Cinnamon started at Thu Jun 06 2013 16:23:02 GMT+0200 (CEST)
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
      JS LOG: network applet: Found connection for active
Window manager warning: Log level 16: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:2593: instance `0x2d40ad0' has no handler with id `24264'

(cinnamon:6148): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(cinnamon:6148): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
Window manager warning: Log level 16: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:2593: instance `0x3939000' has no handler with id `21132'
Window manager warning: Log level 8: g_source_remove: assertion `tag > 0' failed
Window manager warning: Log level 16: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:2593: instance `0x3b050f0' has no handler with id `30387'
Window manager warning: Log level 16: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:2593: instance `0x3952940' has no handler with id `20854'


optirun cinnamon --replace (with nvidia card)
Code: Select all
xxxx@xxxx ~ $ optirun cinnamon --replace >> '/home/sofie-mint/Bureaublad/optirun_cinnamon'

(cinnamon:6030): Gtk-WARNING **: Theme parsing error: unity-greeter.css:3:37: Expected ',' in color definition
      JS LOG: About to start Cinnamon
Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)
      JS LOG: Cinnamon started at Thu Jun 06 2013 16:20:50 GMT+0200 (CEST)
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

      JS LOG: network applet: Found connection for active
Window manager warning: Log level 16: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:2593: instance `0x1d65190' has no handler with id `24261'
Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!


(cinnamon:6030): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!


(cinnamon:6030): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!

Window manager warning: Log level 16: NOTE: Not using GLX TFP!
PinkShinyRose
Level 1
Level 1
 
Posts: 6
Joined: Sun Jun 03, 2012 8:26 pm

Re: System tray: Icons missing

Postby Stephixus on Thu Sep 05, 2013 3:08 pm

Stephixus
Level 1
Level 1
 
Posts: 2
Joined: Thu Sep 05, 2013 2:53 pm

Re: System tray: Icons missing

Postby PinkShinyRose on Thu Sep 05, 2013 5:11 pm

Stephixus wrote:Hi,

A "solution"...
See this feed :
http://forums.linuxmint.com/viewtopic.php?f=47&t=142202&p=761252#p752130


Yay, this fixed it for liferea, thank you. Although I'm going to keep the topic unsolved for the media player icons.
PinkShinyRose
Level 1
Level 1
 
Posts: 6
Joined: Sun Jun 03, 2012 8:26 pm

Re: System tray: Icons missing

Postby fractalf on Sat Oct 04, 2014 7:30 am

I had this problems with Amarok and Banshee in Linux Mint 17 64bit. After 2 hours of searching and testing I got it working:

- Open "Applets"
- In the tab "Get more online" search for "tray" and install "System Tray Collapsible"
- Add it to the panel and you will see a "Configure" button appear
- In the config check the option "Show players support by sound applet"
- Remove the default "System tray"

That did it for me. I'm thinking there is a bug in the default "System tray" applet
fractalf
Level 1
Level 1
 
Posts: 1
Joined: Sat Oct 04, 2014 7:18 am

Re: System tray: Icons missing

Postby dohduhdah on Mon Oct 13, 2014 5:41 am

Hello.

On an Acer Aspire laptop, I seem to experience the same issue of missing icons in the system tray:

http://imgur.com/Dq6so66

I also have a Dell Inspiron laptop and here I can see the icons that are supposed to be displayed:

http://imgur.com/Gn7zeHW

The invisible icons are fully functional though, so I can still do things like connect to a wireless
network by clicking on the invisible network icon. The invisible icons can easily be identified
by their tooltips that pop up as you hover the mouse over them.
Still, it would be nice if the icons were visible.

Some specs for the Acer laptop:

http://pastebin.com/EcgD0Zfm

Greetings and thanks in advance for any suggestions how to fix this issue, Niek
dohduhdah
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 13, 2014 5:24 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 3 guests