Workspace switcher looping

Workspace switcher looping

Postby zerodeficit on Thu Mar 21, 2013 1:24 pm

Hi,

Assuming a 4 workspace enviroment: [ws1][ws2][ws3][ws4]
Is there a way to loop from workspace 4 to workspace 1 by switching one workspace to the right?

Thanks.
zerodeficit
Level 1
Level 1
 
Posts: 2
Joined: Thu Mar 21, 2013 1:04 pm

Linux Mint is funded by ads and donations.
 

Re: Workspace switcher looping

Postby bjornmu on Sat Mar 23, 2013 5:03 am

Ctrl-Alt-Left and Ctrl-Alt-Right should do it.
User avatar
bjornmu
Level 3
Level 3
 
Posts: 160
Joined: Wed Dec 19, 2012 2:50 am
Location: Trondheim, Norway

Re: Workspace switcher looping

Postby zerodeficit on Mon Apr 01, 2013 8:31 am

Yes, that's how you switch through adjacent workspaces, however if you hit Ctrl+Alt+Right when you're in workspace 4, you do not go to workspace 1.

To reiterate: Is there a way to go from right most workspace to the left most workspace by switching one workspace to the right.
zerodeficit
Level 1
Level 1
 
Posts: 2
Joined: Thu Mar 21, 2013 1:04 pm

Re: Workspace switcher looping

Postby TazX on Wed Sep 11, 2013 10:29 am

I was having the same problem (in Cinnamon, but still) and found the answer while trying to fix something else (set my default number of workspaces to 4).

First you need to install dconf-tools.
Code: Select all
sudo apt-get install dconf-tools


Then go to dconf-editor (you should be able to open it in the menu, but the command-line command
Code: Select all
dconf-editor
works equally well).

Select the dropdown arrow for 'org' and go to your windows manager (cinnamon for me, presumably it is mate for you). Select the 'overrides' menu, and you should be able to turn on something called 'workspace-cycle.' Bingo, you can now cycle through your workspaces.

PS - you can choose how many workspaces to have using dconf-editor too - it is under your theme, scroll down to number-workspaces (I've entered 4). In fact, now I have it I'm keen to experiment - it looks like a powerful way to personalise Mint.
TazX
Level 1
Level 1
 
Posts: 6
Joined: Wed Sep 11, 2013 10:26 am

Re: Workspace switcher looping

Postby LinWinux on Wed Sep 11, 2013 10:49 am

Can't you set up keyboard shortcuts for that? So instead of using a key combination with only the left and right arrow keys, instead try something like ALT + PGUP for work space 1, ALT + Left Arrow for work space 2, ALT + Right Arrow for work space 3, and ALT + PGDN for work space 4? On my keyboard the page up and page down keys are also the up arrow and down arrow keys which is why I wrote it like that.

I don't use cinnamon but I'd think you should be able to set up 4 convenient keyboard shortcuts, one for each work space?
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.
User avatar
LinWinux
Level 3
Level 3
 
Posts: 153
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: Workspace switcher looping

Postby AngeloGomes on Thu Sep 12, 2013 7:23 pm

If you use Mint 15 and Mate, do not try to change the keys to switch between workspaces or the hell will appear on your computer.
AngeloGomes
Level 1
Level 1
 
Posts: 26
Joined: Wed Mar 13, 2013 7:43 am

Re: Workspace switcher looping

Postby LinWinux on Thu Sep 12, 2013 11:24 pm

I have ALT + 8 set up for WS1, ALT + 9 for WS 2, and ALT + 0 for WS 3. It's been that way for 4 days now. Works like a charm, even tested it after logging out and in, rebooting the system, and cold starting the computer from a shut down. My setup is Mint 15 with Mate. Don't know why you have problems with those keyboard shortcuts, but they work just fine for me.

Okay, I guess in all fairness I should add that I'm running XFCE panels though since I never cared for the Mate panels. I noticed that the XFCE panels were in the repositories separately so I could install them without actually installing all of XFCE. My workspace switcher is the one from the XFCE panel and that seems to work like a charm. I still have the Mate panel too. The only thing that's on it is my Mint Menu. I keep the panel hidden in the corner of my desktop and use the XFCE panels for everything else ... :lol:
Works for me!
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.
User avatar
LinWinux
Level 3
Level 3
 
Posts: 153
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: Workspace switcher looping

Postby AngeloGomes on Fri Sep 13, 2013 8:04 am

Yes, it is something related to Mate as you don have the problem with XFCE.

I concluded that after I had to re-install 4 times my Linux Mint 15 64 bits. After the 4rd install I decided to not touch anymore the keyboard shortcuts to switch between workspaces. I just let it as it was installed, i.e, the default settings.

It is a boring issue, but I am loving Linux Mint anyway. Simply the best Linux Distro I used so far.
AngeloGomes
Level 1
Level 1
 
Posts: 26
Joined: Wed Mar 13, 2013 7:43 am

Re: Workspace switcher looping

Postby TazX on Sun Oct 27, 2013 8:13 am

Heya,

I'm using MATE now (I managed to break Cinnamon - doh!). I managed to find the setting you need in dconf-editor. Go to mate > marco > general, and at the bottom of that setting will be something called wrap-style. It will be on 'no wrap' - where it doesn't wrap around. Change it to classic (there is a drop down menu) and you will be good to go.
TazX
Level 1
Level 1
 
Posts: 6
Joined: Wed Sep 11, 2013 10:26 am

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: No registered users and 7 guests