Failed to open a session for the virtual machine Linux Mint

Questions about applications and software
Forum rules
Before you post please read how to get help

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Thu Sep 12, 2013 6:53 pm

Hi John. Awesome, thank you for the excellent walk-through, written in such an easy to understand way. :D

I followed all your instructions all the way, and was successful at every step.

Just as I got to your last one...

Start again to verify that all is well. If so, quit and replace the snapshot with a new one: freshInstallUpdate


I was celebrating as I logged back in for the last check before taking that last snapshot, I came crashing back down to earth, as I got that 'soul-destroying' "Oops! Something has gone wrong and the system cannot recover" message again. :(

It worked all the way through. I was able to shut down and log back in again perfectly fine.

Until that very last one. There were no reported errors on the upgrades. It all went smoothly. I don't understand what could be the problem now.

We still of course have the latest snapshot to go back to though, so I will await any further thoughts and guidance you have.

Sooo close, and yet still so far. ;) :roll:

A potential issue is that I'm almost out of internet allowance, so not sure I'll have enough to redo the upgrades again tonnight. I'll get a top up tomorrow.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Linux Mint is funded by ads and donations.
 

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Thu Sep 12, 2013 7:20 pm

Further to my last post, I tried to log in again. Got the same error screen but this time, an "x-session errors-file" came up with it.

I still have it open, but am unable to copy/paste the text, and there is rather a lot of it. :lol:

(Copy/past worked before this in the tests you set for me).

I'm using cinnamon though not MATE, as that was my initial selection and the iso I originally chose to download.

Some of the issues in the log relate to cinnamon.

A few excerpts:

"warning - failed to connect to host. Make sure 3D acceleration is enabled for this VM". (Ok, so I know how to do that, but will wait for you to say so first).
"Gnome session is accelerated. No hardware 3D supprt."
"Helper exited with code 256".
"Session cinnamon runnable check failed. Exited with code 1".
"gnome-keyring daemon: insufficient process capabilities, insecure memory may get used."

lots of other code that would take ages to type out with various digits and colons.

"access control disabled - clients can conect from any host"
"JS error: !!! Exception was requiring cinnamon, version none: typelib file for namespace for 'meta' version 3.0 not found."

"warning! Application cinnamon 2d.desktop killed by signal 15"
"applet now removed from notification area".

"nemo: 3514: warning! cannot get _net_workarea - cannot get workarea - guessing layout..."
"backend does not require manual layout management but is provided by the application.

That's about all.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Thu Sep 12, 2013 9:04 pm

Thank goodness you have the snapshot. Hang on to it (don't replace it for long while). Also, when my disk space allows, I sometimes make a complete backup of my vbox disks folder.

If you set the settings>display>3D checkbox, it may work. Try it. (Remember, you stall have your snapshot to fall back to.) With a stable snapshot and a backup you can experiment with impunity. I'm not an expert on the Vbox settings requirements for LMDE Cinnimon (don't use it), but I am confident that it will work.

I also wonder about that initial update. It works fine before the big update but crashes after it. I had this occur once. Luckily I had an initial snapshot and was able to find the offending application and completely remove it. I don't think there is a systemic distro flaw (the forum would be ablaze with related posts).

But, let's try the 3D thing first.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 1:05 pm

Ok - so I tried enabling the 3D acceleration and fired up the VM.

An error arose, telling me that my 64bit system was not supported and that the VM would fail to load. It stated that I would need to enable the appropriate support in my BIOS settings.

That is strange - because - when I first installed VBox, I went in and manually enabled the virtualisation options.

But I went back into BIOS anyway to check, and sure enough, it was disabled. :?

I know for a fact that I enabled it, so how it is not now enabled, I'm coming up blanks on. Anyway, I enabled it again, fired up the machine (with 3d Accelleration box ticked) - and it crashed again to the "Oops" screen, this time once again without an error report.

So I am stumped now. How on earth am I to decipher what the problem is, in amongst the many things that would have been changed by the updates and upgrades? Where to start?

I hope you don't mind me turning into something of a long-term project John. :wink:
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 1:43 pm

You have a working snapshot that you took when you completeed the installation, just after guest additions were verified. Does this boot without a hitch? If it does, don't update it. I'm going to to create a Cinnimon LMDE VM and see where the smoke goes. Go ahead and experiment with the VM in the meantime.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 3:25 pm

So, my test is in progress.

You should see this: http://www.virtualbox.org/manual/ch03.html

Evidently, 64 bit guests require, among other things, the APIC check box at System>Motherboard needs to be checked.


Particularly the section that reads:
64-bit guests

VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems,[11] provided that the following conditions are met:

You need a 64-bit processor with hardware virtualization support (see the section called “Hardware vs. software virtualization”).

You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

On 64-bit hosts (which typically come with hardware virtualization support), 64-bit guest operating systems are always supported regardless of settings, so you can simply install a 64-bit operating system in the guest.

Warning

On any host, you should enable the I/O APIC for virtual machines that you intend to use in 64-bit mode. This is especially true for 64-bit Windows VMs. See the section called “"Advanced" tab”. In addition, for 64-bit Windows guests, you should make sure that the VM uses the Intel networking device, since there is no 64-bit driver support for the AMD PCNet card; see the section called “Virtual networking hardware”.

If you use the "Create VM" wizard of the VirtualBox graphical user interface (see the section called “Creating your first virtual machine”), VirtualBox will automatically use the correct settings for each selected 64-bit operating system type.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 4:32 pm

OK, here's an update:

In short, I have reproduced your error and found the trouble.
.
Quick synopsis:
I installed LMDE Cinnimon in a VM
First run OK (but had to enable 3D to overcome the display warning)
I installed Guest Additions - reboot OK
I updated - reboot gives me the OOPS (by the way, this error message needs some work)
Log out then login with a Gnome Fallback session works
Shutdown then checking the System>Motherboard>Enable IO APIC checkbox results in a complete fix.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 5:17 pm

Thanks a lot for going to so much effort for me.

Sorry, only just back in from meeting a client.


trapperjohn wrote:OK, here's an update:

In short, I have reproduced your error and found the trouble.


Excellent news.


trapperjohn wrote:Log out then login with a Gnome Fallback session works
Shutdown then checking the System>Motherboard>Enable IO APIC checkbox results in a complete fix.


I don't know what a gnome fallback session is. Is it the option "gnome classic" from the login menu?

If so, from the state my machine is currently in, what should I do next, just login with the gnome session and reboot and it is fixed?

By the way, the IO APIC box has always been checked by default on mine. :?
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 5:31 pm

I tried the gnome classic session, and I can indeed get in, which is obviously great. :D

But the layout has changed, and is far less attractive, and less intuitive. :(

I also can't find the shutdown option anywhere either now. [EDIT]: scrap that, found it now, by clicking on "user1"[/EDIT]

Is it a question of having to have this gnome desktop if I want a working machine then, or is there a way I can change the look and feel back to how it was and still have a working system?

If I sign in to the gnome session in future, am I able to install the "eleganse" theme to change the look, or will it not work in gnome too?

Sorry for such basic questions, but like I said, I am completely new to this and know next to nothing.
Last edited by Mr. Green on Fri Sep 13, 2013 5:48 pm, edited 1 time in total.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 5:38 pm

In the vbox interface, go to settings>system>motherboard and check the Enable IO APIC checkbox. Restarting with a Cinnimon session should now work.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 5:50 pm

trapperjohn wrote:In the vbox interface, go to settings>system>motherboard and check the Enable IO APIC checkbox. Restarting with a Cinnimon session should now work.


That has always been enabled by default for me the whole time.

So you mean that now that I've ran a gnome session to get back into the system, that cinnamon will just 'magically' start working again?

Also, normally, I note that the login default is "last session". Does this mean I should change that to "cinnamon" each time I log in?
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 5:54 pm

Nope. Just tried logging in to a cinnamon session: "Oops!" :roll: :lol:
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 6:10 pm

Humm,

Let's double check that virtulization is enabled in your native machine's BIOS. Also, just double checking, is your native machine running an x64 OS and what processor does your machine use.?
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 7:20 pm

trapperjohn wrote:Humm,

Let's double check that virtulization is enabled in your native machine's BIOS. Also, just double checking, is your native machine running an x64 OS and what processor does your machine use.?


I only just re-enabled it, but will check again. I''m not sure how it could keep resetting itself though? :?

Windows 7 64 bit OS, and Intel Celeron G160 2.60Ghz CPU.


What have you got yourself into here John? :wink: :lol:
Last edited by Mr. Green on Fri Sep 13, 2013 7:26 pm, edited 1 time in total.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 7:25 pm

Just re-checked the bios, and yes, "Intel Virtualzation Technology" is enabled.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Fri Sep 13, 2013 8:21 pm

Here are a few images of my settings:
3.png

4.png

5.png


I guessing yours are the same. Your Bios is set to allow hardware virtualization and your machine can't be any less functional than the laptop I am using currently.

I am fairly certain that the problems you are seeing are not with LMDE-Cinnimon, but rather, the way the OS is being virtualized. (There may be other opinions). A future migration to a native install would not have the set of headaches you have had.

We have a decision to make. Completely redo the install and hope it works out right. Ditch LMDE-Cinnimon and, when you have bandwidth, get the LMDE-Mate and try it (I have found it a cooperative VBox guest). Consider another distro like Debian Wheezy (my favorite for my native machines).

Further follow up:
The question posted has evolved sinse you first wrote it. We have learned along the way and can reformulate a new, symptom-directed post; LMDE Vbox Guest: Cinnimon session crash after update. Definity include in the post that gnome fallback is in tact.

Bug report:
Although I was, in the end, able to correct my crash; we both reproduced the error and we know that it resulted from an update. The quandry is, does the bug go to VBox or Mint?

BTW:
I have used vanilla Mint 13/15 Cinnimon on occasion in the past. The effects are great. For me, I prefer a minimalist desktop/display manager. Running Cinnimon is a hot, resource demanding option... the performance cost of eye candy.
trapperjohn
Level 5
Level 5
 
Posts: 689
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Fri Sep 13, 2013 8:37 pm

Thanks very much for all your efforts kind sir. :D

I must sleep now as up again at dawn (in europe) but will be around much more tomorrow. I'll go through all your settings you shared and points raised in your post when I'm in from work and reply in detail then.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Sat Sep 14, 2013 2:29 pm

trapperjohn wrote:Here are a few images of my settings:

I guessing yours are the same. Your Bios is set to allow hardware virtualization and your machine can't be any less functional than the laptop I am using currently.


Hi John. :D

Yes, my setting are pretty much the same, save for a few small differences in resource allocation. Whilst my machine is nice and new and performs very well, you seem to have a bit more under the bonnet to spare than I do. ;)

Only setting difference was that you had PAE/NX enabled. Mine was not by default. I tried Cinnamon again with that enabled, but no change to the status quo.



trapperjohn wrote:I am fairly certain that the problems you are seeing are not with LMDE-Cinnimon, but rather, the way the OS is being virtualized. (There may be other opinions). A future migration to a native install would not have the set of headaches you have had.


That sounds logical, otherwise I can't see how you were able to fix the issues by ticking a box I already had ticked. Something to experiment with when I have more time. Good to know that these issues would not present with a full native install though. My ultimate aim, is for a linux based install on an encrypted flash drive that can be nice and portable for my work. This VBox experiment is really to get me used to the system and how everything works. Once I'm confident enough in my ability to navigate around enough to be able to use the distro for my working needs, I'll be looking to set up a permanent and secure portable installation.


trapperjohn wrote:We have a decision to make. Completely redo the install and hope it works out right. Ditch LMDE-Cinnimon and, when you have bandwidth, get the LMDE-Mate and try it (I have found it a cooperative VBox guest). Consider another distro like Debian Wheezy (my favorite for my native machines).


Whilst I'd ideally have loved to have been working from the Cinnamon environment, you have helped me to get to the point where I have a working LMDE, which when all is said and done, is all I really wanted. I've managed to reconfigure a few things to make the gnome classic look more to my liking now, so I can live with that for the time being. :)

I wish I had the time to commit further and keep plugging away until I get Cinnamon working, but I have a family situation that has arisen, and I need to go away for a few days. Next couple of weeks I have a very testing work schedule and will be travelling a lot, so at the moment, I can't see how I'm going to find the free time.


trapperjohn wrote:Further follow up:
The question posted has evolved sinse you first wrote it. We have learned along the way and can reformulate a new, symptom-directed post; LMDE Vbox Guest: Cinnimon session crash after update. Definity include in the post that gnome fallback is in tact.


Indeed, I am most grateful for the education mate, couldn't have got to this point without your help.


trapperjohn wrote:Bug report:
Although I was, in the end, able to correct my crash; we both reproduced the error and we know that it resulted from an update. The quandry is, does the bug go to VBox or Mint?



Maybe it would be best to consider both, unless we can be sure that either one is the problem?


trapperjohn wrote:BTW:
I have used vanilla Mint 13/15 Cinnimon on occasion in the past. The effects are great. For me, I prefer a minimalist desktop/display manager. Running Cinnimon is a hot, resource demanding option... the performance cost of eye candy.


I've always been a sucker for aesthetic beauty mate. ;)

Anyway, thanks so much for all the time, patience and help you have given me John. You are a good man, and the world could sure use more of your kind, dedicated to selfless service to others.

It has been good to make your aquaintance my friend. :D
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Linux Mint is funded by ads and donations.
 
Previous

Return to Software & Applications

Who is online

Users browsing this forum: Google [Bot] and 8 guests