How to setup system-wide proxy settings ?

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

How to setup system-wide proxy settings ?

Postby ddreamer on Thu Nov 21, 2013 1:46 pm

export http_proxy="http://Username:Password@Proxy_server_IP:PORT"
export https_proxy="https://Username:Password@Proxy_server_IP:PORT"
export ftp_proxy="ftp://Username:Password@Proxy_server_IP:PORT"

Seemed not work in LMDE
Cinnamon Version 1.8.8
Distribution:LinuxMint 1:debian(x86-64)
Kernel/Build 1.10.2-amd64/#1 SMP Debian 3.10.5-1(2013-08-07)
I got on internet through LAN using Wicd.

In addition, these variables are intepreted by the application and whether to use the proxy is dependent on the application itself. Is there anyway to force all internet connection through a specific proxy server ?

The network app associated with LMDE showed sort of "system network service not compatible with this version".
ddreamer
Level 1
Level 1
 
Posts: 12
Joined: Thu Aug 23, 2012 11:46 am

Linux Mint is funded by ads and donations.
 

Re: How to setup system-wide proxy settings ?

Postby ddreamer on Thu Nov 28, 2013 3:34 am

"gnome-control-center network" gives an error message like something incompatible with this version. And I need system-wide proxy settings when the computer is inside intranet of my company so that I can access internet.
ddreamer
Level 1
Level 1
 
Posts: 12
Joined: Thu Aug 23, 2012 11:46 am

Re: How to setup system-wide proxy settings ?

Postby gryphon on Fri Nov 29, 2013 3:55 am

Try running gconf-editor then browse to /system/proxy and set http_proxy, etc.

Or if you're using a Socks proxy you can use tsocks to tunnel connections: http://tsocks.sourceforge.net
User avatar
gryphon
Level 1
Level 1
 
Posts: 31
Joined: Fri Nov 01, 2013 12:05 pm


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 2 guests