How-to fix "Warning: No support for locale: en_US.utf"

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

How-to fix "Warning: No support for locale: en_US.utf"

Postby powerhouse on Sat Sep 01, 2012 10:57 am

Linux Mint 13 (and subsequent releases 14, 15, and 16) introduced some changes regarding local language support and how it's setup. As a result, you will see the following warning, for example when running update-initramfs:

Warning: No support for locale: en_US.utf8


This is because locale-gen is using an archive file to store all the locales, but many utilities are still looking for the locale files.

Have a look at /usr/lib/locale/. If your output looks like this, read on:

Code: Select all
# ls /usr/lib/locale/
C.UTF-8  locale-archive


The warning isn't critical, as far as I can tell, but if it bothers you or causes troubles, try the following in a terminal window:

Code: Select all
sudo locale-gen --purge --no-archive


This command purges (deletes) the archive file and replaces it with the .utf8 files.

Code: Select all
# ls /usr/lib/locale/
C.UTF-8     de_LI.utf8  en_CA.utf8  en_IN       en_US.utf8
de_AT.utf8  de_LU.utf8  en_DK.utf8  en_NG       en_ZA.utf8
de_BE.utf8  en_AG       en_GB.utf8  en_NZ.utf8  en_ZM
de_CH.utf8  en_AU.utf8  en_HK.utf8  en_PH.utf8  en_ZW.utf8
de_DE.utf8  en_BW.utf8  en_IE.utf8  en_SG.utf8


Remark: The above output represents the English and German locale files, your output may be different depending on the languages you selected.
Last edited by powerhouse on Thu Apr 03, 2014 2:51 am, edited 3 times in total.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Linux Mint is funded by ads and donations.
 

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby xenopeek on Sat Sep 01, 2012 11:35 am

Thanks! I had been wondering about that error :)
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14802
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby martywd on Sat Sep 01, 2012 12:59 pm

I saw a 'fix' for this issue somewhere else. It didn't work for me.

This fix with very fine explanation does!

Code: Select all
$
marty@xxxxxx:~
$ sudo update-initramfs -u
[sudo] password for marty:
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
Warning: No support for locale: en_US.utf8
marty@xxxxxx:~
$ sudo locale-gen --purge --no-archive
Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
Generation complete.
marty@xxxxxx:~
$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
marty@xxxxxx:~
$

No error(s).

Thanks 'powerhouse'
.
martywd
Level 3
Level 3
 
Posts: 119
Joined: Sun May 08, 2011 10:35 am
Location: Texas

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby powerhouse on Sun Sep 02, 2012 3:31 pm

Vincent Vermeulen wrote:Thanks! I had been wondering about that error :)


Yep, it's one of these things that might get people worried. Hope it's going to be fixed, if only for cosmetic reasons.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby powerhouse on Sun Sep 02, 2012 3:39 pm

martywd wrote:I saw a 'fix' for this issue somewhere else. It didn't work for me.

This fix with very fine explanation does!

Code: Select all
$
marty@xxxxxx:~
$ sudo update-initramfs -u
[sudo] password for marty:
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
Warning: No support for locale: en_US.utf8
marty@xxxxxx:~
$ sudo locale-gen --purge --no-archive
Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
Generation complete.
marty@xxxxxx:~
$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
marty@xxxxxx:~
$

No error(s).

Thanks 'powerhouse'
.



You're welcome! Though I believe it's only a cosmetic issue. Can't remember that it caused any problems. In case it gets fixed, you could run sudo locale-gen --purge to get back to the archive way of storing locales (haven't tried it though).
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby martywd on Sun Sep 02, 2012 3:53 pm

powerhouse wrote:......

...In case it gets fixed, you could run sudo locale-gen --purge to get back to the archive way of storing locales...


I'll remember to try that if/when the fix comes along.

Thanks. Again!
.
martywd
Level 3
Level 3
 
Posts: 119
Joined: Sun May 08, 2011 10:35 am
Location: Texas

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby Catbuntu on Wed Jan 02, 2013 7:41 am

Thanks! The local-gen command worked like a charm. No more odd warnings!

Catbuntu
Image
Acer Aspire 6930.
CPU→Intel Core 2 Duo @ 2,00GHz. RAM3GB. Graphics card→NVIDIA GeForce 9300M GS. O.S.→Linux Mint 14.1 «Nadia» 64-bit Cinnamon ed.
Catbuntu's Bloggie
User avatar
Catbuntu
Level 2
Level 2
 
Posts: 73
Joined: Tue Oct 23, 2012 2:37 pm
Location: Catalunya

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby powerhouse on Thu Jan 03, 2013 8:54 pm

Catbuntu wrote:Thanks! The local-gen command worked like a charm. No more odd warnings!

Catbuntu


You're welcome!
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby horirevens on Tue Feb 12, 2013 12:03 pm

martywd wrote:I saw a 'fix' for this issue somewhere else. It didn't work for me.

This fix with very fine explanation does!

Code: Select all
$
marty@xxxxxx:~
$ sudo update-initramfs -u
[sudo] password for marty:
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
Warning: No support for locale: en_US.utf8
marty@xxxxxx:~
$ sudo locale-gen --purge --no-archive
Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
Generation complete.
marty@xxxxxx:~
$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic-pae
marty@xxxxxx:~
$

No error(s).

Thanks 'powerhouse'
.


It work for me too. thanks a lot :D
horirevens
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 12, 2013 10:59 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby michalko on Thu Oct 24, 2013 7:47 am

It works for me, thanks a lot.
User avatar
michalko
Level 1
Level 1
 
Posts: 2
Joined: Mon Sep 09, 2013 5:37 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby ddalley on Thu Nov 21, 2013 1:10 pm

So, a year later, what are the chances of this finally getting fixed?

I presume that only one utility needs to be updated, to use the more modern method of looking for locales.
ddalley
Level 4
Level 4
 
Posts: 278
Joined: Sun Mar 15, 2009 4:25 am
Location: Toronto, Canada

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby powerhouse on Sat Nov 23, 2013 5:27 am

ddalley wrote:So, a year later, what are the chances of this finally getting fixed?

I presume that only one utility needs to be updated, to use the more modern method of looking for locales.


Just for reference, I'm NOT following my own instructions, that is I use the new locales format (archive file) for over a year now and I never had any issue with it. With certain updates it throws error messages at me, but that is all - no problems whatsoever. Perhaps this is the reason no one bothers with it: if it ain't broke, don't fix it!
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 645
Joined: Thu May 03, 2012 3:54 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby xenopeek on Sat Nov 23, 2013 5:44 am

It doesn't throw errors at you powerhouse, it throws a warning :wink:
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14802
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby FabioBeneditto on Thu Jan 23, 2014 3:37 pm

Hi!

Works fine to me! :mrgreen:

Thanks for sharing your knowledge :D
:wq
Fabio Beneditto - http://blog.altoscodigos.tk
"A hacker does for love what others would not do for money."
"A Vida é mais bela quando vista de cima de uma motocicleta.
"
Linux Mint 17 Mate (at Work) / XFCE (at Mobile / Home)
User avatar
FabioBeneditto
Level 1
Level 1
 
Posts: 6
Joined: Sat Jan 11, 2014 11:27 am
Location: Ivoti, RS (Brazil)

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby Adelante on Thu Jan 23, 2014 4:11 pm

Thanks a lot. It always bugs me.

powerhouse wrote:The warning isn't critical, as far as I can tell, but if it bothers you or causes troubles, try the following in a terminal window:

Code: Select all
sudo locale-gen --purge --no-archive


This command purges (deletes) the archive file and replaces it with the .utf8 files.
Linux Mint 17 Cinnamon
Adelante
Level 4
Level 4
 
Posts: 313
Joined: Mon Mar 14, 2011 8:16 pm

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby Tz2001 on Thu Jan 23, 2014 4:58 pm

Thanks! I'd seen this error when installing things via apt all the time, however because I'm on en_GB I'd always assumed it was because whatever software I'd installed only had translations for en_US and not the GB version.
Tz2001
Level 1
Level 1
 
Posts: 42
Joined: Fri Mar 08, 2013 8:11 pm

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby thanosfrag on Tue Feb 11, 2014 7:22 pm

Thanks powerhouse. It did work perfectly well.
LM 16 'Petra' Cinnamon 64bit - HP Compaq CQ58-d69SG
thanosfrag
Level 2
Level 2
 
Posts: 93
Joined: Mon Nov 04, 2013 6:23 am

Re: How-to fix "Warning: No support for locale: en_US.utf"

Postby GRAVEL on Wed Apr 02, 2014 3:05 pm

Thank you for this info,
sincerely,

Roger
GRAVEL
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 26, 2014 5:58 am

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: Yahoo [Bot] and 8 guests