suspend restart immediatly…

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

suspend restart immediatly…

Postby FDF on Tue Apr 10, 2012 2:28 am

Hello,

I applied the LMDE Pack four two days ago.
Since I found the computer wake up in the morning (it normally suspend after one hour), I wondered about the suspend.
So I try to force the computer to suspend (via menu shutdown). It do the process. I even hear the fan and the hard disk stop. But as soon as it has stopped it wake up again.
in the log, I can't see what has requested the computer to wake up, but maybe I don't know the proper log to look in.
Anyway, that is not very convenient…

I tried the same with the Hibernate option and face exactly the same problem. It is hibernating, but resume immediately (full boot of the hard).

Can anybody help me?

Thanks
FDF
Level 3
Level 3
 
Posts: 101
Joined: Fri Nov 04, 2011 7:55 pm

Linux Mint is funded by ads and donations.
 

Re: suspend restart immediatly…

Postby FDF on Sun Apr 15, 2012 4:38 am

Hi,

I have checked and made test.

When I select the kernel 2.6.39 in grub, instead of 3.0.2, suspend and hibernate works well. Thus I guess Kernel or module incompatibility with hardware, but I don't know how to solve that.

By the way, one questions is… is it really important to follow the "latest" kernel? what can really be expected by changing kernel? better hardware performance for very new things, or other important point?

Thanks and regards
FDF
Level 3
Level 3
 
Posts: 101
Joined: Fri Nov 04, 2011 7:55 pm

Re: suspend restart immediatly…

Postby äxl on Sun Apr 15, 2012 9:05 am

FDF wrote:When I select the kernel 2.6.39 in grub, instead of 3.0.2, suspend and hibernate works well. Thus I guess Kernel or module incompatibility with hardware, but I don't know how to solve that.

You could compare the output of lsmod if you think it's a module.
By the way, one questions is… is it really important to follow the "latest" kernel? what can really be expected by changing kernel? better hardware performance for very new things, or other important point?

http://wiki.debian.org/KernelFAQ
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: suspend restart immediatly…

Postby beauman on Wed Jan 29, 2014 2:14 pm

Same problem here. Immediatly restarting after suspend or hibernate.

Any advice, how to collect more info about this behaviour?
User avatar
beauman
Level 1
Level 1
 
Posts: 38
Joined: Sun Jan 26, 2014 5:57 pm
Location: Vienna, Austria

Re: suspend restart immediatly…

Postby FDF on Fri Jan 31, 2014 5:00 am

Hi, I have never been further, and stick with the old kernel…
FDF
Level 3
Level 3
 
Posts: 101
Joined: Fri Nov 04, 2011 7:55 pm

Re: suspend restart immediatly…

Postby Magister on Sat Feb 01, 2014 5:52 pm

maybe a USB device, in my case it was my mouse that made suspend restart. do a:

Code: Select all
cat /proc/acpi/wakeup


you will have maybe USB0 USB1 USB2 and USB3 in enabled state. Do a:

Code: Select all
echo USB0 > /proc/acpi/wakeup


to disable USB0, then suspend to see if it restarts immediately. if yes, disable another USB.

when you find the right USB, put the echo command in /etc/rc.local

To know what was the device, I had to check the pci string from wakeup in the dmesg log, for instance

Code: Select all
dmesg | grep 0000:00:04.0


Hope this helps!
HP Mini311 - Atom - ION - 3GB
Mint 16-32 Cinnamon
Magister
Level 1
Level 1
 
Posts: 13
Joined: Sat Nov 23, 2013 6:55 pm
Location: Montréal, QC, Canada

Re: suspend restart immediatly…

Postby beauman on Wed Feb 05, 2014 7:27 pm

Before I do anything I get
Code: Select all
cat /proc/acpi/wakeup
HUB0     S5   *disabled  pci:0000:00:09.0
XVR0     S5   *disabled  pci:0000:00:0e.0
XVR1     S5   *disabled  pci:0000:00:0d.0
XVR2     S5   *disabled  pci:0000:00:0c.0
XVR3     S5   *disabled  pci:0000:00:0b.0
USB0     S4   *enabled   pci:0000:00:02.0
USB2     S4   *enabled   pci:0000:00:02.1
MMAC     S5   *disabled  pci:0000:00:0a.0
MMCI     S5   *disabled
UAR1     S5   *disabled  pnp:00:07
PS2K     S4   *enabled   pnp:00:09


I don't have the user rights to do a

Code: Select all
echo USB0 > /proc/acpi/wakeup

and that doesn't work either:
Code: Select all
sudo echo USB0 > /proc/acpi/wakeup


But that works:
Code: Select all
echo USB0 > wakeup
sudo cp wakeup /proc/acpi/wakeup


and leads to a disabled USB0 wakeup trigger (line six from top):

Code: Select all
HUB0     S5   *disabled  pci:0000:00:09.0
XVR0     S5   *disabled  pci:0000:00:0e.0
XVR1     S5   *disabled  pci:0000:00:0d.0
XVR2     S5   *disabled  pci:0000:00:0c.0
XVR3     S5   *disabled  pci:0000:00:0b.0
USB0     S4   *disabled  pci:0000:00:02.0
USB2     S4   *enabled   pci:0000:00:02.1
MMAC     S5   *disabled  pci:0000:00:0a.0
MMCI     S5   *disabled
UAR1     S5   *disabled  pnp:00:07
PS2K     S4   *enabled   pnp:00:09


The good news is: That works. I can use hibernate and it will but the system to sleep.
The bad news is: new problem. It online works once. If I did a hibernate before and if I do it a second time, it will not really suspend. Going down yes,
but the blower continue running and I can't reactivate from the power button.
User avatar
beauman
Level 1
Level 1
 
Posts: 38
Joined: Sun Jan 26, 2014 5:57 pm
Location: Vienna, Austria

Linux Mint is funded by ads and donations.
 

Return to Other Topics

Who is online

Users browsing this forum: No registered users and 1 guest