Guide to HDMI audio problem [solved]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Guide to HDMI audio problem [solved]

Postby abtygwyn on Mon Dec 24, 2012 12:37 pm

Is there an 'idiots' guide to getting the audio to work on my HDMI link. I can't seem to do it no matter what I try.
I'm using LMDE and fully up to date and everything else (that I know of) is working just fine!

Thanks all. Merry Christmas

Andrew

The standard update UP7/8 appeared to reinstall the HDMI option in the sound settings which is what I was unable to do manually before.
Last edited by abtygwyn on Sun Mar 02, 2014 1:46 pm, edited 3 times in total.
abtygwyn
Level 3
Level 3
 
Posts: 155
Joined: Mon Apr 25, 2011 4:33 am

Linux Mint is funded by ads and donations.
 

Re: Quick quide to HDMI audio

Postby proxima_centauri on Tue Dec 25, 2012 1:39 pm

Please post the output of your video card and driver, from terminal "inxi -Gx".
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Quick quide to HDMI audio

Postby abtygwyn on Thu Dec 27, 2012 5:40 am

proxima_centauri wrote:Please post the output of your video card and driver, from terminal "inxi -Gx".


Many thanks, hope this helps.

andrew@laptopu400:~$ inxi -Gx
Graphics: Card Intel Mobile GM965/GL960 Integrated Graphics Controller (primary) X.Org 1.12.4 Res: 1280x800@59.9hz
GLX Renderer Mesa DRI Intel 965GM GLX Version 2.1 Mesa 8.0.4 Direct Rendering Yes
andrew@laptopu400:~$
abtygwyn
Level 3
Level 3
 
Posts: 155
Joined: Mon Apr 25, 2011 4:33 am

Re: Quick quide to HDMI audio

Postby abtygwyn on Mon Jan 28, 2013 8:45 am

abtygwyn wrote:
proxima_centauri wrote:Please post the output of your video card and driver, from terminal "inxi -Gx".


Many thanks, hope this helps.

andrew@laptopu400:~$ inxi -Gx
Graphics: Card Intel Mobile GM965/GL960 Integrated Graphics Controller (primary) X.Org 1.12.4 Res: 1280x800@59.9hz
GLX Renderer Mesa DRI Intel 965GM GLX Version 2.1 Mesa 8.0.4 Direct Rendering Yes
andrew@laptopu400:~$


Any suggestions as to how to configure my HDMI socket please! It works fine with Win7 so I know it's not a hardware issue, but I can't sort this myself unfortunately.
abtygwyn
Level 3
Level 3
 
Posts: 155
Joined: Mon Apr 25, 2011 4:33 am

Re: Quick quide to HDMI audio

Postby proxima_centauri on Mon Jan 28, 2013 10:26 am

Have you tried going to Sound Settings while the HDMI is plugged in, and selecting HDMI as your sound output?
It does not switch automatically for me, I have to go to Sound Settings each time to select the proper output.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Quick quide to HDMI audio

Postby abtygwyn on Mon Jan 28, 2013 11:47 am

proxima_centauri wrote:Have you tried going to Sound Settings while the HDMI is plugged in, and selecting HDMI as your sound output?
It does not switch automatically for me, I have to go to Sound Settings each time to select the proper output.


I am unable to select HDMI in my sound settings, because it never comes up as an option.
Question is "how to get my system to enable HDMI sound settings as an option".

Any help would be much appreciated.
Andrew
abtygwyn
Level 3
Level 3
 
Posts: 155
Joined: Mon Apr 25, 2011 4:33 am

Re: Quick quide to HDMI audio

Postby awshidahak on Sat Apr 06, 2013 6:09 pm

Hey, I don't know if you've got this fixed or not (since this thread is a little bit old) but since it don't see the fix posted on here, I'll go ahead and share what's worked for me.

First off, this fix only works if you're on pulseaudio (the default sound server, if you don't know what I'm talking about, pulseaudio is probably what you're using). Go to the software manager, or your package manager of choise, and check to see if a package called pavucontrol is installed. If not, install it. Afterward, select PulseAudio Volume Control from the menu (if it's not there, you may need to right click the menu and select refresh). Inside of PulseAudio, select the configuration tab, and change the Profile to Digital Stereo (HDMI) Output. To switch back to your other speakers (assuming you have other speakers) you need to change that sound option back to whatever it was beforehand (probably Analog Stereo Duplex). You'll need to do this every time you switch as pulse doesn't detect when something's plugged or unplugged.
awshidahak
Level 1
Level 1
 
Posts: 19
Joined: Sat Sep 06, 2008 5:10 pm

Re: Quick quide to HDMI audio

Postby abtygwyn on Sat Mar 01, 2014 3:54 pm

awshidahak wrote:Hey, I don't know if you've got this fixed or not (since this thread is a little bit old) but since it don't see the fix posted on here, I'll go ahead and share what's worked for me.

First off, this fix only works if you're on pulseaudio (the default sound server, if you don't know what I'm talking about, pulseaudio is probably what you're using). Go to the software manager, or your package manager of choise, and check to see if a package called pavucontrol is installed. If not, install it. Afterward, select PulseAudio Volume Control from the menu (if it's not there, you may need to right click the menu and select refresh). Inside of PulseAudio, select the configuration tab, and change the Profile to Digital Stereo (HDMI) Output. To switch back to your other speakers (assuming you have other speakers) you need to change that sound option back to whatever it was beforehand (probably Analog Stereo Duplex). You'll need to do this every time you switch as pulse doesn't detect when something's plugged or unplugged.


Thanks it is fixed now, but nothing I did, short of applying the latest update which reinstalled the HDMI option in the sound settings and that was that.
abtygwyn
Level 3
Level 3
 
Posts: 155
Joined: Mon Apr 25, 2011 4:33 am

Re: Guide to HDMI audio problem [solved]

Postby RegTheDonk on Sun Mar 16, 2014 4:23 pm

Hi, thanks for the pulseaudio tip, that worked in enabling the HDMI audio output from my Asus x101. Only slight problem is (and I don't know if its the netbook OR the way pulse decodes the sound) .... but every 5/6 seconds there is a split-second "buzz" noise. Almost sounds like stubbing a cigarette in water lol . Doesn't matter if I'm watching a video file or YouTube through the Firefox browser.

Has anybody else experienced this and, if so, is there anything else I need to do to stop these jitters?

TIA

Reg.
RegTheDonk
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 16, 2014 4:15 pm

Re: Guide to HDMI audio problem [solved]

Postby RegTheDonk on Mon Mar 17, 2014 4:26 pm

Sorry, scratch the above ... tried it on a different telly and its fine.
RegTheDonk
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 16, 2014 4:15 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests