2.2.x/2.4.5: Desktop icons are gone

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

2.2.x/2.4.5: Desktop icons are gone

Postby theSeppi on Mon Aug 18, 2014 8:04 am

<Moderator on>

Please, note:
This thread has been split from that thread: 1.6.7: Desktop icons are gone, missing setting in options.
Cinnamon 1.6.7 came with Mint 13. Cinnamon 2.0.14 followed Cinnamon 1.6.7 and came to Mint 13 as a backport from the now obsolete Mint 16.
The last post in that thread about Cinnamon 1.6.7 was posted in March 2013, here.
Then this post about Cinnamon 2.2.13 was post 1.25 years later in Aug. 2014. Cinnamon 2.2.13 came with Mint 17.
That thread should not have been revived: different Mint LTS releases, pretty different Cinnamon releases, no more Nautilus on Mint 17, etc pp.

</Moderator off>

This still happens on my system (Qiana, Cinnamon 2.2.13, Nemo 2.2.2). No, I don't have Nautilus installed!

I found the following workaround to avoid the disappearing icons:
Add the command «/bin/sh -c "killall nemo && nemo -n&"» to the startup applications. This will kill the initially started instance of nemo and will start a new instance as an own process.

The similar solution posted above won't work, since the instance controlling the desktop is still running when starting the new one.
Last edited by karlchen on Thu Jan 15, 2015 5:49 am, edited 2 times in total.
Reason: added moderator note about splitting the old thread into two threads
Linux Mint 17.1 Cinnamon Edition 64bit
HP ProBook 455 G1
AMD A8-4500G with Radeon HD 7580M
theSeppi
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 28, 2014 6:27 am
Location: Switzerland

Linux Mint is funded by ads and donations.
 

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby sg1efc on Tue Aug 19, 2014 4:54 pm

theSeppi wrote:This still happens on my system (Qiana, Cinnamon 2.2.13, Nemo 2.2.2). No, I don't have Nautilus installed!

I found the following workaround to avoid the disappearing icons:
Add the command «/bin/sh -c "killall nemo && nemo -n&"» to the startup applications. This will kill the initially started instance of nemo and will start a new instance as an own process.

The similar solution posted above won't work, since the instance controlling the desktop is still running when starting the new one.


Hello theSeppi:

Thank you very much for posting this info & Thanks to everyone else who has also posted.

theSeppi: Would you please give me a bit more details about how you added the command? Specifically, exactly where and how do you add this command? Is it in the System Settings Control Center > click on "Startup Programs"? Or is it somewhere else?

Thank you very much for your help theSeppi, I greatly appreciate it. :)
sg1efc
Level 1
Level 1
 
Posts: 7
Joined: Wed Jan 23, 2013 10:52 pm

[Solved] "icons not showing up" & "right mouse click on desk

Postby sg1efc on Tue Aug 19, 2014 9:42 pm

Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
sg1efc
Level 1
Level 1
 
Posts: 7
Joined: Wed Jan 23, 2013 10:52 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby wewa on Mon Dec 15, 2014 8:49 pm

could not find show-desktop-icons for org.nemo.preferences in dconf Editor.

Also running Qiana 17 64bit.

Will keep looking for another solution.



sg1efc wrote:Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
wewa
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 24, 2012 4:20 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby WinterTroubles on Tue Dec 16, 2014 6:06 am

wewa wrote:could not find show-desktop-icons for org.nemo.preferences in dconf Editor

org>nemo>desktop... not preferences.
sg1efc wrote:..... "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett
User avatar
WinterTroubles
Level 6
Level 6
 
Posts: 1486
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: [Solved] "icons not showing up" & "right mouse click on

Postby wewa on Tue Jan 06, 2015 2:29 pm

Thank you.
I hope they fix this bug soon.



sg1efc wrote:Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
wewa
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 24, 2012 4:20 am

Re: [Solved] "icons not showing up" & "right mouse click on

Postby wewa on Tue Jan 06, 2015 2:29 pm

Thank you.
I hope they fix this bug soon.



sg1efc wrote:Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
wewa
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 24, 2012 4:20 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby WinterTroubles on Tue Jan 06, 2015 4:13 pm

You're welcome :)

As Mint 17.1 Rebecca is out already (for Cinnamon and Mate) and the Nemo is now version 2.4.4 in 17.1 in Cinnamon maybe it's fixed already.

Regards
WT
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett
User avatar
WinterTroubles
Level 6
Level 6
 
Posts: 1486
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: [Solved] "icons not showing up" & "right mouse click on

Postby wewa on Fri Jan 09, 2015 3:53 pm

I have to do this everytime I reboot. :(
I hope this bug is fixed soon.
I find that searching in dconf 'show-desktop-icons' is much faster and easier...
Thank you OP.




sg1efc wrote:Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
wewa
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 24, 2012 4:20 am

Re: 2.2.x/2.4.5: Desktop icons are gone

Postby gdimakop on Thu Jan 15, 2015 4:41 am

Hi, When I login as root via GUI, I have no icons on desktop (Nemo manager), nor right-click on desktop. When I switch to another user, everything is perfect.
I've done almost everything (dconf) under this topic.

Thank you
George

Note: Rebecca 17.1 32bit - nautilus not installed
gdimakop
Level 1
Level 1
 
Posts: 1
Joined: Thu Jan 15, 2015 4:29 am

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: MSNbot Media and 3 guests