Creative SoundBlaster Live! 5.1 Surround Sound [Solved]

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Creative SoundBlaster Live! 5.1 Surround Sound [Solved]

Postby Geoff42 on Tue May 24, 2011 5:05 am

Having just installed LinuxMint Xfce (Debian) on my old XP box, I was
struggling to get surround sound working through the SB Live! 5.1 card.
It worked ok under XP and the test lady would speak to me correctly from
all of the speakers in turn, but when under Mint I tried :-

Code: Select all
speaker-test -Dplug:surround51 -c6 -l1 -twav


she would not speak from the rear speakers and the centre front speaker
was very quiet. I think that the LFE (bass) speaker was working.

Some investigation suggested that it is necessary to edit
/etc/pulse/daemon.conf and set the number of channels :-

Code: Select all
default-sample-channels = 6
enable-lfe-remixing = yes
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe


just in case, I also set the channel map and enabled lfe remixing!
This still did not make the rear speakers work. After much fiddling
I realised that the "speaker-test" command is part of the Alsa system
and that PulseAudio sits on top of the Alsa drivers. Thus, as
speaker-test was not working correctly, then Alsa was not correctly
set up.

I eventually found :-

http://alsa.opensrc.org/Emu10k1

and under "General mixer settings for emu10k1" found stuff about what
I needed to turn on and what to mute. In particular, turning on wave
and muting the SB Live Analog/Digital Output Jack. This can be carried
out using alsamixer, but is not immediately obvious, so :-

Run alsamixer in a terminal window. It may be necessary to select the
correct card. Press "F6" and a small pop-up appears offering the sound
cards. Mine was on "default". Move the cursor to "SB Live! 5.1" and
press "Return". This should now be the selected card and many more
sliders appear on the screen, so many, in fact, that they go off the
right hand side of the window. Some of these sliders can be muted and
are indicated by a small box at the bottom of the slider. The box may
contain "MM" if muted or a reverse video "OO" if enabled. You can
toggle this with the "M" key (either "M" or "m"). You select the slider
with the left or right arrow keys. I have "Master" and "PCM" enabled
as well as "CD". When you reach the right of the window with the arrow
keys the sliders will scroll across to show more of the sliders. The
last option on the right is one of the few that does not actually have
a slider, but can be muted and is labelled "<SB Live >". Use the "M" key
to toggle this one and mute it so that the box contains "MM". Moving
back to the left, check that the sliders for the following are all
set to something reasonable, somewhere between 60 & 100, :-
Master, PCM, Surround, Centre, LFE, Wave, Wave Cen, Wave LFE, Wave Sur.
You can also check that you are happy with the Bass and Treble. I have
Tone muted. All of this was carried out on the "[Playback]" view. If
necessary you can use the "F3" key to select this view.

Exit alsamixer with the "Escape" key.

Now "speaker-test -Dplug:surround51 -c6 -l1 -twav" works correctly
and the lady speaks to me from all the correct speakers although
she doesn't have much bass presence from the LFE speaker!

Now when I run Rhythmbox, sound comes out of all of the speakers
in a very pleasing manner ;-)

You may need to check in "PulseAudio Volume Control" in the
Configuration tab that the correct profile is selected. I am
offered "Internal Audio" and "PCM2900 Audio Codec". The Internal
Audio is set to "Analog Surround 5.1 Output + Analog Mono Input",
while I have PCM2900 Audio Codec set to "Off".

Alsa is version 1.0.23
PulseAudio is 0.9.21-rebootstrapped-dirty

Geoff
Geoff42
Level 1
Level 1
 
Posts: 3
Joined: Mon May 09, 2011 4:24 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests