Search found 1474 matches

by fabien85
Thu Apr 18, 2019 4:33 am
Forum: Installation & Boot
Topic: Executuing 'grub-install /dev/nvme0n1' failed - This is a fatal error
Replies: 21
Views: 448

Re: Executuing 'grub-install /dev/nvme0n1' failed - This is a fatal error

Ok, if you want to install grub, here is an howto : https://easylinuxtipsproject.blogspot.com/p/grub-uefi-repair.html (by forum member pjotr) Good luck on understanding how grub works. I gave up on that myself. What I know is that you need to have the following minimal structure of the EFI Partition...
by fabien85
Wed Apr 17, 2019 1:23 pm
Forum: Installation & Boot
Topic: Executuing 'grub-install /dev/nvme0n1' failed - This is a fatal error
Replies: 21
Views: 448

Re: Executuing 'grub-install /dev/nvme0n1' failed - This is a fatal error

Hi grubby, as far as I see, you seem to have attempted the install with correct steps. The install created a good boot entry in the NVRAM (the entry "ubuntu" that you see from the output of efibootmgr and that you also see in your boot menu). Unfortunately for an unknown reason it did not find your ...
by fabien85
Tue Apr 16, 2019 6:20 am
Forum: Installation & Boot
Topic: [SOLVED] Stuffed up my Secure Boot
Replies: 5
Views: 170

Re: Stuffed up my Secure Boot

Hi, first when you post long terminal outputs, please enclose them in code tags with the button </> above the typing area. That makes your posts much easier to read. Second, and especially if you are single-booting Linux, you do not need secure boot. You can have it disabled and your Linux will be p...
by fabien85
Sat Apr 13, 2019 9:34 am
Forum: Installation & Boot
Topic: Boot directly to Grub
Replies: 41
Views: 906

Re: Boot directly to Grub

I'm going to repeat myself. Since windows is in UEFI mode, the solution is here : viewtopic.php?f=42&t=243338
This is a (unfortunately) usual problem with HP computers.
by fabien85
Fri Apr 12, 2019 8:42 am
Forum: Installation & Boot
Topic: Boot directly to Grub
Replies: 41
Views: 906

Re: Boot directly to Grub

I agree with previous posts, just a quick reaction o this : I just wish there would be a starting-page dedicated to LM 19.1 exclusively, so that people would be able to find all the current info about multibooting, UEFI and setting up of LM 19.1. I'm sure it would help to increase the Linux userbase...
by fabien85
Thu Apr 11, 2019 8:34 am
Forum: Installation & Boot
Topic: Boot directly to Grub
Replies: 41
Views: 906

Re: Boot directly to Grub

When you use timeshift to restore a snapshot, it reinstalls grub (by default). To reinstall grub, there is also the simpler option of following the tutorial from Pjotr : https://easylinuxtipsproject.blogspot.com/p/grub-uefi-repair.html (for UEFI mode, for Legacy/BIOS mode there is another tutorial) ...
by fabien85
Wed Apr 10, 2019 5:43 am
Forum: Installation & Boot
Topic: [SOLVED] Maya to Tessa install without any boot media: possible?
Replies: 23
Views: 442

Re: [SOLVED] Maya to Tessa install without any boot media: possible?

On Mint 19.1 Tessa the following commands can be used instead of gksudo gedit /etc/grub.d/40_custom : xed admin:///etc/grub.d/40_custom sudoedit /etc/grub.d/40_custom I always use sudo nano /path/to/textfile . This works for all versions of Linux I have tested, works on macOS, probably also on BSD....
by fabien85
Wed Apr 10, 2019 5:37 am
Forum: Installation & Boot
Topic: iMac trying to install Mint
Replies: 3
Views: 113

Re: iMac trying to install Mint

Hi, for reference, here are the specs of the machine : https://everymac.com/systems/apple/imac/specs/imac-core-2-duo-2.4-20-inch-aluminum-early-2008-penryn-specs.html (or there is a nearly identical variant just with a 2.66 GHZ CPU instead of 2.40 GHz) When you boot pressing Option, as Lord Boltar s...
by fabien85
Wed Apr 10, 2019 5:24 am
Forum: Installation & Boot
Topic: Boot directly to Grub
Replies: 41
Views: 906

Re: Boot directly to Grub

Hi, I second what has been said previously, it's a problem of boot order and you need to find a way to put the entry "ubuntu" first in the order. Now there is another question : in which boot mode is windows installed ? Use the following instructions to find out, from windows : https://www.rodsbooks...
by fabien85
Tue Apr 09, 2019 11:26 am
Forum: Installation & Boot
Topic: [SOLVED] blank screen, no bios, no login screen
Replies: 7
Views: 203

Re: blank screen, no bios, no login screen

Hi, if you can ssh or vnc into the system, then it's running fine and your firmware/BIOS etc is fine. (by the way there is nearly no way you can kill the firmware through normal operations at the OS level. Certainly not by setting a swap file) If you want to disable the swapfile to test, just edit /...
by fabien85
Wed Apr 03, 2019 4:53 am
Forum: Newbie Questions
Topic: Fresh install on Mac Mini - Crashing into Fallback
Replies: 9
Views: 271

Re: Fresh install on Mac Mini - Crashing into Fallback

Something about Apple using a non-standard UEFI implementation IIRC, though I've had had several firmware patches since then, so hoped one might have fixed the issue :) On my MacBook Pro, the firmware updates never solved this problem. However they succeeded in making the wifi stop working in Linux...
by fabien85
Tue Apr 02, 2019 5:39 am
Forum: Newbie Questions
Topic: Fresh install on Mac Mini - Crashing into Fallback
Replies: 9
Views: 271

Re: Fresh install on Mac Mini - Crashing into Fallback

Installing the official NVIDIA drivers causes my monitor to turn off during boot And it doesnt come back ? If so, I had the same problem on a 2010 MacBook Pro. In my case it was a bug in the firmware by Apple (that was OS independent : it also affected people trying to install windows). One possibl...
by fabien85
Mon Apr 01, 2019 4:58 am
Forum: Newbie Questions
Topic: Fresh install on Mac Mini - Crashing into Fallback
Replies: 9
Views: 271

Re: Fresh install on Mac Mini - Crashing into Fallback

Indeed, in this kind of cases I would suggest to try the Mate or Xfce editions.
Another thing to try is to install the driver to the graphic card : Menu > Administration > Driver Manager, then select the nvidia driver, install it, reboot.
by fabien85
Sat Mar 30, 2019 3:46 pm
Forum: Newbie Questions
Topic: Having truble installing TeXmaker
Replies: 3
Views: 92

Re: Having truble installing TeXmaker

Even simpler than synaptic : use Mint's "Software Manager" (Menu > Administration > Software manager), search for texmaker and click install.

Most softwares should be installed like these. It's rare that you would need to install something manually. That's one of Linux's beauty.
by fabien85
Tue Mar 26, 2019 7:52 am
Forum: Installation & Boot
Topic: [Solved] Grub doesn't show on boot
Replies: 29
Views: 952

Re: [Solved] Grub doesn't show on boot

Well the output of efibootmgr looks much cleaner now. You can still delete Boot0002 if you want. Good thing that it worked. For the mess in your grub menu, it's another problem. You used boot-repair at some point, right ? If so, that's what made this mess, trying to be helpful. (that's one of the ma...
by fabien85
Mon Mar 25, 2019 5:08 am
Forum: Installation & Boot
Topic: [Solved] Grub doesn't show on boot
Replies: 29
Views: 952

Re: [Solved] Grub doesn't show on boot

Hi, ok this "Yes" entry points to grub indeed, at its normal location (shimx64.efi is a quick bootloader that complies with secure boot and loads grub). I dont know how it was created though. The bunch of crap are boot entries, they are stored on the NVRAM not on the hard drive. They are mostly harm...
by fabien85
Sun Mar 24, 2019 9:18 am
Forum: Installation & Boot
Topic: [Solved] Grub doesn't show on boot
Replies: 29
Views: 952

Re: [Solved] Grub doesn't show on boot

Congrats.

(I'm not sure I understand what you did)
From the installed Linux, run the following :

Code: Select all

sudo efibootmgr -v
And post here the result between code tags (button </> above the typing area)
by fabien85
Sat Mar 23, 2019 5:23 am
Forum: Installation & Boot
Topic: [Solved] Grub doesn't show on boot
Replies: 29
Views: 952

Re: Grub doesn't show on boot

The problem is that you are booted on the live USB. There, it's normal that you do not have a /boot/grub/grub.cfg, I just checked quickly and I also do not have it if I boot the Mint live USB. To follow the instructions of https://puolanka.info/goto/to-fix-windows-10-broke-uefi-bootloader/ , you nee...
by fabien85
Wed Mar 20, 2019 6:35 am
Forum: Installation & Boot
Topic: [Solved] Grub doesn't show on boot
Replies: 29
Views: 952

Re: Grub doesn't show on boot

There are several things missing in your /boot/grub For example here is the list of files on my computer $ ls -F /boot/grub/ fonts/ grub.cfg grubenv i386-pc/ locale/ unicode.pf2 x86_64-efi/ grub.cfg is the file that dictates the grub menu ; then the directories contain files and/or executables which...

Go to advanced search