Search found 46 matches

by DaveC49
Wed Apr 11, 2018 2:22 am
Forum: Tutorials
Topic: Installing googletest and googlemock v1.8.0 as shared libraries
Replies: 1
Views: 313

Re: Installing googletest and googlemock v1.8.0 as shared libraries

Apologies I missed one flag - add -D BUILD_SHARED_LIBS=ON to the cmake line otherwise it will not build and deploy the libgtest.so, libgtest_main.so, libgmock.so and libgmock_main.so to /usr/local/lib
by DaveC49
Tue Apr 10, 2018 2:44 am
Forum: Tutorials
Topic: Installing googletest and googlemock v1.8.0 as shared libraries
Replies: 1
Views: 313

Installing googletest and googlemock v1.8.0 as shared libraries

I had some difficulty working out how to get googletest and googlemock installed properly as shared libraries on Linux Mint. Looking at a number of Ubuntu and forum posts, quite a few others have had some difficulty as well. Hope this helps someonelse out. The following procedure using Cmake worked ...
by DaveC49
Sun Mar 25, 2018 4:48 am
Forum: Wireless
Topic: Netgear A6100 -rtl8812au kernel 4.13.0-36
Replies: 2
Views: 857

Re: Netgear A6100 -rtl8812au kernel 4.13.0-36

One additional hassle I came across after a kernel update to 4.13.37 was that the driver was installed and running. iwconfig listed the USB adapter with a generic wlxafgdh... type network interface name. I found some posts (links below) on the ubuntu forums which listed changes to the naming of devi...
by DaveC49
Sun Feb 25, 2018 11:51 pm
Forum: Wireless
Topic: Netgear A6100 -rtl8812au kernel 4.13.0-36
Replies: 2
Views: 857

Netgear A6100 -rtl8812au kernel 4.13.0-36

Hi, Recently upgraded LM18.3 Serena to v4.13.0-36 of the kernel and the rtl8812au driver https://github.com/diederikdehaas/rtl8812AU v 4.3.14 wouldn't install with compiler errors for the kernel signal functions. Tried various fixes which didn't work. Then tried https://github.com/gordboy/rtl8812au ...
by DaveC49
Thu Feb 01, 2018 3:48 am
Forum: Software & Applications
Topic: Vagrant (2.0.2)installing vagrant-libvirt with Ruby 2.3.0 [Solved]
Replies: 0
Views: 134

Vagrant (2.0.2)installing vagrant-libvirt with Ruby 2.3.0 [Solved]

While using vagrant from the software manager ( v 1.8.1) and Ruby 2.3.0 ( not 1.9.1 from the Software manager - no doubt a nonon but such is life) I received the following error while trying to install the vagrant-libvirt plugin: $ vagrant plugin install vagrant-libvirt Installing the 'vagrant-libvi...
by DaveC49
Thu Feb 01, 2018 1:24 am
Forum: Software & Applications
Topic: gnome-terminal GtkWarning: Locale not supported...[Solved]
Replies: 0
Views: 78

gnome-terminal GtkWarning: Locale not supported...[Solved]

After a stuffup in which i clearly deleted something I shouldn't have, my gnome-terminal wouldn't start from the menu. When I opened an Xterm and typed in gnome-terminal at the prompt, I received the following message: Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale....
by DaveC49
Wed Jan 17, 2018 9:55 am
Forum: Wireless
Topic: WIFi disappeared after kernel upgrade to 4.13.0-26-generic
Replies: 11
Views: 2092

Re: WIFi disappeared after kernel upgrade to 4.13.0-26-generic

Hi Dieter, I too have a laptop (ASUS) which upgraded to the 4.13.0.-26 kernel without any problems. It has an inbuilt asus_wireless driver module which had no problem with the kernel change. It is only my desktop (older AMD setup) which has a Netgear A6100/AC600 dual band 802.11ac USB adapter using ...
by DaveC49
Tue Jan 16, 2018 7:32 pm
Forum: Wireless
Topic: WIFi disappeared after kernel upgrade to 4.13.0-26-generic
Replies: 11
Views: 2092

Re: WIFi disappeared after kernel upgrade to 4.13.0-26-generic

Thanks Spearmint, Unfortunately I need a dual band 802.11ac compatible dongle which generally means the rtl8811au chipset. The rtl8812au driver should recognise the rtl8811au chipset according to Realtek. I guess the problem is whether that compatability is maintained in the various repositories sup...
by DaveC49
Tue Jan 16, 2018 12:45 am
Forum: Wireless
Topic: WIFi disappeared after kernel upgrade to 4.13.0-26-generic
Replies: 11
Views: 2092

WIFi disappeared after kernel upgrade to 4.13.0-26-generic

I am having similar problems with WiFi on a desktop with a Netgear A6100 usb Wireless adapter after updating the kernel to 4.13.0-26-generic. This adapter uses the Realtek 8811au chipset ( see wireless-info.txt attached ). I initially tried recompiling and reinstalling the driver I had previously us...
by DaveC49
Mon Aug 07, 2017 11:17 pm
Forum: Hardware Support
Topic: Disappearing HDMI Audio on Desktop
Replies: 2
Views: 477

Re: Disappearing HDMI Audio on Desktop

And that it does not occur when the screen saver cuts in or if the HDMI monitor is turned off.
by DaveC49
Mon Aug 07, 2017 8:06 pm
Forum: Hardware Support
Topic: Disappearing HDMI Audio on Desktop
Replies: 2
Views: 477

Re: Disappearing HDMI Audio on Desktop

Can confirm now that suspending LM18.2 cinnamon does cause this behaviour but not sure whether it occurs spontaneously or not when the OS is not suspended.
by DaveC49
Mon Aug 07, 2017 7:54 pm
Forum: Hardware Support
Topic: Disappearing HDMI Audio on Desktop
Replies: 2
Views: 477

Disappearing HDMI Audio on Desktop

Hi I have a desktop running LM18.2 Cinnamon with dual monitors, one of which is connected via HDMI. On a fresh start or restart, the HDMI audio works fine, for a while but then stops some time later. I do suspend my system if I am going to be away for any time and usually overnight. I have yet to ve...
by DaveC49
Wed Apr 05, 2017 4:32 am
Forum: Installation & Boot
Topic: Upgrade from 17.3 to 18.0 -18.1
Replies: 1
Views: 196

Upgrade from 17.3 to 18.0 -18.1

I have seen a lot of posts advising a clean install rather than using the upgrade between major editions of Mint and some reporting performance issues after using the upgrade I had already installed LM18.1 on a laptop with a clean install so i decided to give the upgrade route a try with my desktop....
by DaveC49
Sun Mar 12, 2017 9:15 am
Forum: Installation & Boot
Topic: grub-efi-amd64-signed Installing LM18.1 on ASS Rog G551JM
Replies: 1
Views: 294

grub-efi-amd64-signed Installing LM18.1 on ASS Rog G551JM

My ASUS GM551JM previously ran Windows10 and LM17.3 in a dual boot configuration. As I haven't touched WIndows10 for over 3 years I decided to install LM18.1 as the only operating system. This is a UEFI boot machine with GPT partitioning ( it does have legacy support for MBR and the traditional BIOS...
by DaveC49
Tue Sep 06, 2016 8:27 pm
Forum: Wireless
Topic: Cinnamon 18 64-bit with Asus AC51 USB Dongle configuration problems
Replies: 4
Views: 1369

Re: Cinnamon 18 64-bit with Asus AC51 USB Dongle configuration problems

Hi, I have similar problems with WiFi dongle (AE6000) on a desktop under Mint 18. I suspect it is a problem with Ubuntu 16.04 which is the base for Mint 18. In my case (see my posts re AE6000 problem in Mint 18) I was using Mediatek drivers for the AE6000, compiling and installing them. As well as t...
by DaveC49
Tue Sep 06, 2016 8:18 pm
Forum: Wireless
Topic: WiFi AE6000 dongle not working on Mint 18
Replies: 8
Views: 2907

Re: WiFi AE6000 dongle not working on Mint 18

Have had to give up at this stage and return to Mint 17.3. There are similar issues in Ubuntu 16.04 and Rajit Sanrath has an issue logged on hs bit bucket site (https://bitbucket.org/sanrath/mediatek_mt7610u_sta_driver_linux-64bit/issues?status=new&status=open) for the Mediatek 7610u driver in Ubunt...
by DaveC49
Sun Sep 04, 2016 3:19 am
Forum: Wireless
Topic: Need wi-fi to install wi-fi (yes, you read that right)
Replies: 7
Views: 742

Re: Need wi-fi to install wi-fi (yes, you read that right)

Hi Bernie, Can you use your Windows 7 system and download the necessary files onto a usb then boot to Mint 18. The hard part is you have to do a fair bit of research on the net if the first go doesn't work. ndisgtk is just a graphical front end for ndiswrapper which is a tool to allow you to install...
by DaveC49
Sat Sep 03, 2016 6:27 pm
Forum: Wireless
Topic: WiFi AE6000 dongle not working on Mint 18
Replies: 8
Views: 2907

Re: WiFi AE6000 dongle not working on Mint 18

Hi, More progress in understanding what is working and what is not is not working and why. I have previously used the Mediatek drivers for the AE6000 dongle on Mint17.1, 17.2 1 and 17.3 on the same machine with no problem. Whatever has changed has been going to Mint18 ( Ubuntu 16.04). Things i have ...
by DaveC49
Sat Sep 03, 2016 1:37 am
Forum: Wireless
Topic: Need wi-fi to install wi-fi (yes, you read that right)
Replies: 7
Views: 742

Re: Need wi-fi to install wi-fi (yes, you read that right)

Hi Struck a similar problem with Mint 18 Cinnamon. If you can connect a hard wired ethernet connection to your router it will simplify sorting out problems. I had one snaking across the floor for a day or two until I had drivers downloaded. I have a different dongle (AE6000) and had to download the ...
by DaveC49
Mon Aug 29, 2016 2:44 am
Forum: Wireless
Topic: WiFi AE6000 dongle not working on Mint 18
Replies: 8
Views: 2907

Re: WiFi AE6000 dongle not working on Mint 18

I found a comment added to https://allanbogh.com/2016/01/04/linksys-ae6000-wireless-ac-usb-adapter-in-linux/ where Ubuntu 16.04 displayed the same symptoms of no wifi. suggested solution was: sudo ifconfig ra0 up sudo service network-manager restart This worked and brought my WiFi up (but not the 5G...

Go to advanced search