Search found 53 matches

by jwiz
Thu Jul 30, 2020 10:33 am
Forum: Hardware Support
Topic: Complete GPU freeze in Cinnamon
Replies: 6
Views: 349

Re: Complete GPU freeze in Cinnamon

Seems to me that the update to kernel-5.6 + latest firmware from buster-backports has solved my iGPU issues.
Running that for 1 week now and have not seen a GPU freeze since (fingers crossed).
by jwiz
Tue Jul 28, 2020 12:29 pm
Forum: Software & Applications
Topic: LMDE - "Save Current Session" on Restart
Replies: 1
Views: 79

Re: LMDE - "Save Current Session" on Restart

sudo apt-install dconf-editor

Run dconf-editor and goto:
org > cinnamon > cinnamon-session
and enable auto-save-session

That should do the trick pretty muck like with gnome.
by jwiz
Tue Jul 28, 2020 8:34 am
Forum: Software & Applications
Topic: Incredibly slow window resizing
Replies: 1
Views: 82

Incredibly slow window resizing

When going to 'properties' for a folder or file and trying to assing a new icon, the dialog window for choosing the icons categories from is incredibly slow to resize. Sometimes it takes up to 2 sec. before the resizing actually happens. For some categories it's slower/faster than others. Something ...
by jwiz
Tue Jul 28, 2020 6:52 am
Forum: Software & Applications
Topic: [SOLVED] Display weekday in vertical panel
Replies: 1
Views: 84

Re: Display weekday in vertical panel

Ok, so it's %n for new line.
Who would've thunk! :wink:
by jwiz
Mon Jul 27, 2020 12:05 pm
Forum: Software & Applications
Topic: [SOLVED] Display weekday in vertical panel
Replies: 1
Views: 84

[SOLVED] Display weekday in vertical panel

I'd like to display the weekday in a line above or below the time and not alongside it, as that doesn't work well in a vertical panel view.
Any ideas?
by jwiz
Sat Jul 25, 2020 6:34 am
Forum: Software & Applications
Topic: Minor localisation issue in Cinnamon 4.6.6
Replies: 3
Views: 155

Re: Minor localisation issues in Cinnamon 4.6.6

Another one in the power management settings.
The button ' Shut down immediately' isn't localized.
power_mgmt.png
by jwiz
Sat Jul 25, 2020 4:30 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

... Usually that firmware error just needs a symlink to fix, but that's on Ubuntu-based systems it seems. I'm a bit surprised you had nothing in the firmware/intel/sof folder, but I don't use LMDE so wasn't aware what it was going to take. From what I gathered do far on this topic, it seems that In...
by jwiz
Fri Jul 24, 2020 8:25 pm
Forum: Software & Applications
Topic: Cinnamon crash / mintupdate segfaulting
Replies: 9
Views: 284

Re: Cinnamon crash / mintupdate / xapp-sn-watcher segfaulting

Obviously the xapp-sn-watcher crashes in Cinnamon 4.6.6 aren't just me:

https://www.linuxmintusers.de/index.php ... ic=63194.0
by jwiz
Fri Jul 24, 2020 1:50 pm
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Wouldn't help in this case, as the sof architecture isn't merged into the intel firmware package.
You'd have to grab it from here: https://github.com/thesofproject/linux- ... ster/intel
by jwiz
Fri Jul 24, 2020 6:19 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

No, the GPU freeze hasn't happened with the 5.6 kernel so far, but I'm wary to say it's resolved, as it happened only sporadically.
by jwiz
Fri Jul 24, 2020 6:01 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Well, its obviously not the problem that it can't be done. I just pulled the latest linux-firmware_1.187.2 from Ubuntu, extracted the sof and sof-tlpg and pushed them into /lib/firmware/intel/. Undid the workaround in alsa-base.conf and rebooted. Voila, things work. [ 5.051478] skl_hda_dsp_generic s...
by jwiz
Fri Jul 24, 2020 4:51 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Been reading up a bit about the SOF (Sound Open Firmware) project and it seems that SOF is supported since kernel 5.2 and part of the LF. But the whole thing seems to be under a BSD license. I wonder, if that could be a reason why we don't see the DSP firmware in Debian and thus disabling the dsp dr...
by jwiz
Fri Jul 24, 2020 3:41 am
Forum: Software & Applications
Topic: Cinnamon crash / mintupdate segfaulting
Replies: 9
Views: 284

Re: Cinnamon crash / mintupdate segfaulting

I meant 'downgrading' in mental parenthesis. :wink:
by jwiz
Fri Jul 24, 2020 2:41 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Kadaitcha Man wrote:
Fri Jul 24, 2020 2:27 am
jwiz wrote:
Fri Jul 24, 2020 2:20 am
So it's the first option for the moment.
Good luck getting it fixed if you can't be bothered following the instructions you're given.
???
Your reaction seems a bit over the top, dont you think?
by jwiz
Fri Jul 24, 2020 2:20 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

The sof firmware appears to be missing.
I don't see anything in /lib/firmware/intel/sof*
Installing alsa-firmware-loaders didnt help too.
So it's the first option for the moment.
by jwiz
Fri Jul 24, 2020 1:35 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Hmm..., seems like a firmware problem: jwiz@minibox42:~$ dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel' [ 0.354806] ACPI: Added _OSI(Linux-Dell-Video) [ 0.354806] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio) [ 0.354806] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics) -- [ 1.49...
by jwiz
Thu Jul 23, 2020 2:47 pm
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

Re: No sound device (Intel) found with kernel 5.6.bpo

Both packages were already the latest ones and I also had 'firmware-intel-sound' installed.
update-initramfs didn't make any change.
by jwiz
Thu Jul 23, 2020 7:39 am
Forum: Hardware Support
Topic: No sound device (Intel) found with kernel 5.6.bpo
Replies: 17
Views: 430

No sound device (Intel) found with kernel 5.6.bpo

Seems the 5.6 kernel from buster-backports has issues with detecting the internal Intel sound chip (Realtek ALC233) on my machine. Both 'aplay -l' and 'alsactl init' have not found the sound device. Had to create /etc/modprobe.d/alsa-base.conf and put 'options snd-hda-intel dmic_detect=0' in it to e...
by jwiz
Thu Jul 23, 2020 5:29 am
Forum: Hardware Support
Topic: Complete GPU freeze in Cinnamon
Replies: 6
Views: 349

Re: Complete GPU freeze in Cinnamon

Thanks, going to try that.
by jwiz
Thu Jul 23, 2020 4:36 am
Forum: Hardware Support
Topic: Complete GPU freeze in Cinnamon
Replies: 6
Views: 349

Re: Complete GPU freeze in Cinnamon/FreeRDP

Suffered another GPU hang this morning even with kernel-5.4 and linux-firmware/nonfree from buster-backports.
Seems LMDE 4 really does not like this machine.

Go to advanced search