Search found 13 matches

by iancmx
Thu Jul 02, 2020 8:56 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

I guess I can only wait for Takashi Iwai 's response. Really want to thank you for trying to help me out the past few dasy tho! Really appreciate it! :D
by iancmx
Wed Jul 01, 2020 8:20 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Previously when I applied 0x19 and 0x21, I did the same thing of installing boot overide for it to work. The apply button never worked for me. Before I applied Takashi Iwai patch, i needed to patch 0x19 to get microphone from the headset to work, but after the patch i didnt need to patch 0x19. but i...
by iancmx
Wed Jul 01, 2020 1:31 am
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Currenttly for hdajackretask for 0x21, it is set to: Connectivity: Jack Location: Left Device: Headphone Jack: 3.5mm Color: Green Jack Detection: Present Channel group: 3 Channel (in group): 30 & 31 So I tried changing it to front and pressed apply. However I got an error saying that tee:/sys/class/...
by iancmx
Wed Jul 01, 2020 1:09 am
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 0x02 [sudo] password for iancmx: nid = 0x1, verb = 0x716, param = 0x2 value = 0x0 ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DIR 0x02 nid = 0x1, verb = 0x717, param = 0x2 value = 0x0 ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DATA 0x02 ...
by iancmx
Tue Jun 30, 2020 11:23 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x0f [sudo] password for iancmx: nid = 0x20, verb = 0x500, param = 0xf value = 0x0 ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74 nid = 0x20, verb = 0x477, param = 0x74 value = 0x0 ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 0x01 nid = 0x1, v...
by iancmx
Mon Jun 29, 2020 10:57 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Really appreciate the time and effort you are giving me to help solve this issue. Ive run all the lines and here are my results: ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x06 [sudo] password for iancmx: nid = 0x20, verb = 0x500, param = 0x6 value = 0x0 ➜ ~ sudo hda-verb /dev/snd/hwC0D0 0x20 0x47...
by iancmx
Sun Jun 28, 2020 11:19 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

I ran each of the lines sperately, and still no result. Thanks a lot for the help today!
by iancmx
Sun Jun 28, 2020 11:04 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Unfortunately, i dont think im getting any positive results. Im not sure if im doing this properly. Just to clarify, im supposed to run the 2 pairs of command one at a time, then check to see if i get audio from my headphones right after each run right? Do i have to restart alsa or pulseaudio after ...
by iancmx
Sun Jun 28, 2020 10:23 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Here's the output from running those lines: ➜ ~ sudo su [sudo] password for iancmx: [MX-LAPTOP-MANJARO iancmx]# echo 1 > /sys/module/snd_hda_codec/parameters/dump_coef [MX-LAPTOP-MANJARO iancmx]# exit exit ➜ ~ cat /proc/asound/card0/codec#0 Codec: Realtek ALC294 Address: 0 AFG Function Id: 0x1 (unso...
by iancmx
Sun Jun 28, 2020 8:30 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Unfortunately, after running that line, still no headphone audio. Here's the output of the second line: ➜ Desktop sudo hda-verb /dev/snd/hwC0D0 0x21 SET_PIN_WIDGET_CONTROL 0x40 [sudo] password for iancmx: nid = 0x21, verb = 0x707, param = 0x40 value = 0x0 ➜ Desktop cat /lib/firmware/hda-jack-retask....
by iancmx
Sun Jun 28, 2020 7:38 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

Heres the output: ➜ Desktop curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info\?inline\=false | bash | nc termbin.com 9999 % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 2039 100 2039 0 0 4913 0 --:--:-- --:...
by iancmx
Sun Jun 28, 2020 4:19 pm
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

So I am the guy who posted that bug report. I've just installed the kernel with the patch Takashi Iwai suggested. After using the new patch, headphones were still unrecognized. However, headset mic is being detected, but does not work. Then using HDAjackretask, by setting 0x21 to headphones, the hea...
by iancmx
Mon Jun 01, 2020 2:42 am
Forum: Hardware Support
Topic: No headphone jack detection (ASUS Zephyrus)
Replies: 53
Views: 3805

Re: No headphone jack detection (ASUS Zephyrus)

I have the exact same ASUS ROG Zephyrus M GU502GV and have the exact same problem. Dual booting windows and Manjaro. Similar to you guys, im unable to get detection for headphones. Speaker works fine tho. Any one manage to find a solution?

Go to advanced search