Search found 10 matches

by UnrealMiniMe
Mon Aug 20, 2012 3:17 pm
Forum: LMDE 1 Archive
Topic: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!
Replies: 8
Views: 25313

Re: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!

I GOT IT. You want to follow the guide here: http://forums.linuxmint.com/viewtopic.php?f=42&t=63376&p=364620#p364620 However, make sure you create folders for /run/shm and /run/lock/dev inside of your chroot before you mount /dev/shm. Now, if you make your /etc/crypttab look like it does in the guid...
by UnrealMiniMe
Mon Aug 20, 2012 2:19 pm
Forum: LMDE 1 Archive
Topic: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!
Replies: 8
Views: 25313

Re: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!

I'm currently experiencing the same problem again with another distro I'm testing out, and I'm trying to fix it the "right way" this time without deleting crypttab, etc. You're right about having to make those directories to fix the broken symlink, although there are a couple discrepancies between o...
by UnrealMiniMe
Thu Aug 16, 2012 4:50 pm
Forum: LMDE 1 Archive
Topic: Why are Update Packs based on Testing rather than Sid?
Replies: 6
Views: 7524

Why are Update Packs based on Testing rather than Sid?

I'm starting to wonder what the reasoning was behind this decision. Debian Testing is notorious for its time-based rules and policies preventing frequently updated applications (in Sid) from commonly carrying over, even if the new versions are more stable. Even though these policies are meant to pre...
by UnrealMiniMe
Mon Oct 24, 2011 9:47 am
Forum: LMDE 1 Archive
Topic: Every GTK2 theme but Mint-X/-Metal broken for some apps
Replies: 9
Views: 3568

Re: Every GTK2 theme but Mint-X/-Metal broken for some apps

Thanks for the explanation, guys! It's a shame about my poor, beloved Darklooks, but Atolm and Zukitwo-Dark may just fill the void.
by UnrealMiniMe
Fri Oct 21, 2011 11:42 pm
Forum: LMDE 1 Archive
Topic: Every GTK2 theme but Mint-X/-Metal broken for some apps
Replies: 9
Views: 3568

Every GTK2 theme but Mint-X/-Metal broken for some apps

I'm using a new installation of LMDE x86_64. For some reason, every GTK2 theme except Mint-X and Mint-X-Metal is broken for certain applications, including: gnome-terminal gnome-system-monitor gcalctool gucharmap gdebi-gtk seahorse I just checked, and it turns out this problem even affects the curre...
by UnrealMiniMe
Thu Oct 20, 2011 12:37 pm
Forum: LMDE 1 Archive
Topic: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!
Replies: 8
Views: 25313

Re: LUKS/dm-crypt and LVM: Boot script ordering incorrect!

UPDATE WITH SOLUTION: I have this mostly solved! Apparently, the /etc/crypttab file was causing all of the extra (redundant) password checks / unlock attempts after the first one. In order to make this work correctly, I had to DELETE /etc/crypttab while retaining the following /etc/initramfs-tools/...
by UnrealMiniMe
Thu Oct 20, 2011 9:31 am
Forum: LMDE 1 Archive
Topic: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!
Replies: 8
Views: 25313

Re: LUKS/dm-crypt and LVM: Boot script ordering incorrect!

Update: I've made some progress, but I still haven't solved the problem. I modified the /etc/initramfs-tools/conf.d/cryptroot file again, so it says: CRYPTOPTS=target=sda5_crypt,source=/dev/sda5,lvm=LogicalVolumesOnEncryptedPartition-Root The boot sequence starts up the same: Volume group "LogicalV...
by UnrealMiniMe
Wed Oct 19, 2011 12:34 pm
Forum: Tutorials
Topic: Installing Mint LMDE with whole disk encryption (LUKS+LVM)
Replies: 7
Views: 20497

Re: Installing Mint LMDE with whole disk encryption (LUKS+LV

My experience mostly mirrors pwyll's (except for the happy ending): I got the "too many levels of symbolic links" error. I decided to fix it by copying /var/run/shm to /mnt/var/run/ before chrooting, though. I also had to remove the comments from the /etc/initramfs-tools/modules lines. I also had pr...
by UnrealMiniMe
Wed Oct 19, 2011 12:16 pm
Forum: LMDE 1 Archive
Topic: Encrytion and alternate Installer?
Replies: 1
Views: 693

Re: Encrytion and alternate Installer?

There are a few guides out, including these two: http://forums.linuxmint.com/viewtopic.php?f=141&t=71159&start=0&hilit=encrypt* http://forums.linuxmint.com/viewtopic.php?f=42&t=63376&p=364620#p364620 They seem to work for some people, but they don't work for me (http://forums.linuxmint.com/viewtopic...
by UnrealMiniMe
Wed Oct 19, 2011 10:54 am
Forum: LMDE 1 Archive
Topic: [SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!
Replies: 8
Views: 25313

[SOLVED] LUKS/dm-crypt & LVM boot sequence incorrect!

I'm trying to set up LMDE (x86_64) with an encrypted root partition (using LVM on top of LUKS as usual). I've tried the following two guides, and they both have the same results: http://forums.linuxmint.com/viewtopic.php?f=141&t=71159&start=0&hilit=encrypt* http://forums.linuxmint.com/viewtopic.php?...

Go to advanced search