Search found 169 matches

by Dukenukemx
Wed Jan 08, 2020 3:12 am
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

I solved the problem. I realized that I had updated the PPA from QT5.12 to 5.12.3 to 5.12.6. Doing an "apt remove qt512-meta-full" does not remove the /opt/qt512 folder. So it was just overwriting files when I updated QT. I had to do a ppa purge "sudo ppa-purge -d bionic ppa:beineri/opt-qt-5.12.3-bi...
by Dukenukemx
Mon Jan 06, 2020 9:19 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

After entering in export QT_DEBUG_PLUGINS=1 I reran VLC and got this. Well, the part that's the error. Got keys from plugin meta data ("xcb") QFactoryLoader::QFactoryLoader() checking directory path "/usr/bin/platforms" ... Cannot load library /opt/qt512/plugins/platforms/libqxcb.so: (/opt/qt512/plu...
by Dukenukemx
Mon Jan 06, 2020 9:14 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

If that issue has anything to do with this thread then you are still sourcing that qt512-env.sh from some place. If its gone from /etc/profile.d than its not from there, and you will have to retrace you steps to see what it is you did. The error changes when I remove the qt512-env.sh, so I don't th...
by Dukenukemx
Mon Jan 06, 2020 5:55 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

Simply remove the file from /etc/profile.d again and make sure to reboot or at least logout and back in, then use Karlchen's method to set the required variable specifically for yuzu. I removed the file from /etc/profile.d long ago and Karlchen's method still works for Yuzu but now VLC and Dolphin ...
by Dukenukemx
Mon Jan 06, 2020 1:45 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

Here's the error once I removed qt512-env.sh. VLC isn't the only application effected by this it seems. main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface. qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This applic...
by Dukenukemx
Mon Jan 06, 2020 12:53 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

Just noticed that I can't run VLC anymore and I get this error when I run it in terminal. This QT crap is really pissing me off. Also I put qt512-env.sh in /etc/profile.d/ with no change. At this point I'm OK with putting in that command that @karlchen mentioned, just so long as it doesn't screw wit...
by Dukenukemx
Mon Dec 30, 2019 12:19 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

Re: need export LD_LIBRARY_PATH for .desktop shortcut

How about this approach? Exec=/usr/bin/env LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/qt512/lib" /opt/qt512/bin/yuzu That worked. I used this because yuzu is located in /usr/local/bin/, so you can just use yuzu. I'd like to try and make it so I don't need all that for running applications I compiled, l...
by Dukenukemx
Sun Dec 29, 2019 12:49 pm
Forum: Software & Applications
Topic: need export LD_LIBRARY_PATH for .desktop shortcut
Replies: 14
Views: 269

need export LD_LIBRARY_PATH for .desktop shortcut

I'm trying to run yuzu that I compiled but it requires that I use export "LD_LIBRARY_PATH=/opt/qt512/lib/" in terminal before running it to work. So I put "source /opt/qt512/bin/qt512-env.sh" in .bashrc and it works but only for terminal. It doesn't work for .desktop shortcuts where Exec=yuzu would ...
by Dukenukemx
Tue Feb 12, 2019 9:24 pm
Forum: Software & Applications
Topic: Help install QT 5.10 on Mint 19.1
Replies: 1
Views: 397

Re: Help install QT 5.10 on Mint 19.1

I found a solution. I installed this PPA and that allowed me to compile RPCS3.

https://launchpad.net/~beineri/+archive ... 2.0-bionic

sudo add-apt-repository ppa:beineri/opt-qt-5.12.0-bionic
sudo apt-get update
sudo apt install qt512-meta-minimal
by Dukenukemx
Fri Feb 08, 2019 2:05 pm
Forum: Software & Applications
Topic: Help install QT 5.10 on Mint 19.1
Replies: 1
Views: 397

Help install QT 5.10 on Mint 19.1

I need helping updating QT 5.9.5 to 5.10, but I've not had luck. I downloaded the installer and it put a ton of files in /opt/Qt5.10.0 but qmake -v shows 5.9.5. I've tried editing /usr/lib/x86_64-linux-gnu/qtchooser/default.conf to this. /opt/Qt5.10.0/5.10.0/gcc_64/bin /opt/Qt5.10.0/5.10.0/gcc_64/li...
by Dukenukemx
Sat Dec 15, 2018 12:27 pm
Forum: Graphics Cards & Monitors
Topic: RX 470 wants to run at 30Hz instead of 60Hz refresh rate
Replies: 4
Views: 264

Re: RX 470 wants to run at 30Hz instead of 60Hz refresh rate

So far so good, everything seems fine now.
by Dukenukemx
Thu Dec 13, 2018 8:36 am
Forum: Graphics Cards & Monitors
Topic: RX 470 wants to run at 30Hz instead of 60Hz refresh rate
Replies: 4
Views: 264

Re: RX 470 wants to run at 30Hz instead of 60Hz refresh rate

Thanks roblm, I'll update if this doesn't stick.
by Dukenukemx
Mon Dec 10, 2018 11:01 am
Forum: Graphics Cards & Monitors
Topic: How to get Vulkan support on older AMD GCN cards on Mint 19
Replies: 7
Views: 5620

Re: How to get Vulkan support on older AMD GCN cards on Mint 19

ugly wrote:
Mon Dec 10, 2018 10:40 am
Dukenukemx wrote:
Tue Jul 03, 2018 11:13 pm
Step #3 Install Vulkan

Code: Select all

sudo apt-get install mesa-vulkan-drivers
For Vulkan, I would change this slightly:

Code: Select all

sudo apt-get install mesa-vulkan-drivers mesa-vulkan-drivers:i386
I needed the i386 to get a game that was white-listed on Proton to work.
I've made the changes, thanks.
by Dukenukemx
Mon Dec 10, 2018 10:13 am
Forum: Graphics Cards & Monitors
Topic: RX 470 wants to run at 30Hz instead of 60Hz refresh rate
Replies: 4
Views: 264

RX 470 wants to run at 30Hz instead of 60Hz refresh rate

I have a PC hooked up to a HDTV 4k but running at 1080P and I want the screen to stay at 60Hz but it goes back to 30Hz when I either shut off the TV or if I switch inputs on the TV. I can switch it to 60Hz if I run "sudo xrandr -r 60" but it'll go back to 30. Display doesn't give me options to choos...
by Dukenukemx
Wed Jul 04, 2018 9:47 am
Forum: Graphics Cards & Monitors
Topic: How to get Vulkan support on older AMD GCN cards on Mint 19
Replies: 7
Views: 5620

Re: How to get Vulkan support on older AMD GCN cards on Mint 19

For sake of clarity, Please explain the difference between the driver sets, and why one would chose the non-pro driver. To be honest, I myself have no idea what the non pro driver is designed for. AMDGPU and Radeon are kinda like driver packages in that they contain many things. Both have RadeonSi ...
by Dukenukemx
Tue Jul 03, 2018 11:13 pm
Forum: Graphics Cards & Monitors
Topic: How to get Vulkan support on older AMD GCN cards on Mint 19
Replies: 7
Views: 5620

How to get Vulkan support on older AMD GCN cards on Mint 19

This is a guide for those seeking Vulkan support on their Southern Islands or Volcanic Islands graphic cards. Another name is Radeon HD 7000 series and Rx 200 series. Basically the open source drivers by default use Radeon for these graphic cards, which has no RADV for vulkan support. The AMDGPU-PRO...
by Dukenukemx
Tue Jul 03, 2018 10:45 pm
Forum: Software & Applications
Topic: For AMD users who can't get Minecraft to work on Mint 19
Replies: 3
Views: 413

Re: For thoes who can't get Minecraft to work on Mint 19

Hoser Rob wrote:
Tue Jul 03, 2018 9:27 am
Nice that it works but maybe you should rename the thread to something like "For AMD users who can't get Minecraft to work on Mint 19".
I fixed it thanks to your suggestion.
by Dukenukemx
Tue Jul 03, 2018 9:14 am
Forum: Software & Applications
Topic: For AMD users who can't get Minecraft to work on Mint 19
Replies: 3
Views: 413

For AMD users who can't get Minecraft to work on Mint 19

If you're getting "OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread' and using open source drivers, you need to create a config file to fix this. I use an AMD graphics card so I made a 20-radeon.conf in /usr/share/X11/xorg.conf.d/ and put this in it. Section "Device"...
by Dukenukemx
Mon Jul 02, 2018 6:32 pm
Forum: Cinnamon
Topic: Mint 19 Cinnamon freezes eventually
Replies: 5
Views: 2908

Re: Mint 19 Cinnamon freezes eventually

Another update, I'm using Cinnamon now and no problems yet. Would only take a few minutes before it'll freeze. I'll update if it happens again.

Go to advanced search