Search found 106 matches

by bigbenaugust
Wed May 25, 2016 9:33 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

I would say compile the latest and install to /usr/local or /opt/local if you can. Otherwise, look at using mount.cifs and mounting the shares instead of using smbclient.
by bigbenaugust
Wed May 18, 2016 9:29 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

The bug has been resolved upstream. So on our RHEL servers where we actually needed smbclient, we've compiled the latest source and dropped it in /usr/local/bin so we can keep those jobs running.

Now, how long the upstream fix is going to take to get to Debian... who knows.
by bigbenaugust
Tue Apr 26, 2016 10:34 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

After getting into it with our Storage team and reviewing some RHEL and NetApp docs, it looks like the latest Samba is being more rigid about enforcing packet signing then the server (or appliance) is. The server is trying to negotiate for a downgrade in protocol and Samba isn't allowing it (could b...
by bigbenaugust
Mon Apr 25, 2016 12:17 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

Running smbclient with a debug level of 10 gets me this down at the end: Starting GENSEC mechanism spnego Starting GENSEC submechanism ntlmssp negotiate: struct NEGOTIATE_MESSAGE Signature : 'NTLMSSP' MessageType : NtLmNegotiate (1) NegotiateFlags : 0x62088215 (1644724757) 1: NTLMSSP_NEGOTIATE_UNICO...
by bigbenaugust
Mon Apr 25, 2016 10:46 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

JayBird707 wrote:I'm really getting bummed. It seems like every time I reboot the last work around doesn't work any more. Does anyone have any news?


I have contacted our storage team downstairs to see what I'm generating on the appliance end. Maybe that will help me figure out what to change on this end.
by bigbenaugust
Fri Apr 22, 2016 11:09 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

It is interesting to note that the Debian Security update for samba (4.2.10) is labeled as "do not use" at samba.org.
by bigbenaugust
Thu Apr 21, 2016 10:59 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

I did try setting the netbios name in smbclient and it did not help the issue.
by bigbenaugust
Wed Apr 20, 2016 9:10 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

I noted the Samba upgrade a couple of days ago and installed it OK. I had not needed any printouts since so I tried it here. It printed but not before there was a warning flashed on the screen about"Samba broken". A moment after the flash the Xerox printer printed the 1 page like it was s...
by bigbenaugust
Wed Apr 20, 2016 5:13 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

If it's worth anything, I just upgraded my Debian Sid machine and got a message about a samba upgrade that fixed several serious security issues, but also was likely to break existing samba configs (which I don't use, so no worries there). I can try to dig that message up if needed and post it here...
by bigbenaugust
Wed Apr 20, 2016 3:25 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

OK, I at least got smbclient working so I can get on with life in the office. Turning debugging up to ludicrous levels and googling for errors was unproductive, but the timing suggests that this is related to the badlock-related patches from security.debian.org of last week. Fedora, Ubuntu, and Debi...
by bigbenaugust
Wed Apr 20, 2016 8:19 am
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

I have just tested a third LinuxMint 17.3 computer. Samba worked OK on it. Then I updated the computer. Afterwards Samba did not work!! The update included: samba 2:4.3.8+dfsg-0ubuntu0.14.04.2 Also samba-libs; samba-common; samba-common-bin; smbclient with the same version details Yeah, my Xubuntu ...
by bigbenaugust
Tue Apr 19, 2016 2:13 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

On my work machine, I connect to two CIFS shares on a regular basis.
After the update last week, one of them still works and one of them doesn't. I am still looking into this.
by bigbenaugust
Mon Apr 18, 2016 1:17 pm
Forum: Archive
Topic: Latest updates broke Samba
Replies: 35
Views: 11030

Re: Latest updates broke Samba

DarkNova wrote:Thanks. In my case the packages installed fine, so Samba isn't really broken in that sense, more in the sense that there may have been a bug introduced with this update.


Yes, I think so.
by bigbenaugust
Sat Apr 16, 2016 10:33 pm
Forum: Newbie Questions
Topic: iptables script blocking too much
Replies: 3
Views: 406

Re: iptables script blocking too much

This is been a pain in the butt but I feel like im learning alot. :lol: This quote is glorious. 20 years as a UNIX admin... and this sentence just about sums it up. Back to the issue at hand, if you happen to be blocking outbound DNS (UDP port 53), then that will foul up lookups. But you shouldn't ...
by bigbenaugust
Fri Apr 15, 2016 8:59 pm
Forum: Newbie Questions
Topic: iptables script blocking too much
Replies: 3
Views: 406

Re: iptables script blocking too much

It is my understanding that ufw simply provides a slightly more human-friendly interface to iptables rules. For instance, you can set up rules using ufw and then list them using sudo iptables --list An application firewall is more like allow/deny rules in Apache or OpenSSH. It exists above the level...
by bigbenaugust
Wed Apr 13, 2016 11:53 pm
Forum: Newbie Questions
Topic: LMDE 2 Betsy 32 bit Mate - Shutdown
Replies: 4
Views: 436

Re: LMDE 2 Betsy 32 bit Mate - Shutdown

Seems like your hardware is modern enough that shutdown should have worked, assuming a default user config.
But if you reinstalled with 64-bit, we'll never get those log messages anyway. Oh well.

My ancient Mac, which runs LMDE2 32-bit MATE, has no trouble whatsoever shutting down from the desktop.
by bigbenaugust
Wed Apr 13, 2016 10:23 am
Forum: Newbie Questions
Topic: LMDE 2 Betsy 32 bit Mate - Shutdown
Replies: 4
Views: 436

Re: LMDE 2 Betsy 32 bit Mate - Shutdown

What hardware are you using? If you have really really old hardware, it may not understand the shutdown signal the OS is sending. Just a first guess. Some logs and such would be useful, too. For instance, inxi -Sxv 7 would get us some hardware info, and dmesg might tell us what it's doing when you s...
by bigbenaugust
Mon Apr 11, 2016 4:00 pm
Forum: Newbie Questions
Topic: Is this safe to add to sources list
Replies: 3
Views: 520

Re: Is this safe to add to sources list

Depends on what you want to pull from backports. On my LMDE2 machines, I am just pulling LibreOffice and the kernel and haven't had any trouble.
by bigbenaugust
Tue Apr 05, 2016 3:55 pm
Forum: Newbie Questions
Topic: Rolling release or need to reformat after a new version come out ?
Replies: 2
Views: 432

Re: Rolling release or need to reformat after a new version come out ?

You can do an upgrade in place with Debian by changing the repos to the new version and doing an apt-get dist-upgrade.
Some find it cleaner to install from scratch, however.

But since Debian only releases a new stable every other year... you have time to worry about this. ;)
by bigbenaugust
Sun Feb 14, 2016 9:38 pm
Forum: Software & Applications
Topic: postgresql-9.4 installation warning - ID_LIKE
Replies: 2
Views: 404

Re: postgresql-9.4 installation warning - ID_LIKE

Check the /etc/os-release file?

https://www.freedesktop.org/software/systemd/man/os-release.html

Maybe it needs a line like:

Code: Select all

ID_LIKE=Debian


?

Go to advanced search