Solved? MDM will not let me log in

Forum rules
Before you post please read how to get help
Level 2
Level 2
Posts: 68
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Solved? MDM will not let me log in

Postby blue_bullet » Wed Aug 28, 2013 2:45 pm

I installed Linux Mint 15 KDE on my existing dual boot system along with Windows 8 and Linux Mint 14 KDE (all 64 bit) on an HP Envy dv7 with (UEFI). I applied the updates after the install. I updated to KDE 4.11 as that is what I have on 14 KDE. I have separate /home partitions which in the past have allowed me to copy my home directories from one Linux Mint release to the next and in that way preserve my data and settings. The command I use for that in Konsole is:

sudo cp -p -r -v "/media/rob/5d565130-9b06-4bc1-904f-d943120c5ccb/rob" "/home", where rob is my userid. That copies data from my LM14 home partition to my LM15 home partition preserving permissions and timestamps.

This has worked in the past moving from 12 to 13 and 13 to 14, but now I get the error message in MDM "Could not start D-Bus. Can you call qdbus?" with the ~/.xsession-errors file stating 5 times "Failed to connect to the VIrtualBox kernel service". Then back to the MDM screen. I can login with another userid with admin priviledges on LM15 to issue sudo commands to fix my problem, but I don't know what my problem is. I suspect something in the .kde directory as I had customized it a bit on Linux Mint 14. Can someone suggest a way to fix this loop I am in?
I just keep coming back to MDM without a way to log in with just a console. Rebooting with recovery only allows me to log in as root. I have spent several days Googling this and reinstalling to no avail.
Also I would like suggestions on better ways to preserve data between releases.

I should add that GNU GRUB version 2.00-7ubuntu11 offers my Linux Mint 14 KDE version along with Windows 8 and Olivia, but the login screen keeps coming back w/o a message after I select a user and provide a password so I can no longer get to Linux Mint 14 KDE. Windows 8 works fine and Olivia lets me log in with one userid (no copying between home directories yet) but not on the one where I copied /home/rob (LM14) to /home/rob (LM15).

Here's particulars people always ask about:

fargo (HP DV7T-7200 Quad Edition)
Linux Mint 15 KDE
Windows 8 Home - brista

Wenesday, August 28, 12:29 P

Output from CLI ( inxi -Fc 0 >h.txt; kate h.txt):
System: Host: fargo Kernel: 3.8.0-26-generic x86_64 (64 bit) Desktop: KDE 4.11.00 Distro: Linux Mint 15 Olivia
Machine: System: Hewlett-Packard product: HP ENVY dv7 Notebook PC version: 088A110000305920000620100
Mobo: Hewlett-Packard model: 181C version: 52.24 Bios: Insyde version: F.22 date: 11/02/2012
CPU: Quad core Intel Core i7-3630QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz 3: 1200.00 MHz 4: 1200.00 MHz 5: 1200.00 MHz 6: 1200.00 MHz 7: 1200.00 MHz 8: 1200.00 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.1.3
Audio: Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.8.0-26-generic
Network: Card-1: Ralink Device 539b driver: rt2800pci
IF: wlan0 state: up speed: N/A duplex: N/A mac: a4:17:31:ab:a0:cf
Card-2: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: down mac: a0:b3:cc:4c:17:4f
Drives: HDD Total Size: 1000.2GB (1.6% used) 1: id: /dev/sda model: Hitachi_HTS54101 size: 1000.2GB
Partition: ID: / size: 19G used: 5.1G (30%) fs: ext4 ID: /home size: 74G used: 9.4G (14%) fs: ext4
ID: /boot size: 454M used: 49M (12%) fs: ext4 ID: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 52.0C mobo: 52.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 245 Uptime: 2 min Memory: 909.7/7875.6MB Client: Shell inxi: 1.8.4

Rob Burness
Last edited by blue_bullet on Thu Aug 29, 2013 3:19 pm, edited 1 time in total.

User avatar
Level 10
Level 10
Posts: 3029
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: MDM will not let me log in

Postby nomko » Wed Aug 28, 2013 4:21 pm

Level 2
Level 2
Posts: 68
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Solved? Re: MDM will not let me log in

Postby blue_bullet » Thu Aug 29, 2013 3:17 pm

I started with a new home directory and began copying files selectively. Here's what I learned. The file ~/.kde/env/ is no longer honored by the rewritten /usr/bin/startkde program. If I rename the env directory to env_hold, I can log in. If I rename it back to env, I get caught in the loop that asks me about qdbus again, and I cannot login. I looks as though the person who rewrote the startkde program was unable to completely test it.

Here is what my looks like:

# User specific environment variables go here. Program name can be anything. It just needs to reside in the /home/user/.kde/env directory.
# /etc/environment does not resolve variables like $HOME on the rhs of equation so put variables like that here if you use kde.
# It is also suggested you put something like "source $HOME/.kde/env/", where is this program, as last line of .bashrc.
# .pam_enviroment also runs in the kde environment, but I have not figured out how to get pam to resolve $ variables.

# Adding rcss directories so all machines in rcss have access to the same settings:
export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:"$HOME"/Dropbox/shared_rcss_complex:/usr/local/share/rcss"

# This is where The Hessling Editor looks for the (rexx) macros you may use:
#export THE_MACRO_PATH=$HOME"/source/the_macros"
# This path looks at dropbox instead of line commented line above:
export THE_MACRO_PATH=$HOME"/Dropbox/shared_files/source/the_macros"
# Create a variable WAMI (Who or Where Am I) just for kicks:

I use along with Dropbox to keep all users on my systems current and to keep my maintenance simple. Obivously I got blown out of the water on that one.
I guess I need to find out how to report this as a bug or a program that needs more testing.

Level 2
Level 2
Posts: 68
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Re: Solved? MDM will not let me log in

Postby blue_bullet » Thu Aug 29, 2013 7:41 pm

I filed a bug with, but the problem may lie with the /usr/bin/startkde program which may have been written and maintained by the Linux Mint team.
If so it needs to be fixed by them rather than KDE developers. I have worked around the problem by placing the paths I need in ~/.kde_orig/env/
Do I need to report this differently so it can be fixed and so others do not run into the same problem? Kinda feel like I am talking to myself here...

Level 2
Level 2
Posts: 68
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Re: Solved? MDM will not let me log in

Postby blue_bullet » Fri Dec 13, 2013 6:56 pm

This problem is back with Linux Mint 16 KDE 64 bit RC. If ~/.kde/env directory exists I cannot log in. Can this be fixed before the stable release?
Here is the reference for setting environment variables in kde:

Maybe I should post this somewhere else where it will get developers attention. Any suggestions?

Level 2
Level 2
Posts: 68
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Re: Solved (Again)? MDM will not let me log in

Postby blue_bullet » Sun Dec 22, 2013 6:57 pm

If no path statement exists in /etc/environment MDM fails with messages in .xsession-errors that lead me nowhere with Google searches.
Something like "Error in MDM 5: exec; Init not found." I could press ctrl+alt+F2, login and issue startx and get the desktop, but Cron was not around along with many other things I rely on. By trial and error I found the problem.
It turns out that if I have no path assignment in /etc/environment rather relying on it being set in some file * in ~/.kde/env/*.sh, e.g. /home/rob/.kde/env/ then MDM fails with fairly useless error messages. If I place a valid path in /etc/environment everything works and my variable expansion takes place in (variable expansion cannot take place in /etc/environment). This behavior is different than in LM 15 KDE. In LM 15 KDE my path statement in /etc/environment was commented out and path assignment took place in my file. While not necessarily a bug the behavior in LM 16 KDE is certainly different and not documented. FWIW I migrated my home directories via sudo cp -r -p -v from my LM 15 KDE partition.

It took me 3 days to track this thing down and solve it (again). It took me 3 days only b/c I am deceptively slow. ;> The upside is I learned something. That's what I like about Linux Mint and linux in general; you get to learn things that most people could care less about.

I just thought I would mention it in case others are trying to do things with the convoluted mess of processing environment variables and setting paths. I think the mess is due to the various places unix came from (UCal/Berkely, Bell Labs, DoD, ...) and the need/desire to acommodate all approaches to minimize forks.
For those interested here is a link to an excellent explanation of environment variables:

I will post this in the comments section on the Petra KDE Release annoucement as well since I sorta complained there.

Return to “KDE”

Who is online

Users browsing this forum: No registered users and 1 guest