Konqueror is prefixing gg: to my searches

Forum rules
Before you post please read how to get help
griffeth
Level 1
Level 1
Posts: 4
Joined: Fri Apr 24, 2009 9:34 pm

Konqueror is prefixing gg: to my searches

Postby griffeth » Fri Apr 24, 2009 9:54 pm

Hello,

I am running Linux Mint 6 KDE, and am very happy with it. However, there is one problem. I must have caused it myself, as it does not appear in other user accounts.

In Konqueror, I somehow messed up the search function. If I type something into the address bar (that isn't a URL) then it will search google for it. However, if I type something into the search bar, beside the address bar, it will search google for it, but prefix gg: to it.

For example, if I want to find "hello," it should search google for "hello." But instead, it searches for "gg:hello."

It's not that big a problem, I can just use the address bar instead, but I would like to fix this. I've tried editing the search engines, deleting ~/.kde/share/kde4/services/searchproviders, ~/.kde/share/apps/konqueror, and ~/.kde/share/config/konquerorrc, but konqueror insists on prefixing gg: to everything.

What other files/folders should I delete, or what else should I do?

Thank you for taking time to read this,
Griffeth

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: Konqueror is prefixing gg: to my searches

Postby nick » Sat Apr 25, 2009 12:38 pm

HI

Maybe? this will help.

http://docs.kde.org/stable/en/kdebase-a ... wsing.html

If enabled, Konqueror's Web Shortcuts feature lets you submit a query directly to a search engine or similar web site without having to visit the site first.
For example, entering gg:konqueror into the Location Bar and pressing Enter will ask Google™ to search for items related to Konqueror.
To see what Web Shortcuts are available, and perhaps add your own, use Settings->Configure Konqueror... to open the Settings dialog box and click on the Web Shortcuts icon.

Nick

griffeth
Level 1
Level 1
Posts: 4
Joined: Fri Apr 24, 2009 9:34 pm

Re: Konqueror is prefixing gg: to my searches

Postby griffeth » Sat Apr 25, 2009 4:21 pm

Thanks, but that doesn't help me. I have Web Shortcuts enabled, but I can't understand why it actually searches Google for "gg:my search" instead of just "my search."

dafi
Level 1
Level 1
Posts: 34
Joined: Sat Sep 27, 2008 8:55 am

Re: Konqueror is prefixing gg: to my searches

Postby dafi » Sun Apr 26, 2009 11:45 am

Clock on the little arrow at the google-sign in the searchbox.
Choose something like "Select Searchengines"
Search for "google" in the following list and click edit.
the URL in Linux Mint 5 is:

Code: Select all

http://www.google.de/search?q=\{@}&ie=UTF-8&oe=UTF-8


Perhaps you could try this one?? (But safe your old one before changing it)

griffeth
Level 1
Level 1
Posts: 4
Joined: Fri Apr 24, 2009 9:34 pm

Re: Konqueror is prefixing gg: to my searches

Postby griffeth » Sun Apr 26, 2009 3:59 pm

Thanks, but that didn't make a difference.

I discovered something else: no matter which search engine I select, it will always search Google, and prefix the search engine's letters.

For example, if I try to search Wikipedia for "Hello," instead of taking me to the Wikipedia page for Hello, it searches Google for "wp:hello."

dafi
Level 1
Level 1
Posts: 34
Joined: Sat Sep 27, 2008 8:55 am

Re: Konqueror is prefixing gg: to my searches

Postby dafi » Sun Apr 26, 2009 4:57 pm

At the bottom of the "enable web shortcuts" window is a DropDownfield.
You could set this to "colon" or to "space" (or something like that)
If I set this to space I get the same behaviour. Perhaps your setting is "space" but you should set it to colon?
Try "gg hello"
if this works, then you should change your settings...

griffeth
Level 1
Level 1
Posts: 4
Joined: Fri Apr 24, 2009 9:34 pm

Re: Konqueror is prefixing gg: to my searches

Postby griffeth » Mon Apr 27, 2009 10:28 pm

That cleared up the problem. I've always preferred using space, the way Opera does, but this is fine too. Thank you.


Return to “KDE”

Who is online

Users browsing this forum: No registered users and 5 guests