[SOLVED] CUPS -New Printers - Live and Installed - KMint RC1

Forum rules
Before you post please read how to get help
Post Reply
User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

[SOLVED] CUPS -New Printers - Live and Installed - KMint RC1

Post by rec9140 » Tue Feb 15, 2011 9:15 pm

When testing using the Live DVD for KMint RC1 ( I test under live DVD till I have all software and devices tested then install to a test *physical* PC) and seem to run into a couple of issue with CUPS and printer

Under the live DVD when you got to New Network Printer the menu to pick a type like LPR etc. when it its just blank no types of printers to move to the next step, so you can not add a printer to test.

When I did this with my initial Live test, I installed the missing HPLIP GUI and installed my normal HP network printers from the "lab" and didn't notice this...

Doing this in a different test lab, I found this was not finding any printers.

KDE or KMint or CUPS? ?

The next issue is extraneous items in the menu to pick for network printers to install... On my particular test subnet I have several network based printers from Sharp MX4501 to several HP 4300's.

I get a lot strange and extra items in the menu... this has been persistent since about KMint 8, 7 didn't have this as it didn't even find the printers.. I could set them up by hand and they would work...

Heres what I get on my installed test laptop
cups_new_printers.png
cups_new_printers.png (52.16 KiB) Viewed 1242 times
I've ignored all these items to install by hand by type to ensure that correct settings are applied... but this could be an issue for some.


Heres what I get on a LIVE DVD on a different system, or the laptop in LIVE DVD use, same location, same network, WIRED or wireless (802.11a/b/g)
empty_CUPS.png
No CUPS devices
empty_CUPS.png (523.57 KiB) Viewed 1229 times

KDE or KMint or CUPS? ?
Last edited by rec9140 on Tue Apr 05, 2011 7:06 am, edited 1 time in total.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: CUPS -New Printers - Live and Installed - KMint RC1

Post by rec9140 » Thu Mar 31, 2011 9:13 am

The problem for this on a LIVE DVD with BLANK printer choices and now way to proceed is that CUPS is not starting/ed and will not start for some reason on the LIVE DVD.

On an installed setup, I've not run into this again, so am chalking up to a momentary glitch.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: CUPS -New Printers - Live and Installed - KMint RC1

Post by rec9140 » Mon Apr 04, 2011 8:57 pm

OK.. this one is solved now too..

apparmor ....

When you start the Live DVD or a USB:

Code: Select all

mint@mintkde /etc/apparmor.d $ sudo ln -s /etc/apparmor.d/usr.sbin.cupsd /etc/apparmor.d/disable/
mint@mintkde /etc/apparmor.d $ sudo apparmor_parser -R /etc/apparmor.d/usr.sbin.cupsd 
mint@mintkde /etc/apparmor.d $ sudo service cups start
cups start/running, process 4324
mint@mintkde /etc/apparmor.d $ 
CUPS will now be started and you can run the printer configuration.

If your using a USB device as a walk up OS to an infested device, this is PERSISTABLE! My USB Keyring is now setup with HPLIP and the printers in my office and home, and able to add what I need where ever I go.

The issue with the spurious devices is a KDE Printer Manager BUG and is still present... but CUPS not getting started on the Live DVD is resolved.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

Post Reply

Return to “KDE”