How to Disable PulseAudio for use with Skype?

Forum rules
Before you post please read how to get help
Post Reply
bobg
Level 1
Level 1
Posts: 5
Joined: Mon Oct 12, 2009 2:55 pm

How to Disable PulseAudio for use with Skype?

Post by bobg » Fri Mar 25, 2011 3:40 pm

Cannot get Skype to use my Dynex Webcam in the Options menu. It insists on using PulseAudio server
without giving me any options in the drop-down menu. How do I disable PulseAudio so that I can choose
my own sound capture items?

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: How to Disable PulseAudio for use with Skype?

Post by mads » Wed Mar 30, 2011 11:06 am

How To: Completely remove PulseAudio & replace it with ALSA

@ Edit: "rec9140" (see next post) is right. I was not aware OP was using KDE.
Last edited by mads on Sun Apr 17, 2011 6:41 am, edited 1 time in total.

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: How to Disable PulseAudio for use with Skype?

Post by rec9140 » Wed Mar 30, 2011 2:33 pm


I would caution those following this HOWTO that this is OUTSIDE the KDE branch of the forum and references packages and items in the GUI which are NOT KDE.

Aslo CAREFUL about rm'ng /etc/asound.conf IF YOU HAVE ALSA PLUGINS on KDE defined! ! !

Normally on KDE /etc/asound.conf is NON EXISTANT! Others need to plug in the craPulse in /etc/asound.conf


So if your like me and have defined ALSA plugins do NOT rm /etc/asound.conf ! ! !

esound is not normally a part of KDE, but used with another DE.

**** DANGEROUS *** but will achieve what you want.. a dead pulseaudio... I know I've done it!

Code: Select all

cd /usr/bin
****** WARNING ************* DANGEROUS *************************
sudo mv pulseaudio XpulseXaudioX
Can not run what you can not find! :twisted:

Its a little brute force, but you can REVERT!

Code: Select all

sudo mv  XpulseXaudioX pulseaudio
When KDE asks you to forget about the craPulse connection tell it no if you want to revert to them...

Why this is even in KDE I have no clue, its junk on regular *buntu(s) and KDE doesn't play nice with craPulse anyway.

The idea of removing this crud goes against my policy... but I can not find what init or other auostart is starting this crap up... I moved various /etc/xdg/autostart files referencing it and other things with no joy... then I brute force'd it... bye bye crap!

KMINT Dev(s): Please REMOVE pulseaudio and RETURN OSS kernel support in KMint 11 Kataya (I really like that name! :) )
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: How to Disable PulseAudio for use with Skype?

Post by rec9140 » Wed Mar 30, 2011 8:08 pm

While my procedure is a bit hackish, ok a LOT hackish and brute force... but I can gurantee it works...

I nuked pulsecrap and then I installed skype and plugged in my Logitech 510 web cam and tested it out works with both... I don't have a headset in my bag right now... but the sounds work and even using the crappy built in mic of my laptop the echo test was PERFECT.
skype1.png
Skype
skype1.png (52.24 KiB) Viewed 4680 times
The attachment skype2.png is no longer available
Attachments
skype2.png
Skype
skype2.png (96.51 KiB) Viewed 4680 times
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
Enna
Level 2
Level 2
Posts: 96
Joined: Sun Sep 12, 2010 1:34 am

Re: How to Disable PulseAudio for use with Skype?

Post by Enna » Mon Apr 25, 2011 5:33 pm

Hi there,

tried to get rid of PA and used this guide here... but all my Terminal does is this:

Code: Select all

cd /usr/bin
anna@anna-K70AD /usr/bin $ ****** WARNING ************* DANGEROUS *************************
bash: [: Fehlende `]'
anna@anna-K70AD /usr/bin $ sudo mv pulseaudio XpulseXaudioX
anna@anna-K70AD /usr/bin $ sudo mv  XpulseXaudioX pulseaudio
...nothing happens!
Is there another way to kill PulseAudio? Would like to make Skype work...

Cheers,
Enna
Linux Mint 15 Olivia / 64-bit / Cinnamon

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: How to Disable PulseAudio for use with Skype?

Post by rec9140 » Mon Apr 25, 2011 6:02 pm

Enna wrote: Is there another way to kill PulseAudio? Would like to make Skype work...
Start up Konsole:

Code: Select all

cd /usr/bin
sudo mv pulseaudio XpulseXaudioX
Go into System monitor find pulseaudio in the list of processes, and kill it.

pulsecrap is now dead!

Reboot or at a minimum log out and log in again other wise you will have no KMixer controls .. .When KDE informs you that it can not find "Pulse audio Inputs" click no and go on... this allows you to test things out and revert if you need to... I've tested it out with my hardware and found no need to continue to deal with the this message so I click ignore for these devices in future and click YES to tell pulsecrap to be gone for good!

Install skype:

Code: Select all

sudo apt-get install skype
Looks like the repos have updated... I based my test on earlier versions have no clue if the latest works.. guess I should have kept the old DEB around.. but I don't really use it anyway.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

User avatar
Enna
Level 2
Level 2
Posts: 96
Joined: Sun Sep 12, 2010 1:34 am

Re: How to Disable PulseAudio for use with Skype?

Post by Enna » Thu Apr 28, 2011 5:40 am

You know what, after being 9 months abroad, far away from my home country,FINALLY Skype works and I can talk to friends and family! For the first time, after spending a lot of time, (which I don't really have), with many different Mint Editions to get it to work and now it does. Well rec9140 you gave the most valuable help of all, so thank you! :)
...and also, I always believed Skype will work with Linux and I really don't want Windows (Windoofs für alle die Deutsch verstehen), not even on a small partition on my laptop or somewhere near my computer sphere :mrgreen:
Linux Mint 15 Olivia / 64-bit / Cinnamon

User avatar
rec9140
Level 5
Level 5
Posts: 629
Joined: Wed Mar 12, 2008 4:58 pm
Contact:

Re: How to Disable PulseAudio for use with Skype?

Post by rec9140 » Thu Apr 28, 2011 6:19 am

Enna wrote:You know what, after being 9 months abroad, far away from my home country,FINALLY Skype works and I can talk to friends and family! For the first time, after spending a lot of time, (which I don't really have), with many different Mint Editions to get it to work and now it does. Well rec9140 you gave the most valuable help of all, so thank you! :)
...and also, I always believed Skype will work with Linux and I really don't want Windows (Windoofs für alle die Deutsch verstehen), not even on a small partition on my laptop or somewhere near my computer sphere :mrgreen:
Well I am glad to help.. I don't support winstupper any longer... Reboot, don't work, oh well sorry. call some one who cares... :mrgreen:

I am on a mission to eliminate all winvirus systems at my agency... I've been Linux only for 3+ years now with zero issues.. 100% of this is a DIRECT RESULT of KMint! :D

KDE done right.. I don't venture outside KDE Land, ever, its just a wasteland...
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....

Orbital_sFear
Level 1
Level 1
Posts: 6
Joined: Thu Mar 01, 2012 6:11 am

Re: How to Disable PulseAudio for use with Skype?

Post by Orbital_sFear » Fri Mar 02, 2012 5:44 am

I really can't believe this method of renaming pulseaudio works! I renamed pulse audio, then ran pulseaudio --kill. Started up skype and finally I could select the correct sound device!!!

Thanks a ton. Now I just hope my system will come to life on my next reboot =)

-Oribtal

Post Reply

Return to “KDE”