having troubles with dd

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 5
Joined: Mon Jul 30, 2012 2:48 am

having troubles with dd

Postby caslie » Tue Aug 07, 2012 1:24 am

i tried to download arch linux iso out of curiousity and made the command

# dd if=archlinux.iso of=/dev/sdb

it went okay but i changed my mind but when i tried to use the USB it can't be used anymore.. It was 4GB USB but now the system only detects 125MB..
i also tried using # dd count=1 bs=512 if=/dev/zero of=/dev/sdb but to no avail...

i also tried gparted but it doesn't detect any partition.. i also tried formatting it in windows 7 but windows failed in formatting.. it only detects 125MB out of the 4B...

help!!! thanks.

User avatar
Level 17
Level 17
Posts: 7951
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: having troubles with dd

Postby karlchen » Wed Aug 08, 2012 4:42 pm

Hello, caslie.

Maybe this article will help solve your problem and return your pendrive to its initial size: How To Use DiskPart Command To Recover Missing Or Unallocated Space On A USB Drive. Windows Diskpart is used to recover the unallocated space which is present but cannot be accessed.
Reason: By using dd to write an ISO image to the pendrive which was smaller than the pendrive the pendrive partition table has been changed now suggesting the available "disk" space were much smaller than the pendrive actually is.

Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

Return to “XFCE”