Newbie: after installation, "Failed to start the X server"

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 9
Joined: Wed Sep 18, 2013 7:16 am

Newbie: after installation, "Failed to start the X server"

Postby mintisthebest » Thu Sep 19, 2013 5:02 am

I've taken the liberty of copying the below from the Newbie section where it has not got any replies.

After installation, "Failed to start the X server" error

Postby mintisthebest on Wed Sep 18, 2013 10:56 pm
Please left me describe the lengthy sequence of events. It may be long winded but I hope it will contain the information an expert requires to tell me how to fix things. I am a complete newbie to Linux so would appreciate specific detailed step-by-step instructions about exactly what to do please.

My computer is a Dell Dimension L700CXE, with a 698Mhz CPU and 512MB Ram. I have an old Matrox mga video card. I had tried a variety of Linux OS's in the search for the best one. I previously had Debian LXDE installed which worked OK. But even so I know nothing about Linux and have never used it before.

What happened:
1. I ran linuxmint-13-xfce-dvd-32bit.iso (ie Maya with xfce) as a live CD. Worked perfectly. Very impressed, Mint is so much better than anything else. I only recently found out about xfce and LXDE meaning that I could run Mint even on my low spec computer.

2. During the install no problems.

3. After restart got an error message about the X server, probably the same as what I copied down later. Computer would not go any further and I had to turn it off.

4. I restarted with the mint livedvd in the dvd drive, but from the menu I chose the option to restart from the hard drive. I thought this might fix things perhaps. Everything worked OK, no problems.

5. I removed the DVD and restarted as normal. No problems, everything OK.

6. I shut the computer down and restarted. Everything seemed to be OK and I used Firefox a little. But when I closed Firefox I got just black instead of the Mint wallpaper. And when I right-clicked on the dektop nothing happens - no menu.

7. Restarted computer again but got this long error message again (copied it by hand so have left bits out and may have mistakes):

"Failed to start the X server
X. Org X Server 1.11.3
Protocol version 11, revision 0
Buildoperating system: Linux
user l700cxe 3.2.0-23-generic#36-Ubuntu SMP Tue Apr 10 20:31:14 UTC 2012 i686
Kernal command line: BOOT_IMAGE=/boot/vmlinu-3.2.0 -23-generic root=UUID=61e74ac0-68ff-45ff-b8a0-36-fa9c2bc055 vo quiet splash vt.handoff=7
xorg-server 2:1.11.4-0ubuntu10

8. Restarted. It worked OK but had just black where the mint wallpaper should be. I allowed hundreds of updates to be done (there were two updates that asked me if I wanted to update some sort of a script or keep the old one - I kept the old one both times - do not know if that was right) .

9. Restarted again. Seems to work OK but just black where the mint wallpaper should be, and nothing happens when I right-click on the black. Am using it to write this posting.

Please tell me what I need to do to fix things? Please give step by step instructions as I am a complete Linux newby.

I will not mind if this is too technical for the newbie section and it is transferred to some other group on the forum.


User avatar
Level 10
Level 10
Posts: 3029
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Newbie: after installation, "Failed to start the X serve

Postby nomko » Thu Sep 19, 2013 7:56 am

Here you can get Linux drivers for your Matrox VGA card. Try to install the correct driver. Hopefully this will correct your problem.

Level 4
Level 4
Posts: 361
Joined: Sat Aug 10, 2013 8:20 am

Re: Newbie: after installation, "Failed to start the X serve

Postby bobafetthotmail » Mon Sep 23, 2013 6:33 am

Theoretically the driver should be called xserver-xorg-video-mga, and is already there on anything based on Debian. I have it on my Mint 15 xfce even if this is a netbook with a GMA 3150.

Something that might help is setting the right video kernel parameters at boot.

This tutorial. Instead of Tab key it might be "e"

Otherwise you can boot from the live-cd and modify the grub file you find in /etc/default.

The kernel parameters are set inside the "" of GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (quiet and splash are boot parameters)

You will have to try various things and see for yourself though.

A parameter worth a shot is mga.modeset=0 that should force it to use the driver for mga cards like Matrox Millennium I/II,Mystique, G100,G200,G400,G450,G550,G550 Dual-DVI .

In case it didn't work, "nomodeset" should save you. It's supposed to force the load of the legacy VESA driver that should be able to operate any card still functional on the planet. More or less.

Level 1
Level 1
Posts: 1
Joined: Mon Oct 14, 2013 10:48 am

Re: Newbie: after installation, "Failed to start the X serve

Postby maxdev137 » Mon Oct 14, 2013 11:17 am

This might help. I testing Mint 13 32-bit on an old Asus TUSL2 m/b (Pentium III-S)
with a Matrox M400 or 450 installed. It would not start the X server. I got rid of "xforcevesa" and "nomodeset"
by editing the grub2 menuentry at boot time. (hit "e" for edit). The problem is that the vesa framebuffer (vesafb) conflicts with the matrox driver which wants its own frambuffer.
Here's where i found the solution:
at Comments 39-41

Hope iit helps. Look at /var/log/Xorg.0.log to see what happening. Let me know.

Return to “XFCE”

Who is online

Users browsing this forum: No registered users and 1 guest