Root password live USB [SOLVED]

Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 48
Joined: Sat Dec 12, 2009 3:02 pm

Root password live USB [SOLVED]

Postby DaTorbiera » Fri Jan 10, 2014 7:01 am


The other day I created a live USB with Mint 16 Xfce with persistence. Works like a charm. I set up the WiFi, my VPN, the works. I even managed to set up a second user account using adduser.

But now that I'm trying to repeat all of this on another USB, I can no longer run adduser unless as log on as root. But since I don't know the password for root on the live image I'm stuck. Does anyone know what the password is ? All the usual ones don't work.

Many thanks

Last edited by DaTorbiera on Mon Jan 05, 2015 10:42 am, edited 1 time in total.

Level 2
Level 2
Posts: 60
Joined: Mon Mar 15, 2010 5:43 pm

Re: Root password live USB

Postby wh7qq » Sat Jan 18, 2014 4:40 pm

You don't need the root password. Just do

Code: Select all

sudo su
in a terminal and you will become root. If you must have a root password, you can then do

Code: Select all

passwd root newpassword
(replace newpassword with your choice) but it will, of course, dissappear the next time you boot the live disk. Most commands will work by simply using

Code: Select all

preceding the command.

Level 1
Level 1
Posts: 3
Joined: Sun Dec 16, 2007 12:52 am

Re: Root password live USB

Postby ssfc72 » Tue Jun 03, 2014 6:26 am

Doesn't work running mint4win.
After typing in, sudo su, in Terminal, I get a response that the command is not allowed.

User avatar
Level 6
Level 6
Posts: 1476
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Root password live USB

Postby WinterTroubles » Tue Jun 03, 2014 6:39 am

The mint4win Windows installer was not able to reliably handle the size of the ISO images. It was therefore removed and isn't available in Linux Mint 16.
From the release notes for mint 16 xfce :?:

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

Return to “XFCE”