Page 37 of 38

Re: gm10's Linux Mint Tools PPA

Posted: Tue May 05, 2020 1:28 pm
by oldgranola
Well boo. The kernel manager function isn't working for me. I'm on 5.4 series, got behind. Now I get "kernel unavailable, cannot build". So something I updated killed it I suppose. Back to UKUU I guess. too bad how sad.

Re: gm10's Linux Mint Tools PPA

Posted: Tue May 05, 2020 1:35 pm
by oldgranola
oldgranola wrote:
Tue May 05, 2020 1:28 pm
Well boo. The kernel manager function isn't working for me. I'm on 5.4 series, got behind. Now I get "kernel unavailable, cannot build". So something I updated killed it I suppose. Back to UKUU I guess. too bad how sad.
It worked for latest 5.6.x so ...maybe ...nevermind

Re: gm10's Linux Mint Tools PPA

Posted: Tue May 05, 2020 9:24 pm
by sleeper12
gittiest personITW wrote:
Fri Apr 03, 2020 3:39 am
I'm missing gm10.
Well, speaking of those missing, it seems that HAWR has vanished from here too. He helped a lot with wifi problems. Too bad, but folks come & go for various reasons I suppose.

Re: gm10's Linux Mint Tools PPA

Posted: Wed May 06, 2020 12:12 am
by smurphos
oldgranola wrote:
Tue May 05, 2020 1:35 pm
oldgranola wrote:
Tue May 05, 2020 1:28 pm
Well boo. The kernel manager function isn't working for me. I'm on 5.4 series, got behind. Now I get "kernel unavailable, cannot build". So something I updated killed it I suppose. Back to UKUU I guess. too bad how sad.
It worked for latest 5.6.x so ...maybe ...nevermind
Those kernels would be broken for UKUU aswell - the problem is upstream - the automatic build of this series is failing and has been for a while https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.4.38/
Build for amd64 failed (see BUILD.LOG.amd64):
linux-headers-5.4.38-050438_5.4.38-050438.202005051922_all.deb
*_amd64.deb

Re: gm10's Linux Mint Tools PPA

Posted: Wed May 06, 2020 2:20 pm
by oldgranola
smurphos wrote:
Wed May 06, 2020 12:12 am
oldgranola wrote:
Tue May 05, 2020 1:35 pm
oldgranola wrote:
Tue May 05, 2020 1:28 pm
Well boo. The kernel manager function isn't working for me. I'm on 5.4 series, got behind. Now I get "kernel unavailable, cannot build". So something I updated killed it I suppose. Back to UKUU I guess. too bad how sad.
It worked for latest 5.6.x so ...maybe ...nevermind
Those kernels would be broken for UKUU aswell - the problem is upstream - the automatic build of this series is failing and has been for a while https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.4.38/
Build for amd64 failed (see BUILD.LOG.amd64):
linux-headers-5.4.38-050438_5.4.38-050438.202005051922_all.deb
*_amd64.deb
Ah, got it . Thanks. So the Ubuntu 20 LTS series must be staying with 5.4.0.-xxxx then.

Re: gm10's Linux Mint Tools PPA

Posted: Thu May 07, 2020 12:27 am
by smurphos
oldgranola wrote:
Wed May 06, 2020 2:20 pm
Ah, got it . Thanks. So the Ubuntu 20 LTS series must be staying with 5.4.0.-xxxx then.
The Ubuntu 20 LTS kernel series is 5.4 but not the same 5.4 as provided by the mainline kernel series.
https://wiki.ubuntu.com/Kernel/MainlineBuilds
https://wiki.ubuntu.com/Kernel/FAQ#Kern ... support.3F

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 7:51 am
by OveS
Installed gm10 tools on Mint 20 beta (in VirtualBox), and a brief test implies it works normally.

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 8:20 am
by AndyMH
OveS wrote:
Mon Jun 15, 2020 7:51 am
Installed gm10 tools on Mint 20 beta (in VirtualBox), and a brief test implies it works normally.
The only caution I would add is that gm10 has been awol, at least on this forum, since Feb.

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 10:28 am
by t42
The end of the road sign. I just installed gm10's Tools on a LM20 Beta. At first it seems OK until the 1st check, then it's stuck in a 'checking updates' loop. The same issue was on Ubuntu 20.04. I'm still using gm10's Tools on Xubuntu 19.10 and it's working fine, but not on Xubuntu 20.04.
Anyway all of the above is of small importance compared with undefined gm10's status.

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 11:33 am
by AndyMH
Yes, would be nice to know if (s)he is okay. Has contributed a lot to this forum, helped me in the past :(

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 11:53 am
by Pjotr
t42 wrote:
Mon Jun 15, 2020 10:28 am
The end of the road sign. I just installed gm10's Tools on a LM20 Beta. At first it seems OK until the 1st check, then it's stuck in a 'checking updates' loop. The same issue was on Ubuntu 20.04. I'm still using gm10's Tools on Xubuntu 19.10 and it's working fine, but not on Xubuntu 20.04.
Yes, unfortunately it's the end of the road for gm10's tools on Ubuntu 20.04 and all that's built on that code base, including Mint 20.

But there is a glimmer of hope: gm10's mintupdate has been "adopted" by the developers of Bodhi Linux; his mintupdate is even present by default in one of its editions.

Currently, Bodhi is still based on Ubuntu 18.04, but it's upcoming new version will be based on Ubuntu 20.04. It's likely that the Bodhi devs will fix gm10's mintupdate themselves, for the new code base. If so, that fixed version might become useful for Ubuntu 20.04 and Linux Mint 20....

Re: gm10's Linux Mint Tools PPA

Posted: Mon Jun 15, 2020 2:34 pm
by gittiest personITW
gm10, hopefully, is fine. He/she has been active up till end of May (or has given someone else access), just not on these forums.
If it weren't considered rude to pm, I would just say 'Hi, and good to see you are still around' but privacy must be respected.
Although, I would suggest/ask him to go onto 11111 as 11000 is so last year.
Good luck.

Re: gm10's Linux Mint Tools PPA

Posted: Wed Jun 17, 2020 6:31 pm
by mnurolcay
t42 wrote:
Mon Jun 15, 2020 10:28 am
The end of the road sign. I just installed gm10's Tools on a LM20 Beta. At first it seems OK until the 1st check, then it's stuck in a 'checking updates' loop. The same issue was on Ubuntu 20.04. I'm still using gm10's Tools on Xubuntu 19.10 and it's working fine, but not on Xubuntu 20.04.
Anyway all of the above is of small importance compared with undefined gm10's status.
I removed it via ppa-purge, tried to revert all packages to default ones. But still have problem with Update Manager. "Remove/Downgrade foreign packages" function is not working. Just nothing happens after click. I got this error on terminal:

Code: Select all

 Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintSources/foreign_packages.py", line 241, in <module>
    foreign_browser = Foreign_Browser()
  File "/usr/lib/linuxmint/mintSources/foreign_packages.py", line 100, in __init__
    candidate_version = pkg.candidate.version
AttributeError: 'NoneType' object has no attribute 'version'

Re: gm10's Linux Mint Tools PPA

Posted: Wed Jun 17, 2020 6:35 pm
by ajgringo619
gittiest personITW wrote:
Mon Jun 15, 2020 2:34 pm
If it weren't considered rude to pm...
??? :roll:

Re: gm10's Linux Mint Tools PPA

Posted: Wed Jun 17, 2020 7:20 pm
by thx-1138
ajgringo619 wrote:
Wed Jun 17, 2020 6:35 pm
gittiest personITW wrote:
Mon Jun 15, 2020 2:34 pm
If it weren't considered rude to pm...
??? :roll:
...i had sent an extremely short one-liner (& partly humouristic i'd think) e-mail to gm10 at some point in early April i believe.
Just to let him know that he's been missed around here.
Since he does have an e-mail posted in public after all (2 actually), I also don't think that's rude by any means.
After all, he obviously has various e-mail accounts for different roles...
ie. worst case scenario, messages he doesn't care about, most likely simply end up to /dev/null :)

If i was to make a wild guess as to why...well, no, i won't make a guess.
That, i'd possibly find rude... :)

Re: gm10's Linux Mint Tools PPA

Posted: Wed Jun 17, 2020 7:46 pm
by ajgringo619
I find it necessary for a couple of reasons:
1) to get clarification from the admins/mods about something you've posted that was removed (no need for a public discussion)
2) to move a topic privately, especially if the original topic has been hijacked (which I've been guilty of many times)
3) to ask someone about an old post that needs to be updated (I did this asking about GPU passthrough with QEMU/KVM)

I'm certain there are others.

Re: gm10's Linux Mint Tools PPA

Posted: Thu Jun 18, 2020 11:04 am
by t42
mnurolcay wrote:
Wed Jun 17, 2020 6:31 pm
I removed it via ppa-purge, tried to revert all packages to default ones. But still have problem with Update Manager. "Remove/Downgrade foreign packages" function is not working. Just nothing happens after click.
Not sure which OS you are using. I had no problems to remove gm10's LMT from Linux Mint 20 in such an order
1. Software Sources > PPA > Remove
2. Software Sources > Maintenance > Remove packages not available from sources (this option may not be available due to your previous actions)
3. sudo apt update
4.

Code: Select all

sudo apt policy mintupdate
mintupdate:
  Installed: (none)
  Candidate: 5.6.7
  Version table:
     1:6.1.5~gm10 -1
        100 /var/lib/dpkg/status
     5.6.7 500
        500 http://packages.linuxmint.com ulyana/main amd64 Packages
        500 http://packages.linuxmint.com ulyana/main i386 Packages

Code: Select all

sudo apt install mintupdate
If no luck with the above options, just purge and install current version

Code: Select all

sudo apt-get purge --autoremove mintupdate

Re: gm10's Linux Mint Tools PPA

Posted: Fri Jun 19, 2020 3:13 am
by gittiest personITW
Very subtle gm.
Nice one to know you're 'around'.

Good luck.

Re: gm10's Linux Mint Tools PPA

Posted: Fri Jun 19, 2020 3:24 am
by t42
:D 8) :!:

Re: gm10's Linux Mint Tools PPA

Posted: Fri Jun 19, 2020 5:03 am
by gittiest personITW
thx-1138 wrote:
Wed Jun 17, 2020 7:20 pm
ajgringo619 wrote:
Wed Jun 17, 2020 6:35 pm
gittiest personITW wrote:
Mon Jun 15, 2020 2:34 pm
If it weren't considered rude to pm...
??? :roll:
...i had sent an extremely short one-liner (& partly humouristic i'd think) e-mail to gm10 at some point in early April i believe.
Just to let him know that he's been missed around here.
Since he does have an e-mail posted in public after all (2 actually), I also don't think that's rude by any means.
After all, he obviously has various e-mail accounts for different roles...
ie. worst case scenario, messages he doesn't care about, most likely simply end up to /dev/null :)

If i was to make a wild guess as to why...well, no, i won't make a guess.
That, i'd possibly find rude... :)
What I meant was - if gm wanted to be contacted, I am sure he/she would make it clear. Don't want to 'stalk' a valued member of the community.
A pm is all well and good in its place if you know what I mean.

Saying that - I don't want to be re-writing any rules/guidelines on pm's so its just my own personal thoughts on the matter.