flashplugin and pulseaudio

Archived topics about LMDE 1 and LMDE 2
enedene
Level 1
Level 1
Posts: 20
Joined: Wed Sep 08, 2010 3:46 pm

flashplugin and pulseaudio

Post by enedene »

Can you play music from flash player and from a local file with mplayer or anything else that uses pulseaudio?
As a test try running some mp3 and then see if you have sound in youtube videos while mp3 is playing.
If you go to sound preferences you'll see that all the applications except firefox use pulseaudio. There is obliviously some kind of conflict.
Also when I tried to reinstall the flashplugin-nonfree I got an error where I couldn't install it anymore, I've found this thread on that subject on Debian forums:
http://forums.debian.net/viewtopic.php?f=17&t=27314
Then I managed to install the flushplugin-mozilla plugin but the problem persists.
dawgdoc
Level 9
Level 9
Posts: 2743
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: flashplugin and pulseaudio

Post by dawgdoc »

I found THISpost that may resolve your issue. It begins
There is a widely known issue which is that MPD (Music player Daemon) and flash are conflicting which ends up that one of them won't have sound (the one which was started earlier). So if you want to run MPD and flash at the same time this Howto is just for you. =)
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim
enedene
Level 1
Level 1
Posts: 20
Joined: Wed Sep 08, 2010 3:46 pm

Re: flashplugin and pulseaudio

Post by enedene »

I was not aware that Linux Mint had this issue, I thought it was specific for LMDE. I've never had it on Ubuntu and Mint is based on Ubuntu, but LMDE is not.
Anyway, I solved the problem like I did on my Arch Linux main desktop, I removed the pulse audio completely and am using Alsa instead.
But it's good to know that there is a simple solution if someone else has this problem. Thank you.
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: flashplugin and pulseaudio

Post by blowtorch »

install

flashplugin-nonfree-extrasound

thats it enjoy
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: flashplugin and pulseaudio

Post by gotjazz »

that's already installed and I still have no sound. Also I don't even HAVE an /etc/mpd directory that's mentioned in the other thread
Image
Mozenrath
Level 4
Level 4
Posts: 209
Joined: Thu Jun 17, 2010 12:41 am

Re: flashplugin and pulseaudio

Post by Mozenrath »

Try installing libflashsupport.

http://packages.ubuntu.com/hardy/libflashsupport
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: flashplugin and pulseaudio

Post by blowtorch »

Mozenrath wrote:Try installing libflashsupport.

http://packages.ubuntu.com/hardy/libflashsupport

First off do not install ubuntu packages. Second that package is flashplugin-nonfree-extrasound in Debian! ... :wink:
User avatar
omenest
Level 1
Level 1
Posts: 30
Joined: Fri Sep 17, 2010 5:48 pm

Re: flashplugin and pulseaudio

Post by omenest »

Greetings,

In order to solve problem of mutually exclusive flash player/pulse audio please try this recipe:

Code: Select all

sudo touch /etc/asound.conf

Code: Select all

sudo gedit /etc/asound.conf
paste the following code in the file asound.conf:

Code: Select all

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
Save the file
Restart your PC

This procedure solves this outsanding bug report.

source:Ubuntu forums
MrD
Level 4
Level 4
Posts: 227
Joined: Wed Dec 09, 2009 8:34 am
Location: UK
Contact:

Re: flashplugin and pulseaudio

Post by MrD »

That 'seems' to have done the job for me! Needs to get into a sticky of 'things to do after fresh install' to bring the OS upto speed until it's fixed by update..
Dell Inspiron 1520 - T6570 2.1ghz C2D, 4 gigs ram, integrated Intel 965 GPU, Intel replacement wifi card.
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: flashplugin and pulseaudio

Post by blowtorch »

omenest wrote:Greetings,

In order to solve problem of mutually exclusive flash player/pulse audio please try this recipe:

Code: Select all

sudo touch /etc/asound.conf

Code: Select all

sudo gedit /etc/asound.conf
paste the following code in the file asound.conf:

Code: Select all

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
Save the file
Restart your PC

This procedure solves this outsanding bug report.

source:Ubuntu forums
Yep I can confirm that this works!
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: flashplugin and pulseaudio

Post by blowtorch »

STICKY this :mrgreen:
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: flashplugin and pulseaudio

Post by gotjazz »

oh yes!
Image
JayKay3000
Level 1
Level 1
Posts: 17
Joined: Fri Jun 04, 2010 11:58 am
Contact:

Re: flashplugin and pulseaudio

Post by JayKay3000 »

Thanks!

I was about to ask the same question till I read this.

Works fine now too.
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: flashplugin and pulseaudio

Post by gotjazz »

and again i request stickyness
Image
User avatar
damienpol
Level 1
Level 1
Posts: 6
Joined: Sun Oct 10, 2010 6:11 pm
Location: Santiago de Compostela, Spain.

Re: flashplugin and pulseaudio

Post by damienpol »

omenest wrote:Greetings,

In order to solve problem of mutually exclusive flash player/pulse audio please try this recipe:

Code: Select all

sudo touch /etc/asound.conf

Code: Select all

sudo gedit /etc/asound.conf
paste the following code in the file asound.conf:

Code: Select all

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
Save the file
Restart your PC

This procedure solves this outsanding bug report.

source:Ubuntu forums
Functions halfway, you hear clicks to play both flash and other
sound source
In a world without walls and fences, we need no WINDOWS and GATES.
User avatar
tdockery97
Level 14
Level 14
Posts: 5060
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: flashplugin and pulseaudio

Post by tdockery97 »

Thanks! Works for me too. :D
Mint MATE 20.1
User avatar
damienpol
Level 1
Level 1
Posts: 6
Joined: Sun Oct 10, 2010 6:11 pm
Location: Santiago de Compostela, Spain.

Re: flashplugin and pulseaudio

Post by damienpol »

I hear pops and uneven sound when playing from two sources (flash and audio file for example), someone else is happening?.
In a world without walls and fences, we need no WINDOWS and GATES.
User avatar
tdockery97
Level 14
Level 14
Posts: 5060
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: flashplugin and pulseaudio

Post by tdockery97 »

Nope. Mine is clear as a bell.
Mint MATE 20.1
Intio
Level 3
Level 3
Posts: 104
Joined: Tue Dec 01, 2009 2:16 pm

Re: flashplugin and pulseaudio

Post by Intio »

Thank you for this! Ever since I switched to LMDE my sound has always been 'flaky', in that any heavy CPU usage would always fragment and break up the sound output. Streaming online, if my mouse cursor so much as moved over an Ad, the sound would cut briefly. Heck - even the startup sound in LMDE would never play smoothly. This was all fine under Mint 9, so I has always assumed that the problem was in the Debian Multimedia repo: the one which VLC users complain about.

Now though, sound output has been restored back to what it was. If, for any reason, I cannot stream smoothe video; the sound is still unimpeeded. A great improvement.
Asus Eee 701 Netbook - 2GB OCZ RAM
Debian Edition - Xfce
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: flashplugin and pulseaudio

Post by gotjazz »

uhm at the risk of seeming a bit spammy and annoying

I can only repeat that this needs stickying - every couple of days this thread needs linking because someone new starts another "sound not working" thread without having realized it's flash/pulse -related.
Image
Locked

Return to “LMDE Archive”