LMDE BREAKAGES - tracking TESTING

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

Hey guys and girls, I have now solved this one. Thanks go to zerozero for his efforts once again, because I would have just accepted that nvidia-kernel-dkms was broken if he hadn't had success with it, but it isn't broken at all, it just needs reinstalling :D

I did this from a terminal login so I don't know if it can be done from synaptic, but it probably can. My steps were:

1) Boot into a terminal login of the 3.0 kernel.

2) su to root

3)

Code: Select all

apt-get remove nvidia-kernel-dkms nvidia-glx
4) Reboot - might not be necessary but that is what I did anyway.

5) Repeat steps 1 and 2.

6)

Code: Select all

apt-get install nvidia-kernel-dkms nvidia-glx
7) Reboot - definitely necessary this time.

I end up with the same version of these two programs:
Start-Date: 2011-08-10 10:35:33
Commandline: apt-get remove nvidia-kernel-dkms
Remove: nvidia-kernel-dkms:i386 (275.21-1), nvidia-glx:i386 (275.21-1)
End-Date: 2011-08-10 10:36:04

Start-Date: 2011-08-10 10:38:55
Commandline: apt-get install nvidia-kernel-dkms nvidia-glx
Install: nvidia-kernel-dkms:i386 (275.21-1), nvidia-glx:i386 (275.21-1)
End-Date: 2011-08-10 10:39:37
But now it works and I have the 3.0 kernel with the Nvidia driver.

Go figure :?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Gerd50
Level 5
Level 5
Posts: 734
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by Gerd50 »

Thank you viking,

for me it looked like the update could work today. But no, the same error as yesterday. I could dokument the error message:

Code: Select all

Examining /etc/kernel/postinst.d
run parts: executing /etc/kernel/postinst.d/dkms 3.0.0-1-686-pae
dkms.conf: Error! No 'Built_Module_Name' directive specified for record #0 
I'll try your fix at once, am sure it will work :)
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1

zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by zerozero »

Thank you viking for your perseverance and from saving me from writing the longest and most tedious post ever with never-ending apt-cache policies :lol:
Image

[ bliss of ignorance ]

spacebison
Level 1
Level 1
Posts: 4
Joined: Wed Apr 27, 2011 2:11 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by spacebison »

Thanks viking777, that seems to have done the trick.

ThomasK
Level 1
Level 1
Posts: 1
Joined: Thu Aug 11, 2011 6:16 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by ThomasK »

Thank you, viking777, that also did the trick for me.

Running a dist-upgrade this morning still broke my nvidia 275.x.x-proprietary-driver. But now I have kernel 3.0 and the nvidia-driver 275.21-1 running together, smoothly. :-))

zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by zerozero »

today i needed some "dpkg kung-fu" to install gstreamer0.10-plugins-bad :lol:
the error is

Code: Select all

Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
configured to not write apport reports
                                      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
and the dpkg magic

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
(Reading database ... 259263 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
Setting up gstreamer0.10-plugins-bad (0.10.22-3) ...
Processing triggers for libglib2.0-0 ...
Image

[ bliss of ignorance ]

allart
Level 1
Level 1
Posts: 1
Joined: Thu Aug 11, 2011 6:53 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by allart »

works, tnx

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

Have a go at

Code: Select all

 sudo dpkg-reconfigure libcurl3-gnutls
Then try again.

Funny thing is, all these updates went through without any intervention on my system :?

Edit. Erm? I replied to a post here but it seems to have disappeared while I was typing. Never mind.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by mads »

viking777 wrote:Have a go at

Code: Select all

 sudo dpkg-reconfigure libcurl3-gnutls
Edit. Erm? I replied to a post here but it seems to have disappeared while I was typing. Never mind.
@viking777, thanks, it was my post.

I got a dependency problem (libcurl3-gnutls) after running the command suggested by zerozero.
However, running 'apt-get clean' followed by 'apt-get dist-upgrade' did the magic.

zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by zerozero »

@mads, afaik, you're tracking latest, can you please check what v. libcurl3-gnutls is in your system?

Code: Select all

libcurl3-gnutls:
  Installed: 7.21.7-1
  Candidate: 7.21.7-1
  Version table:
 *** 7.21.7-1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
we may start having this kind of issues (dependencies problems) with multimedia repo in latest and incoming
Image

[ bliss of ignorance ]

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by mads »

zerozero wrote:@mads, afaik, you're tracking latest, can you please check what v. libcurl3-gnutls is in your system?
I have version 7.21.7-1, tracking to 'testing'. But you are quite right. I was tracking to 'latest' until a few days ago, enjoying a stable system.
Eventually, I got bored and started to miss the creative process of pointing to 'testing'. And here I am now. :lol:

By the way, I am running 32-bit, so I had to run 'dpkg -i --force-overwrite ..._i386.deb', and here is the error I got:

Code: Select all

mads@stua2-linux ~ $ sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
(Reading database ... 150517 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: warning: overriding problem because --force enabled:
 trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-bad:
 gstreamer0.10-plugins-bad depends on libcurl3-gnutls (>= 7.16.2-1); however:
  Package libcurl3-gnutls is not configured yet.
dpkg: error processing gstreamer0.10-plugins-bad (--install):
 dependency problems - leaving unconfigured
Processing triggers for libglib2.0-0 ...
Errors were encountered while processing:
 gstreamer0.10-plugins-bad

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

More gstreamer problems (12 Aug).

Today gstreamer0.10-plugins-ugly removes gstreamer0.10-lame. Now, gstreamer0.10-lame does this:
Description: GStreamer lame plugin
Lame is a program which can be used to create compressed audio files. (Lame
aint MP3 encoder). These audio files can be played back by popular mp3
players such as mpg123.
So if compressing audio files is something you do with your computer then you might want to pin gstreamer0.10-plugins-ugly until the 'lame' plugin catches up with it.

NB Of course you could always compress your files into .ogg instead then you won't need the plugin :) . But your files won't play on an mp3 player then :(
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by xircon »

viking777 wrote:More gstreamer problems (12 Aug).

Today gstreamer0.10-plugins-ugly removes gstreamer0.10-lame. Now, gstreamer0.10-lame does this:
Description: GStreamer lame plugin
Lame is a program which can be used to create compressed audio files. (Lame
aint MP3 encoder). These audio files can be played back by popular mp3
players such as mpg123.
So if compressing audio files is something you do with your computer then you might want to pin gstreamer0.10-plugins-ugly until the 'lame' plugin catches up with it.

NB Of course you could always compress your files into .ogg instead then you won't need the plugin :) . But your files won't play on an mp3 player then :(
Installed OK here (10:30am BST)
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

xircon wrote:

Installed OK here (10:30am BST)
It's crazy isn't it. Yesterday when everyone else was having problems with gstreamer, I had none - now it seems to be the other way around. :?

It is not a big deal for me, I can live without a lame plugin for a while.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Gerd50
Level 5
Level 5
Posts: 734
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by Gerd50 »

No problems with gstreamer here. Yesterday not and today not. I don't know, why i have luck with it :)
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

Maybe I have got a different version of something. Here is the conflict:

Code: Select all

aptitude why-not gstreamer0.10-lame
iB  gstreamer0.10-plugins-ugly Conflicts gstreamer0.10-lame
Here are the versions:

Code: Select all

apt-cache policy gstreamer0.10-lame
gstreamer0.10-lame:
  Installed: (none)
  Candidate: 0.10.18-0.1

Code: Select all

apt-cache policy gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly:
  Installed: 0.10.18-3
  Candidate: 0.10.18-3
The -lame plugin certainly doesn't have the same version number as the -ugly plugin. I don't know if that is the reason for the conflict?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Gerd50
Level 5
Level 5
Posts: 734
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by Gerd50 »

Yes, that's it.

Code: Select all

 ~ $ apt-cache policy gstreamer0.10-lame
gstreamer0.10-lame:
  Installiert: 0.10.18-0.1
  Kandidat:    0.10.18-0.1
  Versionstabelle:
 *** 0.10.18-0.1 0
        500 http://www.debian-multimedia.org/ testing/main i386 Packages
        100 /var/lib/dpkg/status
~ $ apt-cache policy gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly:
  Installiert: 0.10.18-1
  Kandidat:    0.10.18-3
  Versionstabelle:
     0.10.18-3 0
        500 http://ftp.debian.org/debian/ testing/main i386 Packages
 *** 0.10.18-1 0
        100 /var/lib/dpkg/status
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by viking777 »

Gerd50 wrote:Yes, that's it.

Code: Select all

 ~ $ apt-cache policy gstreamer0.10-lame
gstreamer0.10-lame:
  Installiert: 0.10.18-0.1
  Kandidat:    0.10.18-0.1
  Versionstabelle:
 *** 0.10.18-0.1 0
        500 http://www.debian-multimedia.org/ testing/main i386 Packages
        100 /var/lib/dpkg/status
~ $ apt-cache policy gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly:
  Installiert: 0.10.18-1
  Kandidat:    0.10.18-3
  Versionstabelle:
     0.10.18-3 0
        500 http://ftp.debian.org/debian/ testing/main i386 Packages
 *** 0.10.18-1 0
        100 /var/lib/dpkg/status
So did you pin the -ugly upgrade (18.1 to 18.3) as I suggested in my original post? Or was it not offered as part of the upgrade? (I am using synaptic to upgrade btw not mintupdate maybe that is the difference?).
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Gerd50
Level 5
Level 5
Posts: 734
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by Gerd50 »

viking wrote:

So did you pin the -ugly upgrade (18.1 to 18.3) as I suggested in my original post?
No, i didn't. I did the same update on my Debian testing system now. - ugly 18.3 was offered, but hold back from install
automatically.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1

zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking Testing - read here first-10/

Post by zerozero »

well, i saw the conflict this morning (5 a.m. :shock: just before go to work) and now 4 p.m it's still here (same as viking)

Code: Select all

Calculating upgrade... Done
The following packages will be REMOVED:
  gstreamer0.10-lame
The following packages will be upgraded:
  gstreamer0.10-plugins-really-bad gstreamer0.10-plugins-ugly liblzo2-2
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 policykit-1
7 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 1,411 kB of archives.
After this operation, 819 kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
amadeu@amadeu ~ $ apt-cache policy gstreamer0.10-lame
gstreamer0.10-lame:
  Installed: 0.10.18-0.1
  Candidate: 0.10.18-0.1
  Version table:
 *** 0.10.18-0.1 0
        500 http://www.debian-multimedia.org/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
amadeu@amadeu ~ $ apt-cache policy gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly:
  Installed: 0.10.18-1
  Candidate: 0.10.18-3
  Version table:
     0.10.18-3 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
 *** 0.10.18-1 0
        100 /var/lib/dpkg/status
amadeu@amadeu ~ $ 
post-edit: now i see why the differences here :lol: if you do apt-get upgrade this is what you get

Code: Select all

Reading state information... Done
The following packages have been kept back:
  gstreamer0.10-plugins-ugly
The following packages will be upgraded:
  gstreamer0.10-plugins-really-bad liblzo2-2 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 policykit-1
6 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 924 kB of archives.
After this operation, 717 kB disk space will be freed.
Do you want to continue [Y/n]? 
Image

[ bliss of ignorance ]

Locked

Return to “LMDE Archive”