LMDE BREAKAGES - tracking TESTING

Archived topics about LMDE 1
Locked
User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by kmb42vt » Tue Apr 12, 2011 8:21 pm

aljoriz wrote:did the latest update borked the mint fortune?

When I open the terminal I get this error:
/usr/bin/mint-fortune: line 35: [: ==: unary operator expected
Yup, got the same thing here after yesterday's update. Same error. After looking at 'mint-fortune' file I changed line 35 from this:

Code: Select all

if [ $showfortunes == "true" ]; then
To this:

Code: Select all

if [ $showfortunes="true" ]; then
I'm no programmer to be sure but I can troubleshoot pretty well and the ' == ' just didn't look right. Either way, I got my fortunes back in the terminal. HTH :D (If anyone sees a better way of doing this, please speak up)
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by kmb42vt » Tue Apr 12, 2011 8:28 pm

barryp wrote:@tjw Thanks mate, I didn't do anything like that, I actually used MU! (Tempted to go back to sudo && tho).

It is actually working, I just noticed some new strange messages which I've searched for but can't find in the logs.

Later. I have the broken fortune cookie! :( Same error msg as above. No Husse!
I fixed the problem with fortunes in my LMDE. See the following comment:

http://forums.linuxmint.com/viewtopic.p ... 80#p407906
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

vincent
Level 8
Level 8
Posts: 2217
Joined: Tue Feb 09, 2010 4:10 am

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by vincent » Tue Apr 12, 2011 8:33 pm

kmb42vt wrote:

Code: Select all

if [ $showfortunes == "true" ]; then
To this:

Code: Select all

if [ $showfortunes="true" ]; then
I'm no programmer to be sure but I can troubleshoot pretty well and the ' == ' just didn't look right.
A side note: in many (most, I dare say) programming languages, "=" is an assignment operator (e.g. it assigns a value or a number to the variable on the left), while "==" is used in if/else and other control statements in general to test a certain condition, e.g. whether or not the statement is true or false (and so the use of "==" is probably correct here). I'm not sure if this is the underlying cause of the problem though...

Edit: the reason that this hack will work is because you're manually assigning a value of "true" to $showfortunes, which causes it to execute that if/then block.
Last edited by vincent on Tue Apr 12, 2011 8:51 pm, edited 1 time in total.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm

User avatar
Roken
Level 5
Level 5
Posts: 741
Joined: Fri Nov 19, 2010 4:55 pm
Location: Warrington, UK

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by Roken » Tue Apr 12, 2011 8:47 pm

The problem is that there is no longer a key in gconftool /desktop/linuxmint/terminal and so show_fortunes cannot be set.

There is still a key /desktop/gnome/applications/terminal and so you could set show_fortunes there and change the test in the script. Alternatively, comment out the whole test from if [-x gconftool-2]...to the second fi and add show_fortune at the end. All the test does is check if there is a user preference set in gconftool to show or hide the fortunes, so it won't hurt.
Last edited by Roken on Tue Apr 12, 2011 8:52 pm, edited 2 times in total.
Kernel Linux Tex 4.8.13-1-ARCH (64 bit) xfce , burg
Arch
GTX680 4Gb
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz
8Gb RAM

vincent
Level 8
Level 8
Posts: 2217
Joined: Tue Feb 09, 2010 4:10 am

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by vincent » Tue Apr 12, 2011 8:49 pm

romanybob wrote:The 2.6.38 update initially knocked out my wifi (rt2870ste.) Had rt2800usb, rt2800lib, rt2x00usb & rt2x00lib all blacklisted to prevent clash with last kernel. But when doing 'lsmod | grep rt2' got nothing? Un-blacklisted the whole lot & hot plugged. Wifi is now working but signal has dropped to 90% & speed loss?? Still no rt2870ste driver only rt2800/rt2x00. Tried to reinstall 'firmware-ralink' via Synaptic (then with aptitude) no joy... :?
Can anyone offer any insight or info. :?:
amina wrote:romanybob, this may be related to your problem? http://osdir.com/ml/debian-bugs-dist/20 ... 06023.html

I always needed the rt2860sta driver and always had problems getting it to work with 2.6.32. Now, the new kernel supports my wifi without tweaking. But I just checked and rt2860sta is not loaded :shock: But I have no problem with the connection despite this.
The rt2860sta/rt2870sta/rt3070sta/rt3090sta drivers have always resided in the staging section of the mainline kernel, which houses drivers that are still being tested and have no guarantees of stability/functionality (and because of this, may be removed from the kernel at any time). The kernel devs recommend the use of non-staging drivers whenever possible, and recently the rt2x00 series of drivers have been marked as "stable" and have been used as the preferred set of drivers to manage Ralink wireless cards on Linux. The rt2x00 drivers have improved enough that Debian no longer distributes the Ralink staging drivers with its kernel.

For me, rt2x00 is actually more stable, and doesn't cause random suspend lockups that I've experienced with rt2860sta in recent kernels. And it looks like I'm not the only one who has had success with rt2x00. ;)

If you insist on using Ralink's staging drivers though, go here and download and compile the drivers yourself: http://www.ralinktech.com/support.php?s=2
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by kmb42vt » Tue Apr 12, 2011 8:53 pm

vincent wrote:
kmb42vt wrote:

Code: Select all

if [ $showfortunes == "true" ]; then
To this:

Code: Select all

if [ $showfortunes="true" ]; then
I'm no programmer to be sure but I can troubleshoot pretty well and the ' == ' just didn't look right.
A side note: in many (most, I dare say) programming languages, "=" is an assignment operator (e.g. it assigns a value or a number to the variable on the left), while "==" is used in if/else and other control statements in general to test a certain condition, e.g. whether or not the statement is true or false (and so the use of "==" is probably correct here). I'm not sure if this is the underlying cause of the problem though...
Thanks for pointing that out. Just to test it out I added the second equals sign but left out the spaces ahead and behind. The fortunes are still there in terminal. If the spaces before and after the '==' are added back in the fortunes are no longer there and the error reappears. Also, like Roken says:
The problem is that there is no longer a key in gconftool /desktop/linuxmint/terminal and so show_fortunes cannot be set.

There is still a key /desktop/gnome/applications/terminal and so you could set show_fortunes there and change the test in the script. Alternatively, comment out the whole test from if [-x gconftool-2]...to the second fi and add show_fortune at the end. All the test does is check if there is a user preference set in gconftool to show or hide the fortunes, so it won't hurt.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

User avatar
dawgdoc
Level 9
Level 9
Posts: 2719
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by dawgdoc » Tue Apr 12, 2011 9:01 pm

kmb42vt wrote:Thanks for pointing that out. Just to test it out I added the second equals sign but left out the spaces ahead and behind. The fortunes are still there in terminal. If the spaces before and after the '==' are added back in the fortunes are no longer there and the error reappears. Also, like Roken says:
Thanks, kmb

I took the spaces out (the only change I made) and that restored regular fortunes and Husse Quotes.
Image

SYSTEM: Compaq Presario CQ62 -- Mint 17 Cinnamon
READING: Little Brother by Cory Doctorow

User avatar
Roken
Level 5
Level 5
Posts: 741
Joined: Fri Nov 19, 2010 4:55 pm
Location: Warrington, UK

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by Roken » Tue Apr 12, 2011 9:03 pm

It should be noted that even after changing the syntax of the test, the script is still technically broken because it's testing a non-existent variable.
Kernel Linux Tex 4.8.13-1-ARCH (64 bit) xfce , burg
Arch
GTX680 4Gb
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz
8Gb RAM

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by kmb42vt » Tue Apr 12, 2011 9:18 pm

Roken wrote:It should be noted that even after changing the syntax of the test, the script is still technically broken because it's testing a non-existent variable.
True. gconf2 comes directly from Debian testing so I'm wondering if LMDE had it's own modified gconf2 that was recently replaced during an update. Can't remember if it was or not and I may be way off base here anyway.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

dakdikmen
Level 1
Level 1
Posts: 1
Joined: Tue Apr 12, 2011 11:14 pm

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by dakdikmen » Tue Apr 12, 2011 11:26 pm

/usr/bin/mint-fortune: line 35: [: ==: unary operator expected
The missing value is pretty easy to add with the command line tool 'gconftool-2'.
Enable the funny fortune messages:
bash> gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "true"

Disable the messages:
bash> gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "false"

-David

craig10x
Level 7
Level 7
Posts: 1575
Joined: Fri Jul 03, 2009 12:44 pm

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by craig10x » Wed Apr 13, 2011 2:21 am

I was just curious...but does anyone know if debian is aware of all the breakages being caused on many (not all) people's systems since they sent down this new kernel in debian testing?

Has there also been a lot of reports about this on the debian forums as well?

oe6tkt
Level 1
Level 1
Posts: 2
Joined: Fri Dec 31, 2010 4:13 pm

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by oe6tkt » Wed Apr 13, 2011 3:34 am

dakdikmen wrote:
/usr/bin/mint-fortune: line 35: [: ==: unary operator expected
The missing value is pretty easy to add with the command line tool 'gconftool-2'.
Enable the funny fortune messages:
bash> gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "true"

Disable the messages:
bash> gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "false"
As summary:
I got this message in German language (German installation)
/usr/bin/mint-fortune: Zeile 35: [: ==: Einstelliger (unärer) Operator erwartet.
To retain the fortune, I did these steps:
1.) Changing line 35 with

Code: Select all

sudo nano /usr/bin/mint-fortune
from

Code: Select all

if [ $showfortunes == "true" ]; then
to

Code: Select all

if [ "$showfortunes" == "true" ]; then
2.) Activating the fortune for each user ...

Code: Select all

 gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "true"
for "root":

Code: Select all

sudo gconftool-2 --set --type bool /desktop/linuxmint/terminal/show_fortunes "true"
Now everthing is back;
But:
Will there be a setting inside Mint menu - mintConfig, German lang.: "Kontrollzentrum" to switch on/off this parameter?

- Thomas Kuschel
Last edited by oe6tkt on Wed Apr 13, 2011 9:55 am, edited 2 times in total.

barryp
Level 2
Level 2
Posts: 55
Joined: Wed Sep 24, 2008 5:14 am

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by barryp » Wed Apr 13, 2011 5:46 am

"And a lot of times it did not work \
| when it should have and the other way |
| round sometimes" |
| |
\ Husse May 1 2007
@tjh & kmb thanks again!

When I entered
sudo gedit /usr/bin/mint-fortunes
I got lots of
(gedit:2641): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.BFLVTV': No such file or directory
What's that mean?

aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by aljoriz » Wed Apr 13, 2011 9:09 am

In case you don't know how to over write files in nano you can also use

Code: Select all

sudo gedit /usr/bin/mint-fortune
btw can anyone tell me whats the save command in Nano?

romanybob
Level 1
Level 1
Posts: 6
Joined: Fri Oct 29, 2010 4:58 pm

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by romanybob » Wed Apr 13, 2011 10:10 am

amina wrote:romanybob, this may be related to your problem? http://osdir.com/ml/debian-bugs-dist/20 ... 06023.html

I always needed the rt2860sta driver and always had problems getting it to work with 2.6.32. Now, the new kernel supports my wifi without tweaking. But I just checked and rt2860sta is not loaded :shock: But I have no problem with the connection despite this.
vincent wrote:The rt2860sta/rt2870sta/rt3070sta/rt3090sta drivers have always resided in the staging section of the mainline kernel, which houses drivers that are still being tested and have no guarantees of stability/functionality (and because of this, may be removed from the kernel at any time). The kernel devs recommend the use of non-staging drivers whenever possible, and recently the rt2x00 series of drivers have been marked as "stable" and have been used as the preferred set of drivers to manage Ralink wireless cards on Linux. The rt2x00 drivers have improved enough that Debian no longer distributes the Ralink staging drivers with its kernel.

For me, rt2x00 is actually more stable, and doesn't cause random suspend lockups that I've experienced with rt2860sta in recent kernels. And it looks like I'm not the only one who has had success with rt2x00. ;)

If you insist on using Ralink's staging drivers though, go here and download and compile the drivers yourself: http://www.ralinktech.com/support.php?s=2
Thank you amina & vincent, exactly what I needed :D :wink:

oe6tkt
Level 1
Level 1
Posts: 2
Joined: Fri Dec 31, 2010 4:13 pm

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by oe6tkt » Wed Apr 13, 2011 10:39 am

aljoriz wrote: btw can anyone tell me whats the save command in Nano?
Ctrl-O for save, Ctrl-X for exit
- Thomas

rikstation
Level 1
Level 1
Posts: 2
Joined: Fri Mar 25, 2011 11:40 am

Re: LMDE BREAKAGES - read here first - Update 12 april 2011

Post by rikstation » Wed Apr 13, 2011 1:15 pm

kmb42vt wrote: Yup, got the same thing here after yesterday's update. Same error. After looking at 'mint-fortune' file I changed line 35 from this:

Code: Select all

if [ $showfortunes == "true" ]; then
To this:

Code: Select all

if [ $showfortunes="true" ]; then
I'm no programmer to be sure but I can troubleshoot pretty well and the ' == ' just didn't look right. Either way, I got my fortunes back in the terminal. HTH :D (If anyone sees a better way of doing this, please speak up)
This done the trick for me too, Many Thanks

sgosnell
Level 5
Level 5
Posts: 684
Joined: Fri Sep 10, 2010 9:32 pm
Location: Baja Oklahoma

Re: LMDE BREAKAGES - read here first - Update 12 april 2011

Post by sgosnell » Wed Apr 13, 2011 3:41 pm

@craig10x: The kernel has nothing to do with gconf2 and fortunes. The fortune thing is a Mint addition, and it's up to the Mint devs to fix that. It's possible to add the fortunes to any distro, but AFAIK only Mint adds them by default. As for breakages actually caused by the kernel, yes, there Debian bugs filed by many people, far more than for Mint, because the number of Debian users is orders of magnitude larger than Mint users. With any breakage, one has to analyze the actual root source, be it the kernel, an individual package, scripts from a distro, or something else. If you want to report bugs in Debian, install the reportbug package and it will lead you by the hand doing it.
Asus eee-pc 900 w/ 32GB SSD.

barryp
Level 2
Level 2
Posts: 55
Joined: Wed Sep 24, 2008 5:14 am

Re: LMDE BREAKAGES - read here first - Update 12 april 2011

Post by barryp » Wed Apr 13, 2011 4:31 pm

Hi I reported an unusual message during boot - here it is:
rpcbind: Cannot open '/var/run/rpcbind/rpcbind.xdr' file for reading, errno 2
(No such file or directory)
It's a known Debian bug but it is not a problem, details here for those who are interested.
http://www.mail-archive.com/debian-bugs ... 88978.html

aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: LMDE BREAKAGES - read here first - Update 30 mar 2011

Post by aljoriz » Wed Apr 13, 2011 7:09 pm

oe6tkt wrote:
aljoriz wrote: btw can anyone tell me whats the save command in Nano?
Ctrl-O for save, Ctrl-X for exit
- Thomas
Thank you!!!!

Locked

Return to “LMDE 1 Archive”