gtkpod and xmms2

Forum rules
Before you post please read how to get help
User avatar
Level 1
Level 1
Posts: 17
Joined: Mon Jun 04, 2007 7:41 pm
Location: Wellington, New Zealand

gtkpod and xmms2

Postby crossfire139 » Fri Nov 07, 2008 8:17 pm

Old Compaq Evo N115 originally running Win XP Pro. Would take 30min+ to start up and run really slowly despite cleanout and defrag etc. In other words was practically useless.
Recently dumped Win and installed LM 5 Fluxbox CE and the old dog has been given a new lease of life.
I'm trying to educate the family about Linux and am trying to get my son to use his ipod with gtkpod.
I'm no Linux expert however, and am having a few problems getting tracks to play in gtkpod and am fast losing credibility.
I installed gtkpod using synaptic and used grip to rip tracks from CDs. All good so far.
When he tries to play tracks in gtkpod however, it returns an error saying that xmms cannot be found.
I've done a bit of research and installed xmms2 using synaptic but still no luck.
I have edited the preferences in gtkpod to get "Play now" to point at what I thought was xmms but although the error message has gone, nothing happens.
Am I on the right track and where would synaptic install xmms to by default?
I get the feeling I have "Play now" pointing to the wrong place.
I've also tried to get "Play now" to use gmpc and while a gmpc window opens, no music plays.
Any advice much appreciated.


Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: gtkpod and xmms2

Postby Husse » Wed Nov 12, 2008 7:27 am

where would synaptic install xmms to by default?

Probably /usr/bin
Use " which xmms " or " sudo updatedb " followed by " locate -i xmms "
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Others”